Forum Clubic

Encodage -> le son se décale progressivement !

:stuck_out_tongue:
Alors voila, ca fait deja qq tps que j’ai ce problème : losrque j’encode un gros et long fichier (+ de 30min) en DivX ou Xvid, le son se décale de la vidéo mais ceic progressivement : au début et jusqu’au 5/10 premieres miutes, aucun pbs, mais ensuite, il va se décaler de + en + pour attednre parfois un décalage de 15/25sec apres 1h de la vidéo… A quoi ce pb est-il du ?
J’encoe avec la derniere version de VirtualDub.
merci :jap:

Edit : je dit qu’il y a ce pb avec les long fichier, mais jme doute bien qu’il y a le mm pb avec les fichier + court (5min), mais ce n’est pas encore ‘visible’ à l’écoute.

C’est quand tu relis sur une platine que cela décale ?? sinon c’est parfois parce que tu encodes en VBR non CBR (constant et vairous bitrate) que cela décale regardes en CBR

ou bien le fait de ne pas respecter le taux d’échantillonnage de l’audio ( si recompression audio ) pourrait provoquer un tout petit décalage mais à l’échelle du dixième de seconde, mais à ce point :??:

J’avais vu cette astuce je ne sais plus où.
Je ne peux pas te dire si ça marche, mais cela ne coûte rien d’essayer.

LE DECALAGE AUGMENTE PROGESSIVEMENT AU FIL DU TEMPS :

Réglez l’onglet “Video” sur “Direct Sream Copy”, puis allez dans l’onglet “Audio”, et vérifiez qu’il est sur “AVI Audio” ainsi que sur “Direct Stream Copy”.
Ensuite, toujours dans “Audio”, ouvrez le menu “Interleaving” et paramétrez les options comme suit :

Preload = 500 ms
Interleave audio every = 500 ms
Delay audio track by = 0 ms

Pour finir, revenez dans “File” et “Save as AVI”…

Slaut,
Merci pour vos réponse. Donc pour VBR ou CBR, faudrait que je vérifie. Et j’essaierai ta méthode sovkipeu :wink:

Alors, pour la méthode de sovkipeu, j’ai testé sur 2 vidéo de 10min et de 40min. Sur la vidéo de 10min, c’est un peu mieux, car le son comencé a etre décalé des 1/2seconde vers les 7/8min ; avec cette méthode, c’est rpesque nikel. Par contre, sur la vidéo de 40min, j’ai toujours un bon décalage de 15/20min pres de 40min.
Euh je précise que ces tests sont fait sur des programmes TV enregistré avec K!TV (mais ca me le fait aussi qd jencode séparément).

Ah oui, et pour tkv93, ou c’est que je vois si je suis en CBR ou VBR ? Lors de la configuration du codec, j’ai mis manuellement 2048Kbts (c’est par la que la qualité est bonne, je sais c’est gros :smiley: ).

essaie avec cette méthode
http://forum.clubic.com/forum2.php?config=clubic.inc&post=20688&cat=12&cache=cache&sondage=0&owntopic=0&p=1&trash=0&subcat=

okay, ca a lair pas mal cette méthode :wink:
J’essaierai ca ce week.
Merci :jap: