Forum Clubic

Écran vert

salut à tous,
j’ai essayé le dernier live cd d’ubuntu, et j’ai un écran vert avec une faible résolution
j’essaye donc xubuntu et bubuntu, pareil
certaines autres distrib linux, me font aussi cet écran vert, comme la kaella
avec le logiciel virtualbox, cela marche bien par contre
en essayant madboxubuntu, basé sur la 7.10, ça marche très bien (tout comme le net, divx, mp3 d’ailleurs)
cela doit être une mauvaise détection au démmarrage de ma x1950 pro
mais comment faire ?
sinon, ça marche très bien avec mandriva one 2009, toutoulinux
merci de votre aide

Salut,

Comme tu dis, ça doit provenir des pilotes graphiques pré-installés. Ou peut être même qu’ils ne sont pas installé du tout. Comme par faire ça grâce à aptitude ou synaptic.

tu veux dire que je laisse s’installer tel quel, et ensuite je télécharge les pilotes
y a pas une manip avant le démarrage ?
sinon, j’ai essayé toutou linux, et en mode Xorg, ça bug
obligé de passer en mode vesa
pareil pour la slax
comment fait on pour passer en vesa avec ubuntu ?

Il faut éditer un fichier.
Soit grâce à la ligne de commande :

sudo nano /etc/X11/xorg.conf

Soit avec un éditeur :

sudo gedit /etc/X11/xorg.conf

Ensuite, à la ligne “Section Device”, tu ajoutes (ou modifies) :

Driver "vesa"

Ensuite tu relance le serveur X :

sudo /etc/init.d/gdm restart

(ou ctrl + alt + retour-arrière)

Mais tu trouveras les pilotes de ta CG dans les dépôts.

merci je vais essayer

et pourquoi en virtuel avec virtualbox, ça marche bien sans écran vert sous xp ?
Edité le 26/11/2008 à 23:01

Tout simplement que le système d’exploitation ne voit pas ta carte graphique ATI, il voit la virtuelle de VirtualBox et utilise les pilotes de base (vesa).

Les différentes distributions que tu as testé ont du utiliser des pilotes graphique inadaptés à ta x1950 (mal détectée).