Forum Clubic

Ecran noir linux liveCD sortie vga - [Résolu]

Bonjour, comme beaucoup je me suis laissé tenté par les live CD linux (Kaella et mandriva move).

Sur mon ordinateur de bureau aucun problème ou presque. Sur mon portable, écran noir au chargement de linux après l’écran d’accueil et la détection des périphériques. Je ne suis pas le seul dans ce cas et les seules réponses que j’ai trouvées sont liées à un problème de pilotes ATI ou à l’ACPI (désactivation préconnisée pour ce dernier, je penche plutot pour la 2eme réponse).

En désespoir de cause j’ai téléchargé le récent “ulteo” et ça marche, que sur ma sortie VGA et mon écran de portable reste désactivé. J’ai eu beau tenter de modifier les paramètres d’affichage dans linux mais aucun résultat, mon LCD du portable reste éteint.

Une idée pour remédier à cela?

Merci d’avance

Est-ce que tu as essayé l’option vga=771 au moment de lancer le livecd?

Je viens d’essayer vga=771 et j’ai toujours le même problème. J’ai remarqué qu’à chaque fois que “X-windows” est lancé, mon LCD de portable est tout bonnement éteint et l’ordi passe sur la sortie VGA (heureusement que j’ai mon ordi de bureau pour utiliser la sortie VGA du portable pour voir ce qui se passe). Si j’éteins l’ordi en appuyant sur le bouton power, mon LCD reprend de l’activité dès que “X-windows” est terminé. J’ai le même problème que ce soit avec Ulteo ou kaella (Knoppix). J’ai eu beau désactiver l’acpi, la détection hot plug (noudev) et le PCMCIA, rien n’y fait. Pour info, j’ai un acer 8104. Tant que l’interface est celle du démarrage du liveCD ou du prompt, l’écran du portable est actif et dès le lancement du “X-windows”, il est désactivé au profit de la sortie VGA
Ma conclusion de néophyte est que “X-windows” ne prend en compte que ma sortie vga et pas mon ecran de portable.

Une autre idée?

:bounce: eureka!!!

Bon j’ai parcouru pas mal de forum et il semble que le x700 ati ne soit pas le meilleur ami de linux…

Beaucoup de solutions compliquée, d’installation de pilotes, de configuration… peu utile pour un live cd.

Solution simple et rapide :clap: : si vous bootez le livecd knoppix / kaella, avec “nopcmcia”, “noudev” (sinon, bloquage au boot), et si vous rajoutez “xmodule=vesa” vous pourrez enfin obtenir le boot et l’affichage sur le lcd du portable (ici un acer 8104). Donc pas d’écran noir / black screen, la sortie vga fonctionne aussi mais avec la résolution du lcd, donc ecran large…

J’ai pas essayé pour ubuntu ni mandriva move (move ne boot pas de toute façon sur mon portable), avis aux amateurs…

voila j’ai un probleme tres similaire. quand je lance le live cd mandriva one tout se passe bien tant que je suis en mode texye jusqu’a ce fameux ecran noir. donc impossible de continuer. j’ai moi aussi une ati x700 mobility.
sinon c’est quoi vga=771 et xmodule=vesa?? excusez moi mais pour l’instant j’étais resté cantonné a mon windows sauf a la fac donc je ne suis pas(encore) familiarisé avec cela. et quand faut il le rentrer?

vga=771 : résolution et fréquence de l’affichage

xmodule=vesa : pilote de la carte graphique, vesa est le pilote générique qui fonctionne dans tous les cas, enfin normalement.

merci bien!
et sinon quand dois je taper cela?? j’ai lu qu’il fallait faire ctrl+alt+F2 apres cet écran noir puis taper root comme nom d’utilisateur puis rentrer vga=771 et xmodule=vesa. je l’ai fait mais j’ai toujours le meme probleme.
peut etre que ce n’est pas la qu’il faut que je le fasse. un peu plus d’aide s’il vous plait car je débute sous linux.

Non cela se tape avant de lancer le live CD, en appuyant sur F6 et en enlevant les deux tirets.

merci j’essayerai meme si j’ai finalement réussi avec une maniere beaucoup plus compliquée(j’ai éditer xorg.conf: j’ai remplacé ati par radeon, ajouter deux options juste apres, changer les résolutions par défauts car j’ai un écran 16:10,etc).
bref j’ai bien galéré mais j’y suis enfin parvenu.
encore merci pour votre aide.

Juste une petite remarque. J’ai utilisé récemment Mandriva one et j’ai toujours ce problème de désactivations du LCD du portable. Donc en connectant un ecran sur la sortie VGA du portable, je désactive l’option “dupliquer le bureau sur l’ecran secondaire” (panneau conf KDE, serveur x, option) et en relançant la session, le LCD s’active. Il semble donc qu’il y ait un bug qui désactive le LCD au lieu de simplement cloner le bureau sur l’écran secondaire.