Forum Clubic

Ecran cassé sous mandriva

Bonsoir,

Habituel lecteur des forums de clubic et autres, à la recherche de solution info,
je poste aujourd’hui un message, car je n’ai trouvé de solution nulle part :

J’ai un laptop avec une distro Mandriva 2007.1 installée. Manque de bol, il y a
qq temps, je l’ai fait tombé, et du coup, un tier de l’écran s’affiche mal (bug avec des lignes)
La résolution est de 1024x768. Disons que les 250 lignes du bas de l’écran sont
inutilisables. J’arrive encore à utiliser le pc, j’ai mis la barre des taches en haut.
Mais les fenetres saffichent en partie dans la zone brouillée, et par exemple, je peux
pas voir le bas des fenetres (sauf en faisant défiler ok), il est difficile de redimentionner etc.

Ce que je voudrais, c’est d’une maniere ou d’un autre, interdire l’utilisation du bas
de l’écran. Je pense pas qu’il soit possible de modifier la résolution à 1024x518 ( = 768-250).
J’aimerai que le bas de l’écran ne soit pas utilisé par linux.

J’ai cherché qq heures ce soir, il semblerait que le xorg.conf permette de resoudre mon probleme,
mais j’ai cherché dedans, j’ai limpression que je suis dans le mode automatique
(xorg se configurerait automatiqmenet au démarrage ?!)
jai testé xvidtune, mais l’écran nest pas supporté ( “Video are not settable on this chip” )
Je ne sais plus trop ou creuser … J’espere que mon probleme inspirera quelques uns d’entre vous…

Merci pour vos réponses

PS : Voila quelques précisions sur ma config :

carte graphique : VIA S3G PRO
PC : laptop acer aspire 1360
distro : mandriva 2007.1 free
noyau : 2.6.17-13mdv

Et ce que renvoie un “more xorg.conf” :

===================================================

File generated by XFdrake (rev 142098)

**********************************************************************

Refer to the xorg.conf man page for details about the format of

this file.

**********************************************************************

Section “Files”
# font server independent of the X server to render fonts.
FontPath “unix/:-1”

# minimal fonts to allow X to run without xfs
FontPath "/usr/share/fonts/misc:unscaled"

EndSection

Section “Extensions”
Option “Composite”
EndSection

Section “ServerFlags”
#DontZap # disable (server abort)
#DontZoom # disable <KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section “Module”
Load “dbe” # Double-Buffering Extension
Load “v4l” # Video for Linux
Load “extmod”
Load “type1”
Load “freetype”
Load “glx” # 3D layer
Load “dri” # direct rendering
EndSection

Section “InputDevice”
Identifier “Keyboard1”
Driver “kbd”
Option “XkbModel” “pc105”
Option “XkbLayout” “fr”
Option “XkbOptions” “compose:rwin”
EndSection

Section “InputDevice”
Identifier “Mouse1”
Driver “mouse”
Option “Protocol” “ExplorerPS/2”
Option “Device” “/dev/mouse”
EndSection

Section “InputDevice”
Identifier “SynapticsMouse1”
Driver “synaptics”
Option “SHMConfig” “on”
EndSection

Section “Monitor”
Identifier “monitor1”
VendorName “Generic”
ModelName “Flat Panel 1280x1024”
HorizSync 31.5-90
VertRefresh 60

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616

EndSection

Section “Device”
Identifier “device1”
VendorName “VIA Technologies, Inc.”
BoardName “S3 UniChrome-based cards”
Driver “openchrome”
Option “DPMS”
EndSection

Section “Screen”
Identifier “screen1”
Device “device1”
Monitor “monitor1”
DefaultColorDepth 16

Subsection "Display"
    Depth 8
    Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
    Depth 15
    Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
    Depth 16
    Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
    Depth 24
    Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

EndSection

Section “ServerLayout”
Identifier “layout1”
InputDevice “Keyboard1” “CoreKeyboard”
InputDevice “Mouse1” “CorePointer”
InputDevice “SynapticsMouse1” “AlwaysCore”
Screen “screen1”
EndSection

===================================================

Edité le 03/03/2009 à 23:45

Salut,
Tu peux essayer en mettant DisplaySize largeur hauteur à la section Monitor. Pour la largeur/hauteur ça dépend de ton écran (peut être dans ton manuel) sinon je suis tombé sur 304.1mm et 228.1mm, donc en enlevant en gros 1/3 en hauteur ça donnerait ça :

Section “Monitor”
Identifier “monitor1”
VendorName “Generic”
ModelName “Flat Panel 1280x1024”
HorizSync 31.5-90
VertRefresh 60
DisplaySize 304.1 160

Après il y aura certainement d’autres choses à régler : position, résolution.

SI jamais c’est ta carte vidéo qui a pris, ça risque de ne rien changer par contre :frowning:

A+

ReSalut,

Merci pour tes conseils,

J’ai essayé “DisplaySize” mais en fait, ca ne change rien : La zone brouillée reste utilisée par linux.
Dapres certains sites, DisplaySize bugge, et il faut rajouter “Option “NoDDC” “true”” dans la section"
“Device”, mais finalement ca ne change rien pour moi.
J’ai augmenté la taille du bureau virtuel, pour avoir acces au bas des fenetres, ca résoud en partie mon
probleme…

Sinon, pour info : la zone brouillée ne change pas de taille (physique) lorsque je change la résolution :
800x600 etc…

ps : Ca fait toujours plaisir de retrouver les joies de vi lorsqu’il faut editer le xorg.conf sans interface graph.

Re,

Je viens de penser à un truc : pourquoi ne pas créer un deuxième panneau (barre des tâches) de la hauteur de la surface brouillée en le positionnant en bas, ça empêcherait toute fenêtre de s’y étendre.
Par contre je suis pas sous kde (xfce pour moi), je ne sais plus la limite de hauteur d’un panneau (128 pixels sous xfce).

Au pire il faudrait voir avec un dock vide s’il n’y a pas possibilité d’obtenir la bonne hauteur.

A+

re,

J’ai testé la barre des taches secondaire, ca marche,
je recouvre effectivement toute la zone brouillée.

merci pr ton aide,

a+

ps : comment mettre résolu dans le sujet ? j’ai essayé de l’éditer, en vain…
Edité le 03/03/2009 à 23:47