Forum Clubic

Easy php / hébergement free / php6

Bonjour,

Je voulais savoir si il est possible d’utiliser php6 sous easyphp et si l’hébergement free est compatible php6
je travaille actuellement sous la version 5 et voulais tester la future version (ce malgré qu’elle va peut-être jamais sortir).
merci d’avance

Il est peu probable que Free supporte le PHP6 avant sa sortie définitive.

Concernant EasyPHP, ça fait longtemps que je ne m’en suis pas servi mais j’ai connu le même problème lorsque PHP5 était en développement. Il y a des manipulations pour le mettre à jour mais ce n’est pas évident. Je me suis vite rendu compte qu’il était plus pratique de laisser tomber EasyPHP et d’installer Apache + PHP + MySQL manuellement (c’est beaucoup plus simple qu’il n’y parait). Au moins comme ça tu peux mettre à jour PHP et MySQL à ton rythme.

Sinon il y a WAMP, qui propose des fonctionnalités similaires, mais qui lui existe en PHP6 : www.wampserver.com…
Edité le 27/01/2011 à 14:00

… si PHP6 sort un jour !

Je te suggère de rester sur la dernière version 5.3, qui sera très proche de la version 6.0.

Sinon, tu devrais “monter” toi-même ta propre suite LAMP :

  • prendre la dernière version d’Apache toi-même (apache.org)
  • prendre la dernière version de PHP5/6 dans les binaires PHP.net (les snapshots te seront utiles)
  • prendre la dernière version de MySQL (chez Oracle)

Tu auras la dernière version de PHP6 comme ça (s’il y en a des récentes).
Il faut que tu saches qu’une partie très importante de ce qui a été prévu en PHP6 a… déjà été intégrée dans la branche 5.3… et la future 5.4.
Je te conseille de lire ceci : dotclear.placeoweb.com…