Forum Clubic

Dual boot: Lecteur inversé dans XP et Vista -

J’ai un probleme etrange avec l’installation de Vista en Dual Boot (XP + Vista)

J’ai 2 disques dur

Sur le disque 1 : XP

Sur le disque 2 : Vista

mon probleme est le suivant: les lettres des lecteurs sont inversés sur XP et VISTA

Sur XP:

mon disque 1: s’appelle C: (avec XP d’installé)
mon disque 2: s’appelle D: (avec Vista d’installé)

Sur Vista:

mon disque 1: s’appelle D: (avec XP d’installé)
mon disque 2: s’appelle C: (avec Vista d’installé)

Du coup j’ai peur qu’en installant des pilotes ou autre a partir de VISTA d’ecraser avec XP… car les 2 systemes ce sont approprié le lecteur C: , les 2 OS etant pourtant sur 2 disques differents…

bizar non ? Comment puis-je regler ce probleme ?

C’est normal.
Quand tu as Vista de lancé, XP ne fait absolument rien. Il est inerte. Si tu installes des pilotes sous Vista, ils ne seront installés QUE POUR Vista. XP ne les verra pas. Le C: que tu indiquera à l’installation sera le C: de Vista. Cela marche de la même manière si tu utilise XP.
Ton problème est un faux problème donc ^^

Ok merci de ta reponse…

Mais j’etais etonné car lors de la premiere installation de Vista, l’OS VISTA apparaissait bien sur D: que ce soit sur Vista ou XP… d’où ma question…

c’est simple:

si tu installe Vista en bootant sur le DVD, il s’appropie le C: à chaque boot et donc les lettres de lecteurs changent. Entre les 2 OS ça ne pose aucun probleme particulier.

Par contre si tu installes Vista en lançant l’installation depuis XP alors il conservera la lettre de lecteur du disque utilisé lorsque tu es sous XP au debut de l’installation.
C’est ce qui m’a permi d’installer Vista sur un Z: depuis que je le teste avec la Beta2 puis les RC :wink:

L’avantage c’est aussi que ça ne chamboule pas tout le reste des lettres de lecteurs (partitions mais aussi CD/DVD) qui ne bougent pas d’un OS à l’autre. Pratique si tu utilises des softs sans installation et qui sont configuré pour telle ou telle lettre de lecteur.

OK c’est effectivement ce qui s’est passé…

La premiere fois je l’ai installé a partir de XP, la seconde directement en bootant sur le DVD

Merci de ces explications.