Forum Clubic

Du bon usage de desktop.ini sous Vista

Bonjour,

Suite à un problème encore non résolu (résumé : www.clubic.com…) je me penche sur l’utilisation des fichiers desktop.ini.

Les fichiers desktop.ini permettent entre autre de modifier l’apparence du dossier auquel ils appartiennent, modifier le nom sous lequel apparaît un dossier, dire si l’on veut que le dossier soit considéré comme un dossier contenant de la musique, des données, des images etc…

Pour résoudre mon problème, je cherche à utiliser ces lignes de commande en particulier :



[.ShellClassInfo] 
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21781

ou 

[.ShellClassInfo] 
LocalizedResourceName=@%SystemRoot%\system32\fr-FR\shell32.dll.mui,-21781

Mon problème est le suivant : Quel que soit le répertoire (Program Files, un répertoire de mes documents, ou autre) le fichier desktop.ini n’est pas pris en compte. J’ai utilisé le programme “attribute changer” pour passer ces fichiers en tant que fichier caché du système d’exploitation, rien n’y fait ! A cause de Vista ?
Est-ce que quelqu’un saurait comment on utilise ces fichiers sous Vista pour qu’ils soient effectifs ? les créer en tant qu’administrateur etc ? (Plus particulièrement pour le dossier Program Files qui est mon soucis premier :))

Merci pour votre Aide,
Edité le 25/08/2008 à 18:34

www.laboratoire-microsoft.org…

Aide toi de ceci peut être.

nop… sans effet

désolé je ne vois pasplus, mais je pensais qu’avec ces exemples tu pourrais te dépatouiller. Saches quand même que sous vista l’usage de ce .ini est totalement différent que sous xp , exemple : on ne peut pas ajouter une image de fond dans un dossier sous l’explorateur.

Hum, il semble aussi qu’il y ait des restrictions sur la possibilité de les mettre, modifier ect, j’ai beau tout essayer pas moyen de les rendre actif, j’ai fait un test sur un répertoire perso dans mes documents :

nouveau fichier : desktop.ini mit en fichier systeme caché, les lignes de commandes qui vont bien pour modifier l’icone, et en mettre une quelconque (chemin en dur (D:\document…icon.ico) ou en soft %systemroot%…)
ou
copie collage d’un desktop.ini créé automatiquement dans un autre répertoire dont j’ai modifié l’icone

redémarrage de session, de explorer,
en mode sans echec…
Le dossier n’est en aucun cas modifié : icone ou quoi que ce soit d’autre…

Quelqu’un aurait-il une expérience réussie de création/modification de fichier desktop.ini sous vista ? SVP :o(

as tu essayé en recopiant un des exemples exact que je t’ai donné et ensuite en changeant simplement le répertoire qui va bien ainsi que l’emplacement dans la dll pour mettre le bon icone.

je te conseille reshacker , un éditeur d’exe et de dll qui te permet de connaitre les emplacement des icones ( je l’ai déjà utilisée t il est très bien foutu ,backup de la dll avant !, mais je crois qu’il le propose )

Oui, un copier collé tout ce qu’il y a de plus fidèle du contenu pour “documents” dans un dossier quelconque… Aucun résultat.

Pour ResHacker, oui, je m’en sert de temps en temps, en l’occurrence il me sera utile pour résoudre le problème à l’origine de mon envie d’utiliser les desktop.ini…

là je sèche…je ne vois plus rien à te proposer.
qq’un d’autre aurait-il une idée ??

Oki, merci pour les efforts fournis en tout cas.

Quelqu’un d’autre qui se sent de relever un chalenge ?

Bonjour à tous,
Me voici revenu, prêt à en découdre avec “Program Files”

Je tiens à remercier l’utilisateur sharp_ dont l’aide m’a été précieuse,

Pour réaffecter le nom apparent, l’étiquette, “Programmes” au dossier Program Files" sous Windows Vista, voici la marche à suivre :

  1. Se munir du logiciel Attribute Changer.
  2. Faire apparaître les fichiers et dossiers cachés du système d’exploitation : "Organiser -> Option des dossiers et de recherche -> Affichage -> Décocher “Masquer les fichiers protégés du système d’exploitation”
  3. Aller sous “Program Files”, créer un nouveau fichier texte, renommer le desktop.ini
  4. Entrer les lignes de code suivantes :

[.ShellClassInfo] 
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21781

  1. Clique droit sur le fichier desktop.ini et “Change attributes” qui est un bouton apparu suite à l’installation de Attribute changer
  2. Cocher “hidden” et “system”
  3. Remonter d’un niveau, clique droit sur “Program Files” et à l’aide d’attribute changer, vérifier que Read Only est coché (une coche, pas un carré rempli), si tel n’est pas le cas, cocher.
    Sans redémarrage nécessaire, “Program Files” devrait de nouveau apparaître comme “Programmes”
  4. On peut de nouveau cacher les fichiers et dossiers protégés du système d’exploitation comme en 2.

J’ai conscience que mettre ProgramFiles en lecture seule peut choquer, néanmoins, en le laissant dans cet état, je n’ai pas eu de problèmes pour désinstaller Attribute changer. Je verrai à l’utilisation et préviendrai si cela pose un problème.Sachant que dans Vista ce répertoire est géré différemment que dans windows XP, et très protégé, je ne m’étonnerais pas que ça fonctionne très bien comme ça.

Cordialement,

Ps : pour les autres répertoires, je conseille d’essayer l’astuce 7. et voir si l’on a toujours accès au dossier quand même. Mon soucis de base concernait ProgramFiles, ce fut difficile, je n’ai pas cherché beaucoup plus loin pour les autres dossiers moins problématiques, personnalisables en tout cas par leur propriétés classiques…

Merci pour le retour d info.