Forum Clubic

Drivers ATI sur une install d'ubuntu 9.04 server

Bonjour,

j’ai un soucis avec mon ubuntu, à savoir une occupation de mon double coeur à quasi 100% sous firefox, à priori à cause de flash.

Sur certains forums, certains parlent de mettre à jour les drivers graphique, ce qui de toute façon n’est pas une mauvaise idée même si ça ne résout pas mon problème.

Mon soucis vient du fait que j’ai installé ubuntu sur un raid 1 logiciel, possible uniquement depuis l’installation de ubuntu server, sur lequel j’ai ensuite installer gnome comme indiqué pour retrouver un ubuntu classique…

Sauf que les drivers ati ne s’attendent pas à être installé sur une version serveur (puisque normalement dépourvu d’interface graphique) et donc refusent de s’installer pour raison de version non supportée.

Quelqu’un saurait-il comment contourner ce problème ? (ajouter ma version aux versions supportées par exemple ?)

sudo ./ati-installer.sh 8.593 --install
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib32::none:2.6.28-13-server; make sure that the version is being
correctly set by --iscurrentdistro

Edité le 19/07/2009 à 12:36

Je presume que en installant la version ubuntu serveur, tu as hérité du Kernel serveur, on le vois bien ici “2.6.28-13-server”.

Ce qu’il faudrais serrais d’installer le kernel desktop, je presume qu’un :

aptitude update && aptitude install kernel-desktop

fera l’affaire.

Apres, il faut modifier les entrée de grub (ou lilo) pour booté sur le desktop, sois apt le fait tout seul ou alors il faut le faire à la main.

Ensuite tu installs les drivers normalement.

Ps : Il est aussi possible d’essayer l’installation des drivers directement depuis les depot, il te proposera peut etre de téléchargé le kernel desktop :

aptitude update && aptitude install xorg-driver-fglrx fglrx-control

je n’ai lu nul part que les drivers proprios d’ATI étaient disponible en dépôt, ce qui me paraitrait normal… en tout cas, dans les procédure décrite pour ceux qui ont des problèmes d’utilisation mémoire avec flash…

J’ai un peu peur des conséquence de mettre un kernel desktop par dessus la version serveur, si il y a des bidouilles à faire ensuite, ça sort de mon domaine de compétence de simple utilisateur.
Edité le 23/07/2009 à 14:17

Pas de prob pour changer de noyau :wink:
Tu installes le noyau desktop comme si c’etait une appli normale (avec le gestionnaire de packages) et tu rebootes.
Idem pour les drivers ati : utilise le package manager

Je suis sur que les drivers ati proprio son dans les dépots de Ubuntu, il propose même leurs installation avec le system tray de gestion des pilotes.