Forum Clubic

Driver ATI & Résolution - le 16:9 en 4:3, c'est pas beau :(

Salut à tous,

 Voila mon petit soucis, je suis sous [Ubuntu](http://www.clubic.com/telecharger-fiche15525-ubuntu.html) 5.10 avec un Dell Inspiron 6000 (version avec une X300 Mobility), j'ai donc un "ecran large" et j'utilise la résolution suivante : 1280x800 ou 1200x800. Avec les pilotes de base Vesa, pas de prob mais avec les pilotes ATI, l'acceleration marche très bien, mais la résolution est au max de 1024x768 :s et impossible (enfin pour moi :s) de remettre du 1280x800, même en allant directement dans le xorg.conf :s. Le problème vient-il de moi ? du driver ? de la carte ? Si vous avez une solution a me proposer, je suis preneur !!! Merci d'avance, bonne soirée ;).

Regarde dans le fichier /etc/X11/xorg.cong et vérifie que les modes d’affichages sont bien définis avec le mot Modes et non Virtual.

Pour corriger la chaose il te suffit de faire la substitution, ce qui devrait te donner un truc du genre:
Modes "1280x800" "1024x768" "800x600"

Si tu veux garder les deux dernières résolutions, mais t’es pas obligés.

Dans les questions que pose les drivers ATI lors de l’installation, il y en a une qui concerne le choix d’un bureau virtuel ou pas.

http://linuxfacile.neuf.fr/astuces/Serveur…Display%20Modes

Ca c le topic complet
http://linuxfacile.neuf.fr/astuces/Serveur…vers%20Ati.htm

Merci pour ta réponse, voila mon xorg.conf, mais les resolutions sont bien définis avec le mot "modes" :s :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/CID"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver  "kbd"
	Option  "CoreKeyboard"
	Option  "XkbRules"	"xorg"
	Option  "XkbModel"	"pc105"
	Option  "XkbLayout"	"fr"
	Option  "XkbVariant"	"latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver  "mouse"
	Option  "CorePointer"
	Option  "Device"  "/dev/input/mice"
	Option  "Protocol"  "ImPS/2"
	Option  "Emulate3Buttons"	"true"
	Option  "ZAxisMapping"  "4 5"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver  "synaptics"
	Option  "SendCoreEvents"	"true"
	Option  "Device"  "/dev/psaux"
	Option  "Protocol"  "auto-dev"
	Option  "HorizScrollDelta"	"0"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon Mobility M300 (M22)"
	Driver  "fglrx"
	BusID  "PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	Option  "DPMS"
	Modeline	"1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device  "ATI Technologies, Inc. Radeon Mobility M300 (M22)"
	Monitor  "Écran générique"
	DefaultDepth	24
	SubSection "Display"
  Depth  1
  Modes  "1280x800"
	EndSubSection
	SubSection "Display"
  Depth  4
  Modes  "1280x800"
	EndSubSection
	SubSection "Display"
  Depth  8
  Modes  "1280x800"
	EndSubSection
	SubSection "Display"
  Depth  15
  Modes  "1280x800"
	EndSubSection
	SubSection "Display"
  Depth  16
  Modes  "1280x800"
	EndSubSection
	SubSection "Display"
  Depth  24
  Modes  "1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen  "Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Sinon, je peux monter en resolution maximal (avec les drivers ATI) en 1280x768 … pour le 1280 est-il bon et non le 800 ??? Je trouve cela bizarre …