Forum Clubic

Disque Dur en NTFS, comment faire ? [résolu]

Bonjour à tous !

Je voulais récupérer des données sur un vieux disque dur. Windows ne le reconnaissant pas, j’ai booté sur la distrib kaella et là ce DD apparaît bien.
Par contre quand je cherche à copier des fichiers sur mon autre DD (appelons le C) avec konqueror, j’ai un message d’erreur comme quoi c’est impossible.
J’ai même essayé de créer un dossier sur C et là non plus celà ne fonctionne pas.

J’ai pour celà lancé l’utilitaire Captive mais celà n’a pas résolu le problème.
Déjà il ne trouve pas les drivers tout seul et lorsqu’il les trouve dans mon dossier windows (que je lui indique manuellement) je clique sur “suivant” et la procédure se termine sans que je puisse écrirer ou modifier les partitions ntfs.
J’ai également essayé le clic droit sur la partition et changement des droits d’écriture mais ça ne fonctionne pas non plus.

Pouvez-vous m’aider ?

Merci :slight_smile:

NTFS n’est pas reconnu d’emblé par linux.

et en prime, je crois que le live-cd knoppix/kaella monte les disques durs en lecture seule par défaut :smiley:

[MàJ] oops ! :whistle:

Ben oui, je sais…
vous avez lu mon post jusqu’au bout ? :wink:

Voila les lignes de mon fstab qui vont bien.
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-15,ro 0 0
/dev/hdb5 /mnt/win_c2 ntfs umask=0,nls=iso8859-15,ro 0 0
/dev/hdd5 /mnt/win_c3 ntfs umask=0,nls=iso8859-15,ro 0 0
/dev/hda5 /mnt/win_d ntfs umask=0,nls=iso8859-15,ro 0 0
/dev/hdb6 /mnt/win_d2 ntfs umask=0,nls=iso8859-15,ro 0 0

Essayes avec ces options là.

sur le bureau knoppix tu clique droit sur l’icone qui represente le dur sur lequel tu veut écrire > actions > change read/write mode

Jolafr, peux-tu m’expliquer un peu plus précisement stp. Je débute sur linux et là c’est du chinois pour moi ! Je rentre ça où ?

Lithium, dans mon premier post, j’indique avoir déjà essayé ça !

oh

Ah t’es sous knoppix ,
un
mkdir /home/windows
sudo mount -t ntfs /dev/hdx /home/windows devrait marcher.
A taper en console!

où x de /dev/hdx est a remplacer par a b c ou d suivant ton disque!

J’ai ce message " ne peut créer le répertoire ‘home/windows’: permission non accordée"

Et ça, ça donne:
"su: option invalide --t

Une autre idée?
Merci !!! :slight_smile:

vladnice: tape plutot ça:

mkdir /home/knoppix/Desktop/windows
sudo “mount -t ntfs /dev/hda /home/knoppix/Desktop/windows”

ok il a pas les droits sur /home

je pourrais faire quoi alors ?

jolafr: avec knoppix, on n’a pas les droits sur /home, mais par contre on a tous les droits sur /home/knoppix :oui:

vladnice: t’as essayé ce que je t’ai dit?

Thestick, pour ça: mkdir /home/knoppix/Desktop/windows
Celà fonctionne et ça me crée un dossier windows sur le bureau.

Pour sudo “mount -t ntfs /dev/hda /home/knoppix/Desktop/windows”
j’ai un message d’erreur:

sudo: mount -t ntfs /dev/hda /home/knoppix/Desktop/windows: command not found

Sinon, j’ai essayé un autre truc. J’ai crée une partition en fat32 mais c le même problème, je ne peux rien écrire dessus :confused:

Autant pour moi, j’avais oublié de monter la partition en fat32. arf :confused:
Donc j’ai réussi à copier mes fichiers sur cette partition. C réglé. Merci Linux :slight_smile:

Marques résolu dans le titre!
C’est vrai que knoppix c’est bien (avec la version powerpc j’ai pu récuperer des données de ma tant sur son disque “mort”)