Forum Clubic

Disparition du lecteur de cd rom - y'a plus le cdrom

une ami a un pc (p2 350Mhz, cg inconnu mais qui date, DD 4 Go) sous win98 dont le lecteur de cdrom n’apparait pas dans le poste de travail et plus bizarre dans le gestionnaire de periph. Ce pc lui a été donné recemment par un abruti qui doit rien y connaitre en informatique

Question : comment le faire réapparaitre?

j’ai déja essayé en changeant de lecteur mais c’a n’a rien changé.

merci de vos réponses (claires si possibles) :wink:

Si mes souvenirs sont bons, dans le gestionnaire de périphérique, tu peux choisir la lettre de lecteur, “de”…“à”. Mets deux fois la même lettre, evidement une qui n’est pas prise.

peut etre me suis je mal exprimé
il n’apparait pas non plus dans le destionnaire de peripherique

Est-il reconnu par le BIOS au démarrage ?

j’ai pas mal fouillé dans le bios mais je sais pas ou chercher.

il apparait durant les premieres sequences de boot (1ere page visible au boot)

en cherchant dans le gestionnaire de peripherique ou les informations systemes (demarrer/executer et taper msinfo) est ce que le pc ne serait pas en mode compatibilte ms-dos ?

si c’est le cas, c’est que des pilotes 16 bits se chargent au demarrage et entre en conflits avec les pilotes 32 bits de windows 98.
d’abord regarder dans les fichier “config.sys” et “autoexec.bat” s’il n’y a pas des lignes faisant allusion au lecteur de cd-rom.
si c’est encore le cas editer ces fichiers en mettant devant ces lignes les 3 lettres “REM” (correspondant a des commentaires, ce lignes ne seront pas prises en compte par le systeme au demarrage).

si ce n’est pas le cas, il est possible de forcer la reconnaissance en rajoutant ces memes lignes mais la il faudrait faire une recherche parce que c’est vieux et que je ne m’en rapelle plus (ce que c’est que l’age :smiley: ), redemarrer le pc puis supprimer les lignes.

ca c’est pour windows dans le cas ou il ne sont pas reconnu dans le gestionnaire de peripherique, il est bien possible que ca vienne du bios, si le bios est ancien il y a peut etre une option de reconnaissance auto plus une option permettant de forcer la reconnaissance des peripheriques ide.

maintenant il est bien possible que le lecteur de cd-rom soit mal branche ou mal configure (maitre ou esclave) suivant sa position sur la nappe.

comme le pc a l’air ancien, la nappe a trois connecteurs , 2 connecteur pour les disques (connecteur assez prochz l’un de l’autre) assez proche dont l’un est en bout de nappe, celui qui est en bout de nappe doit imperativement etre sur le disque maitre, l’autre sur l’esclave et pas l’inverse(le cable select est un cas a part et ne fonctionnait pas toujours).
le troisieme connecteur lui est a l’autre bout de la nappe et se branche sur le connecteur de la carte mere. ca parait idiot mais beaucoup d’erreur venait d’un mauvais branchement.
les cavaliers sur le lecteur de cd.
normalement un peu au dessus de ce cavalier est indique la mention C S M ou S L A

C = cable select

S = slave (esclave )

M = master (maitre )

si le lecteur de cd est configure en maitre et positionne en esclave (et inversement) il y a de grande chance pour qu’il ne soit pas reconnu sous windows.

si tout est bon de ce cote, pc eteint :smiley: , debranche le lecteur de cd-rom et redemarre, puis eteint a nouveau le pc et rebranche le lecteur de cd-rom, il est possible qu’il le reconnaisse a nouveau et qu’il apparaisse.

il y a la possibilite d’un conflit avec le disque dure, ca n’est plus d’actualite aujourd’hui mais a une epoque il vallait mieux que le lecteur de cd soit seul sur une nappe et pas en esclave du disque dure.

beta -> merci pour ces precisions qui sont tout fait juste. le pc est bien en mode msdos. dans le gestionnaire de periph les pilotes du controlleur de DD ont un joli point d’exclamation jaune devant. les fichiers mentionnés ne contiennent aucune ligne portant sur le cd rom.
je vais tenter une recherhce sur le forum :wink: :jap:

Bonsoir,
avez vous trouvé la solution , car j’ai le meme soucis avec le meme type de pc.
D’avabce merci
Cordialement

il ya peut etre quelque chose a tenter pour retrouver tout ca sans chercher a faire reconnaitre le lecteur de cd_rom.
demarrer windows en mode sans echec puis dans le gestionnaire de peripherique, supprimer la peripherique avec le point d’exclamation (controlleur ide). valider quand il demande de confirmer puis redemarrer le pc (tenir le cd_rom de 98 pret il va peut etre le demander).

autre possibilite qui m’est revenu a l’esprit, il ya quelques annees de ca sur un pentium 200 j’avais monte un lecteur de cd_rom (sony si ma memoire est bonne) or windows ne voulait pas le reconnaitre, il fallait simplement des pilotes particuliers a ce type de lecteur.

enfin pour le lignes a rajouter dans les deux fichiers, j’ai finit par retrouver l’un des posts dans le forum.

ca donne ceci.

dans le config.sys:
"device=oakcdrom.sys /D:CD"

oakcdrom.sys est le drivers universel de micosoft sur la diskette de boot d’install.
Sinon, le drivers DOS livré avec le lecteur CD

et mscdex dans autoexec:
"MSCDEX.EXE /D:CD /L:Y" ( Y est la lettre du 1er lecteur)

1 fois le CD chargé par WIN,il est possible de virer les lignes: WIN a fait sa cuisine et le P&P fonctione à nouveau.
mets 1 “rem” devant les lignes pour voir, sinon conserve
jusqu’à ce que ça marche.

pas de risque de conflit ou d’encombrement mémoire: si les drivers de WIN fonctionnent bien, les lignes inutiles sont ignorées.

le souci a été reglé (voir post de beta juste au dessus pour de l’aide 100% correct)
mais apparament le pc a grillé 2 semaines + tard (c’etait un vieux pc)