Forum Clubic

Désactiver Spotlight (page 2)

Ca fait un peut beaucoup 11 heures. Il est ptet possible de laisser le macbook pro indexer 2 ou 3 heures et après lui dire de partir en veille si tu veux pas qu’il reste allumé.

De toute façon il reste allumé. Là n’est pas la question. Mon backup se fait de manière automatique toutes les nuits à 1H.

Par contre, le truc plus sioux que 2 cron, c’est que je dois avoir un cron qui s’exécute de manière régulière (genre toutes les 10 minutes) et qui lance l’indexation après 22H si elle n’est pas lancée, et qui la coupe après 9H si elle est lancée… Rien de bien méchant, mais il fallait y penser de suite, sinon ça aurait été foireux…

Je viens de lire ceci à propos de Spotlight v2 :

Ah bah quand même :o

Bon finalement, pas envie d’installer le script…

J’en ai fait un qui coupe l’indexation après 9h et la relance après 22h…
Mais il faut être root pour le faire. Ça signifie donc activer le compte root pour installer le cron…

Donc je lance le script à la main quand j’y pense :slight_smile:

euh y a vraiment besoin d’activer le compte root pour se logguer avec ? un sudo su ne suffit pas ? :ane:

Tiens j’ai pas essayé… Mais pour faire un su, il faut activer le compte…
Edité le 12/10/2007 à 08:22

su et sudo sont 2 choses différents, non ?

oui, su te log en root sans logout ta session et sudo execute une commande en root

Je me souviens avoir souvent confondu les 2 mais je constate que su refuse mon mot de passe là où sudo ne pose pas de problème :etonne2: Une idée ?

Je pense que c’est le mot de passe root qu’il faut donner.

Si tu lui en a pas donné :

$ sudo passwd root
Edité le 12/10/2007 à 09:21

pour su et pas sudo ? J’ai peur de ne pas bien comprendre :smiley:


ok j'ai compris, merci Google comme d'hab :D [www.xrings.net...](http://www.xrings.net/xrings/article.php3?id_article=97)

En fait su te switch en root donc le mot de passe sera celui du root et pas le mdp utilisateur.

sudo lui n’a pas besoin d’un password root, tu utilise ta propre session. Par experience je me suis rendu compte que sudo était parfois limité et il fallait passer en root.

Ça marche chez moi, et je n’ai pas souvenir avoir activé le compte

Effectivement, à voir si les cron fonctionnent maintenant :super:


[quote="claps"] Je me souviens avoir souvent confondu les 2 mais je constate que [i]su[/i] refuse mon mot de passe là où [i]sudo[/i] ne pose pas de problème :etonne2: Une idée ? [/quote] sudo te permet d'avoir les privilèges root depuis ton compte. Le mot de passe que tu utilises est TON mot de passe, quand tu fais un su, tu te connecte en tant que root, et là, ça nécessite le mot de passe root. Ce mot de passe n'est pas initialisé, car le compte root est désactivé (il faut manipuler pour pouvoir l'activer).

Oui j’ai vu ça dans ma recherche : par le terminal ou graphiquement via le gestionnaire NetInfo. On va laisser ça en l’état je pense :smiley:

Moi je suis la logique:

D’abord commande sans sudo.
S’il me met un acces denied ou autre, commande avec sudo.
S’il me sort une autre connerie, login root.

Je reviens sur le sujet. J’ai viré l’indexation sur tous les disque externes que j’ai, par la méthode mdutil…
Mais dès le premier rebranchement, voilà qu’il se met à réindexer mon disque externe.

Je suis allé dans les prefs pour ajouter le disque externe à la liste, mais ça ne marche pas.

  • Que je passe par le + en choisissant le disque externe dans la barre de gauche
  • Que je passe par un drag’n drop par Finder

Rien à faire… Ce n’est pas ajouter à la liste…

Alors, comment faire pour qu’il arrête d’indexer mon disque externe, ou n’importe quel disque externe ?

Précision : je peux ajouter /Volumes à l’interface (en faisant Pomme-Shift-G lors du choix du disque), mais pas /Volumes/VALA (VALA étant le nom de mon disque externe).
Je pige pas… On peut pas du tout couper l’indexation des disques externes ?
Edité le 14/10/2007 à 20:50


mdutil -i off VALA/

après fait un


mdutil -s VALA/

pour vérifier

Sans faire le off (que j’ai fait il y a plusieurs jours) :


sudo mdutil -s /Volumes/VALA/
/Volumes/VALA/:
        Status: Indexing Disabled

C’est très étrange, car quand je l’ai branché, il a mis plus de 10 minutes à apparaître, comme quand je branche un disque pour la première fois.
Ensuite, mds s’est affolé pendant encore plusieurs minutes…
Donc visiblement, même quand on désactive l’indexation sur un disque, Spotlight va y faire des trucs… :heink:
Edité le 14/10/2007 à 21:01

et quand tu met

SPOTLIGHT=-NO-

dans /etc/hostconfig il fait la même chose?