Forum Clubic

Des problèmes de connexion à ma base - MYSQL PHP

Bonjour

je cherche a me connecter à ma base de donnée MySQL, mais sa plante, j’ai le msg:

Parse error: syntax error, unexpected T_STRING in C:\OCS Inventory NG\xampp\htdocs\www\include\connection.php on line 7

pourtant je pense pas que mon code soit faux:

<?php
	$hote="localhost";
	$utilisateur="xxx";
	$pass="xxx";
	$base="xxx";
	
	@mysql_connect("$hote"‚ "$utilisateur"‚ "$pass")
	or die("Impossible de se connecter");
	@mysql_select_db("$base")
	or die("Impossible de se connecter");
?>

Si vous pouvez m’aider, j’utilise xampp en local

t’as oublié le ;

@mysql_connect("$hote"‚ "$utilisateur"‚ "$pass");

Facile !

Passe en iso-8859-1 (ou utf-8 , php est censé le supporter (?))

<?php
$hote="localhost";
$utilisateur="xxx";
$pass="xxx";
$base="xxx";

@mysql_connect("$hote", "$utilisateur", "$pass")
or die("Impossible de se connecter");
@mysql_select_db("$base")
or die("Impossible de se connecter");
?>

Tes virgules ne sont pas les bonnes, cela doit être ‘,’ et pas \u201a

Moralité : Word n’est pas un logiciel apte à faire de la prog web.

(jedit)

LOL, j’utilise notepad 2 !!!
Ou est ce que je dois aller pour passer en iso-8859-1???

Merci de ta reponse

J’ai la meme erreur en faisant comme ça.

Merci de ta reponse.

non cette fois tu as l’erreur à la ligne 9…

si tu lisais les erreurs, ça serait bien non ?

Rater, toujours la meme erreur

Parse error: syntax error, unexpected T_STRING in C:\OCS Inventory NG\xampp\htdocs\www\include\connection.php on line 7

alors là… :ouch:

désolé

C’était bien un probleme de jeu de carractére.

Dans mon editeur (notepad2) c’était en ANSI, j’ai passer en utf-8 et ça marche.

par contre pour certaine autre page genre mon index.php qui inclut header.php et connexion.php (le fichier qui causait probleme) je passe en utf-8 à l’aide des menu de notepad, mais si j’enregistre, je quite et reouvre il est de nouveau sur ANSI, c’est grave ou pas??

De toutes façons, c’était un mauvais conseil :wink: pas besoin du point-virgule vu que tu utilises “or” après. Pas besoin non plus de guillemets autour de tes variables, tu peux mettre le nom de tes variables directement.

<?php
$hote="localhost";
$utilisateur="xxx";
$pass="xxx";
$base="xxx";

@mysql_connect($hote, $utilisateur, $pass) or die("Impossible de se connecter");
@mysql_select_db($base) or die("Impossible de se connecter");
?>

Y’a aucune raison que ce code ne fonctionne pas, à moins d’un problème de codage comme l’a fait remarquer Sans-Nom ; le mieux dans ce cas c’est peut-être d’utiliser notepad.exe tout simplement, et pendant l’enregistrement, s’assurer que le format sélectionnée soit de l’ANSI (c’est dans les options de la boite d’enregistrement).

Arf, j’me suis fait grillé :paf:

Sinon sous Windows, le codage par défaut c’est l’ANSI, y’a pas de raison d’utiliser autre chose. :neutre:

Non, car php ne supporte que l’iso8859-1 (dont l’ascii fait parti) et l’utf-8

Je ne sais plus où c’est écrit, et peut être l’ai je vu dans les sources mêmes.

utilise jEdit ou n’importe quel éditeur capable de changer l’encodage

(anyway, Bloc note supporte l’ascii…)

C’est en utilisant l’ANSI (par defaut) que ça deconnait, et en passant en utf-8 dans notepad2 ça a marcher.

Si ça fonctionne chez toi, tant mieux :wink:

Mais avec l’UTF tu risques de rencontrer des soucis, notamment avec strlen (les caractères spéciaux ou accentués seront comptés comme doubles ou triples), du code PHP tapé en ANSI sous notepad (ou même PSPad, ou ConText) je t’assure que ça fonctionne sans souci avec EasyPHP et IIS. Après c’est peut-être une option dans xampp. :neutre:

Mais perso, j’ai un doute sur la fiabilité de ton éditeur de texte. :confused:

Là, son problème c’est que son éditeur change la virgule (,) en caractère bizarre. Faut voir si ton clavier est bien configuré dans Windows, dans ton éditeur

c un clavier M$ usb qui n’a pas de CD d’install donc je supose qu’il doit etre correctement configurer.

J’ai essayer de réediter mon fichier avec le notepad standart et sa fonctionne trés bien!

C’est mon notepad 2 qui est merdique , je V essayer jEdit.

Merci de votre participation

voilà :slight_smile:

prend ma macro Just justify it :stuck_out_tongue: