Forum Clubic

Dependance erronée, apt-get impossible

Bonjour à tous.
sur mon serveur kimsuffit j’ai mis une debian, noyau 2.6.18

j’ai installé seulement quelques paquets de base (php, mysql…), puis apres une tentative de mise àjour, j’obtiens la sortie suivante :

Et ce, quelque soit ma commande avec apt-get … j’ai pourtant installé les paquets necessaires, alors soit il manque encore un paquet que je ne trouve pas, soit c’est un autre problème…

si quelqu’un pouvait m’aider, ca serait chouette :slight_smile:

Il te manque donc “update-grub”, donc :
sudo apt-get install grub

M’enfin si tu utilises LILO, tu peux essayer :
sudo ln -s /bin/true /usr/sbin/update-grub

Aie, j’ai déjà installé grub, et le “update-grub” est bien présent :frowning:

je vais essayer de le réinstaller pour voir…

edit :

je me retrouve a l’install avec ce message :

et quelque soit mon choix, le systeme ne repond plus, je suis obligé d’annuler (ctrl + C) et je me retrouve avec les meme messages d’erreur…
Edité le 06/08/2007 à 12:27

Résolu !

bizarrement, cela marchait en lançant a la main le grub-install … mais pas quand celui-ci était appelé par apt-get…

Bon mais sinon, ton bootloader, c’est quoi ? LILO ?

apt-get update de temps en temps :slight_smile: