Forum Clubic

Démarrage interface graphique impossible [Résolu]

Bonjour,

chaque fois que je démarre l’interface graphique sous nux (mdk 10.1), ca démarre X et le ferme aussitot.
A savoir que les autres utilisateurs n’ont pas ce problème.

Voila le problème trouvé dans mon ~/.xsession-errors :

J’aimerais savoir aussi s’il est possible de démarrer KDE sans charger les paramètres de récupération de session précédente (c’est-à-dire que je voudrai démarrer KDE sans qu’il aille chercher les applications lancées à la précédente session et qui étaient encore ouverte lorsque j’ai quitté).
En fait j’aimerais surtout savoir comment faire. :slight_smile:

Si vous souhaitez connaitre la petite histoire de mon problème :
o j’ai installé Mafia avec un installeur Loki
o j’ai lancé mafia
o hop freeze de l’écran
o redémarrage par le bouton (aucune autre solution)
o je reviens en mode console (je ne démarre que le mode que lorsque j’en ai besoin)
o je tape startx (pour aller faire mon cv sous oOo)
o tout se lance
o par curiosité je réessai mafia
o bien sur ca replante, la résolution de l’écran étant modifié
o je quitte X
o je refais startx
o ca se lance, et ca se coupe au slashscreen
o depuis il ne se passe plus rien, a part les erreurs de la session suscitées.

Merci d’avance

P.S : si en plus vous pouviez me dire comment éxecuter des commandes en root au démarrage et sans passer par sudo (je ne peux pas mettre l’utilisateur concerné ds les sudousers sinon y en a un qui … :pt1cable: )

En mode konsole :
$ rm -Rf /home/mafia/.kde
Note qu’il se régénère au demarrage de KDE

Sinon plus radical --> Si tu as moyen de sauver tes docs dans /home/mafia, de faire un ptit

rm -Rf /home/mafia

puis de le recréer avec

adduser …

Lance kdecontrol pour décocher “sauver la session au redémarrage”

Enfin g pas compris question dans ton PS.

:stuck_out_tongue: hi hi
En fait mafia c’est le jeux, pas l’utilisateur, hi hi.

Mais en fait je voulais reposter pour dire qu’en fait, ca ne marche qu’avec le root. Pour tous les autres utilisateurs (j’en ai recréé un pour tester) ca se bloque.
En fait pour l’utilisateur vins, la je vois l’écran bleu de X qui se lance, et hop ca coupe.
Pour les autres, je vois le splashscreen qui s’en vas vers 28%. Et la, l’écran bleu de X reste, mais il est bien vide !

Voila, y a que root qui veut bien se connecter en interface graphique (kde, c’est la seule qui existe chez moi). Je ne comprend pas trop la subtilité la (à moins qu’il y est un ptit problème de droits, mais ca serait surement mentionné quelque part dans ce cas).

pour le PS, j’ai trouvé ce que je voulais savoir, je pensais que ca pouvais venir de la (que le dcop etait lancé dans cette zone la !), mais non :
~.kde/share/config/session/

Remoi, en fait maintenant, les autres utilisateurs peuvent se connecter.
Donc il y aurait bien une solution bourrin : sauvegarder le home de vins (ce qui est necessaire du moins), supprimer cet utilisateur, le recréer, et recopier ses préférences.
Cependant, je me demande vraiment si l’on peut tout virer comme ca, parce que si il faut que cet utilisateur reconfigure quelques trucs, ca risque de gueuler !!!

Aussi je viens de me rendre compte qu’en fait, je n’ai pas répondu au PS dans le message précédent, mais a la deuxieme partie de mon message.
Pour le PS c’est tout simple ma question : l’ordi démarre, et j’aimerais que, pour tous les utilisateurs, un paquet de commandes comme :
setkeycodes ex03b 215

soient lancées. MAIS pour lancer cette cmomande (setkeycodes), il faut etre en root. Et aucun de mes utilisateurs n’est dans le groupe sudousers et j’aimerais que cela reste ainsi. Donc pas de cmomande sudo setkeycodes… possible pour moi.

Remerci d’avance !

Eh bien voila, problème résolu !!!

Ce que j’ai fait, au cas ou ca puisse intéresser quelqu’un :
En comparant les différents utilisateurs (en fait deux seulement, celui a un problème et un tout neuf !), j’ai fais un peu le ménage dans mon home (qui existe depuis la mandrake 9 quand meme), et depuis tout va bien.

J’ai aussi remarqué en regardant le fichier /var/log/messages que au moment du plantage (vers 13h ce dimanche 6 mars 2005), il y a eu un petit problème d’une part avec les configuration de ~./gconf, et surtout du splashscreen. J’ai donc enlever les fichiers du gconf (je ne pense pas que cela posait problème, mais bon), et j’ai modifié le fichier ~/.kde/share/config/ksplashrc en remplacant le thème de démarrage par le thème blue-bend.

Voila, c’est tout !!!

Merci pour tout !

Encore une fois moi, c’est la dernière fois cette fois justement.

J’ai aussi trouvé la meilleure méthode pour mon truc de lancement de commandes en root automatique au démarrage et pour tous les utilisateurs, le pire c’est que je le connaissais (mausvaise mémoire donc) !!!

Il suffit de rajouter les commandes dans le fichier /etc/rc.local. Ainsi ces dernières seront lancées juste après la phase d’initialisation et de lancement des modules du noyau, et avant de loguer un utilisateur.

VinSBOSS : bon boulot
C bon de régler --seul-- qlqs probs d’un coup, hein ,)

c’est clair que ca fait plaisir, on se sentirais presque intelligent !!!