Forum Clubic

Décalage sonore sur vidéo [résolu (enfin presque)] - Virtualdub, synchronisation

:hello: les gens

J’ai une vidéo surlaquelle j’ai un décalage au niveau du son

au fur et à mesure que la vidéo se passe le son est de plus en plus décalé :frowning:

j’ai essayé ce tuto --> http://perso.wanadoo.fr/horizonpc/Divx/Vir…ml#synchroniser

mais cela n’a pas résolu mon problème (le résultat est que la vidéo qui sort de virtualdub est “accélérée” mais le son est toujours décalé :paf:)

Si cela peut aider j’ai ce message au démarrage de virtualdub lorsque j’ouvre la vidéo

http://membres.lycos.fr/memorex1234/1.JPG

:jap: de m’aider à resynchroniser le tout :slight_smile:

Bon j’ai trouvé une solution :smiley: (pas parfaite mais suffisament pour pouvoir regarder la vid’ sans être dérangé)

J’ai décompresser totalement l’audio pis recompresser :oui:

C’est pas parfaitement synchro sur la fin mais le décalage est minime :wink:

Moi de toute façon j’ai jamais réussi à obtenir un résultat parfait avec VirtualDub

J’ai comme l’impression qu’un décalage supplémentaire se créée lors de la retouche :paf: et ce même en full proccessing ou en direct stream…

Pour les décalages du son par rapport à l’image, il faut aller dans le menu “Audio \ Interleaving…”.

Si le son est décaler dés le début, il faut modifier la valeur de "Preload" dans le cadre "Audio block placement".

Si le son se décale de plus en plus au fur et à mesure du déroulement du film, il faut modifier la valeur "Delay audio track by" dans le cadre "Audio skew connection".
Mettre une valeur positive si le son est en avance.
Mettre une valeur négative si le son est en retard.

Hum merci de ton conseil :jap:
Moi ma methode n’était peut être pas franchement top : Je reduisait le nombre de fps si l’audio prenait de l’avance et inversement…

Disons que la méthode “normale” évite le réencodage de l’image et que du coup il n’y a pas de perte de qualité et c’est beaucoup plus rapide.

Je pense que ça évite aussi le réencodage du son en ne faisant qu’une resynchronisation.

ce problème est récurent et provient généralement d’un audio Mp3 en Vbr , il faut démuxer le son avec VirtualDubMod, et la réencoder en CBR…puis remuxer, cependant ce n’est pas toujours la cause du problème.

ouais merci les gars ça marche bien!!!!!