Forum Clubic

Debian etch : snmpd innaccessible sur le réseau

:hello:

Suite à la reinstallation et migration de mon serveur sur Debian R4 (auparavent Debian R3.1), je sèche complètement pour remettre en place mon monitoring snmp.

J’ai beau chercher dans tous les sens je ne comprends pas ce qui bloque donc voici dans l’ordre:

  • Debian Etch fraichement installé, et pleinement fonctionnel (samba, apache etc)
  • Pas de firewall actif sur le serveur ni sur la machine cliente
  • snmpd installé via apt-get install snmpd
  • Fichier /etc/snmp/snmpd.conf contenant ceci:

#       sec.name  source          community
#com2sec paranoid  default         public
com2sec readonly  192.168.78.0:24  public
com2sec readwrite localhost        private

####
# Second, map the security names into group names:

#             	sec.model  sec.name
group MyROSystem v1        readonly
group MyROSystem v2c       readonly
group MyROSystem usm       readonly
group MyROGroup v1         readonly
group MyROGroup v2c        readonly
group MyROGroup usm        readonly
group MyRWGroup v1         readwrite
group MyRWGroup v2c        readwrite
group MyRWGroup usm        readwrite

####
# Third, create a view for us to let the groups have rights to:

#           incl/excl subtree                          mask
view all    included  .1                               80
view system included  .iso.org.dod.internet.mgmt.mib-2.system

####
# Finally, grant the 2 groups access to the 1 view with different
# write permissions:

#                context sec.model sec.level match  read   write  notif
access MyROSystem ""     any       noauth    exact  system none   none
access MyROGroup ""      any       noauth    exact  all    none   none
access MyRWGroup ""      any       noauth    exact  all    all    none

# -----------------------------------------------------------------------------

*fichier /etc/default/snmpd suivant :


# This file controls the activity of snmpd and snmptrapd

# MIB directories.  /usr/share/snmp/mibs is the default, but
# including it here avoids some strange problems.
export MIBDIRS=/usr/share/snmp/mibs

# snmpd control (yes means start daemon).
SNMPDRUN=yes

# snmpd options (use syslog, close stdin/out/err).
SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid'

# snmptrapd control (yes means start daemon).  As of net-snmp version
# 5.0, master agentx support must be enabled in snmpd before snmptrapd
# can be run.  See snmpd.conf(5) for how to do this.
TRAPDRUN=no

# snmptrapd options (use syslog).
TRAPDOPTS='-Lsd -p /var/run/snmptrapd.pid'

Si je fais un snmpwalk en local sur le serveur tout fonctionne et j’ai bien tout qui s’affiche.

Un netstat -laptnu me donne:


Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat        PID/Program name
(...)
udp        0      0 0.0.0.0:161             0.0.0.0:*                          15119/snmpd
(...)

Mais, si depuis le PC Client (Windows Vista SP1) j’essai de me connecter ça coince.

J’ai essayé plusieurs logiciel comme OidView Professionnal, WalkSNMP agent, ou hilisoft MIB Browser… et aucun n’arrive à trouver le serveur.
Afin de m’assurer que cela ne vienne pas du poste client j’essai alors de taper vers mon routeur, un WRT54G sous firmware sveasoft Alchemy… et là ça marche, j’ai bien accès aux infos SNMP auxquelles je suis censé avoir accès. Le client est donc hors de cause.

Qu’est-ce qui peut bien bloquer au niveau du serveur ??
Pas de firewall, snmpd qui ecoute sur tout le reseau et toutes les interfaces etc… et pourtant ça ne marche quand même pas!! Groumpf!

Un grand merci à ceux qui pourraient faire avancer le schmilblick

:hello:

bon ben …

mais sinon ?

:stuck_out_tongue:

bien bien bien …

Tu pourrais dire quel est ton problème ? Qu’on puisse t’aider …
Tu as essayé de faire un snmpwalk -v 1 -c public adresse_ip_distante ?

Pour ton fichier /etc/default/snmpd, tu dois modifier ça.

TRAPDRUN=yes
TRAPDOPTS=’-On -Lsd -p /var/run/snmptrapd.pid’
Edité le 11/06/2008 à 10:10