Forum Clubic

Debian> apache non accessible depuis l'exterieur

voila, j’ai un P3 500 avec 192 MO DDR auquel j’ai installé debian (la dernière version stable dispo) et apache2. Je possède aussi une connexion Free et la Freebox est en mode “non routeur”. Par contre elle est branchée sur un routeur DLink DI-624 je crois. J’ai ouvert le port 8000 en spécifiant bien l’adresse de ma debian mais problème : apache n’est pas accessible depuis l’extèrieur. vous pouvez d’ailleur essayer Mon Apache. Ce qui est bizarre, c’est qu’il est parfaitement accessible à partir d’un PC branché en réseau local.

Après essai de connection sur ton serveur il me semble que la connection est refusée par l’hote. Vérifie si tu as un firewall actif avec ta debian que le port 8000 soit ouvert et accessible depuis la zone Net.

je sais pas trop comment si y a un firewall sur debian (iptables n’existe pas). Y a un truc encore plus bizarre, c’est qu’a chaque fois je redemarrde le serveur, apache est accessible depuis l’exterieur mais que temporairement apres, je sais pas ce qu’il se passe mais ca ne marche plus

Cela me conforte dans mon opinion à savoir que il y a un firewall lancé sur cette machine. Tu doit ouvrir le port 8000 de ce firewall . Malheureusement je ne peut te dire quel firewall est utilisé il y en a quelques uns. Peut-être quelqu’un utilisateur d’ une debian pourra t’aider sur le firewall installé par défault s’il y en a un.

Ca marche. :ane:

je confirme ça marche tu peut marquer ton topic comme résolu

non ca marche pas terrible. A chaque fois, le serveur apache tombe au bout d’un moment. J’ai été obligé de faire un script qui reload le serveur apache toutes les 10 minutes.

while [ true ]; do
/etc/init.d/apache2 reload
sleep 600
done

:paf:

spa propre !

ya quoi dans les logs quand il plante ?

c’est bien ca le problème. Il ne plante meme pas. Apache est tojours en execution. Je ne sais pas comment résoudre ce P***** de problème

rectification : apache segfault

:smiley: c’est pas pareil

tu peut copier les 10 dernières lignes de logs avant le plantage ?
tu as installé apache depuis apt ?

salut,
colle ta conf httpd.conf et sinon dans listen t’as mis quoi ? *:80 ?

tu peux aussi lancer apache -S pour verifier la syntaxe de la conf, et un tail /var/log/httpd-error.log ?

c’est pas le port 80 (et pas le 8000) normalement ?

t’en fiche ca tu le config comme tu veux (port.conf je crois)

et y’aurait pas de base une option pour bloquer les ips n’appartenant pas au même réseau (par protection) ?
Il me semble que j’avais ça sur mon serveur (mais l’abus d’alcool me joue parfois des tours :ane:)

ok laissez tomber, meme dhclient segfaulte de temps en temps. Je pense que c’est finalement du a un probleme materiel. Laissez moi le temps de faire un test de memoire vive et je vous donne le resultat.