Forum Clubic

Debian 2.6.18-6-amd64 et perl i686

Bonjour. Voila j’ai un serveur linux 2.6.18-6-amd64 (donc en 64 bits) et je doit absolument installer la version de perl: 5.8.8 for i686-linux-thread-multi ( qui je pense est 32bits)

Es-ce possible? es-ce conpatible?
Sachant que j’ai essayé de la trouver sans succes !!!
De meme, j’ai l’impression qu’en 64bits, le noyau le plus récent est 2.6.18 alors que sont mon ubuntu a moi (32bits) je suis deja au 2.6.24 (de memoire)

qq’un a une idée?

Merci
Edité le 28/08/2008 à 10:23

Ben pour les versions du noyau, l’un est un debian l’autre une ubuntu, donc c’est un peu normal que les versions des paquets soient différentes.
Pour perl -> pourquoi ne pas prendre une version amd64 de perl multi thread ?!
Fait confiance au gestionnaire de paquets.
Edité le 28/08/2008 à 10:27

Et bien parce que je dois installer un logiciel très specifique qui impose cette version de perl et pas une autre !
Edité le 28/08/2008 à 10:24

Ok
Ca peut fonctionner, mais tu devras installer sans apt (ie, dpkg seul en forçant l’install du paquet que tu auras téléchargé à la main) ou bien en recompilant en précisant une cible i686
Edité le 28/08/2008 à 10:27


PS : Fait gaffe à ne pas casser pas trop de trucs, perl c'est le genre d'outils utiles ...
au fait, le soft en question cherche cette version précise dans les logiciels installés ou bien c'est un problème de compatibilité au niveau du binaire ?
man [pwet.fr...](http://pwet.fr/man/linux/commandes/dpkg) l'option "architecture" ... ;)

Tiens je n’ai jamais compilé perl mais au pire ça doit se laisser faire assez facilement.

Le pire cas que j’ai vu étant de devoir compiler une appli qt4 sur une redhat4…c’est possible…mais à la fin on a plus une LFS qu’une redhat4 :). Enfin bon les biiiiiiiiiiip du controle config était heureux de dire qu’on tournait avec une redhat4 comme écrit dans la doc :frowning: