Forum Clubic

[CSS/(x)HTML] ]Problème de menu :(

Voila c’est plus explicite : http://darkvengercs.free.fr/test/index.htm
Le début de menu s’affiche avec IE mais pas sous FireFOx :frowning:
J’ai aussi un autre soucis pendant que j’y suis, lorsque je mets le DOCTYPE bein ça décale tout le site :slight_smile:

Pour le css :
http://darkvengercs.free.fr/test/styles/style.css

peut-etre parce que tu ne ferme pas [/url] [:______]

Je l’avais oublié et uploadant :frowning: mais non ça ne vient pas de ça :frowning:

Pas compliqué, quand tu fous le DOCTYPE IE fait du Switching de DTD (ie: il change le mode Quirks Mode pour Standard Compliance Mode et ainsi de suite)

Quel DTD mets tu ? Que fais tu exactement ?

J’ai pas trop compris ce que tu m’as expliqué :frowning:
Je débute en codage xHtml et CSS :confused:
Si tu pouvais m’eclaicissir stp :slight_smile:
Et sinonp our le menu qui s’affiche pas sous Ie t’as pas une idée stp :slight_smile: ?

ajoute un display: block; sur ton lien, Mozilla l’affichera bien. Et ferme ta balise

Deja ça s’affiche sous FireFox avec ce que tu m’as donné merci :slight_smile:

Voila ce que j’ai fais :
http://darkvengercs.free.fr/test/Avenger.htm
Et voila ce que je voudrais faire en gros : http://darkvengercs.free.fr/Avenger/Avenger.htm

Mon css :

/* Feuille de style by Avenger */

body
{
margin: 0;
background-color: #B2C8E1;
text-align: center; /* pour corriger le bug de centrage IE */
}

#global
{
margin-left: auto;
margin-right: auto;
width: 760;
}

.head1
{
background-image: url(’…/images/head1.jpg’);
height: 135px;
width: 760px;
}

ul
{
list-style-type: none;
} /* on supprime les puces, inutiles */

.menu a
{
height: 30px;
width: 95px;
display: block;
color: #000;
background-image: url("…/images/test1.png");

}

.menu a:hover
{
background-image: url("…/images/test2.png");
height: 30px;
width: 95px;
}

et le html :

Avenger : Community

J’éspère que qqun pourra m’aider car les menus j’y pige kedal :frowning:

ajoute un float: left en plus du display: block

ça change rien :frowning:
Et tu sais pourquoi il y a un décalage entre l’image du haut et le menu aussi ?

Parce que tu utilise ul ?

J’en ai marre :d
Ca fait depuis hier que je suis dessus :frowning:
Dis moi quelle est la meilleur solution que je evrais utiliser car la je me dirige dans 50 directions et j’arrive jamais à le faire fonctionner ce manu :cry:

par exemple :

machin[/url] ...

#menu a { display: block; float: left; }

Voila : http://darkvengercs.free.fr/test/Avenger.htm :slight_smile:
Comme d’habitude ça aurait trop beau que ça marche du premier coup :confused:
Bon dejà sous IE ya un logo qui passe à la ligne inférieur :frowning:
Et sinon c’est quoi le code pour centrer le texte mais verticalement ?

merci :slight_smile:

y en a pas trop pour centrer, y a vertical-align: middle mais c’est pas comme si c’était performant. Pour ton prob d’IE : réduit la taille.

C’est bon j’ai trouvé pour centrer :wink: (avec la police ca la mis au milieu presque :slight_smile: )
Euh sinon quand tu dis de réduire la taille :), la taille de quoi ?
DEs images du menu ?
Bein ne fait j’ai fait 760px e largeur sur le site et chaque image fait 95px
95px * 8 = 760px c’est aps normal que ça rentre pas :cry:

http://darkvengercs.free.fr/test/Avenger.htm