Forum Clubic

Créer une ligne Dos avec extension .bat pour créer une tâche

Bonjour à tous ! :hello:

Je cherche un moyen de copier un fichier dans un dossier une fois par semaine à la même heure et j’ai suivi la méthode suivante :

http://forums.futura-sciences.com/logiciel-software-open-source/23909-copier-un-fichier-automatiquement.html

Aussi, j’ai créé cette ligne :

copy “C:\Documents and Settings\Compaq_Propriétaire\Bureau\Capuche.txt” “C:\Documents and Settings\Compaq_Propriétaire\Bureau\Nouveau dossier (3)”

dans un fichier .txt que j’ai renommé en .bat et j’ai tenté de créer une nouvelle tâche mais, à chaque fois j’ai le message suivant :

La nouvelle tâche a été créée mais, elle ne pourra peut-être pas fonctionner car, les informations sur le compte n’ont pas pu être déterminées. L’erreur spécifique est 0x80070005.Accès refusé.
Essayer de localiser l’application avec le bouton parcourir de la barre des tâches.

Lorsque je double-clic sur mon fichier.bat, une fenêtre DOS s’affiche et se referme immédiatement mais, la copie ne se fait pas. :etonne2:

Que dois-je faire ?
Ai-je fais une erreur dans la ligne ?

Merci de vos réponses.:bounce:

Il me semble que pour pouvoir créer une tâche planifiée, il faut que ta session utilisateur soit protégée par un mot de passe, lequel doit être identique à celui nécessaire pour créer cette tâche!

Met un espace entre “copy” et l’adresse source
Il faut essayer d’éviter les accents sous DOS mais je ne pense pas que le probleme vienne de là… ( “Compaq_Propriétaire”)
Y a t’il moyen de changer l’adresse (plus court et sans espaces) initale et l’adresse de déstination ? (ex : C:\Compaq\Capuche.txt )
Tu peut rajouter un “pause” a la fin du script, juste pour voir la réponse DOS (tu le retire aprés ,c’est juste pour la verif…)

Ex :
copy C:\Compaq\Capuche.txt C:\Sauvegarde
pause

Re-bonjour !

J’ai modifié mon fichier .bat avec le bloc-note (c’est bien avec le bloc-note ?) mais, çà n’a toujours pas fonctionné :

copy C:\Documents and Settings\Compaq_Propriétaire\Bureau\Capuche.txt C:\Capuche.txt

J’ai enlevé les guillemets, je les ai remis, j’ai raccourci l’adresse du répertoire mais, ça ne fonctionne toujours pas et j’ai toujours une fenêtre noir qui apparait et disparait sur l’écran sans que rien ne se passe.

Alors, j’ai téléchargé Robocopy mais je ne sais pas l’utiliser.

Est-ce que quelqu’un pourrait m’aider ?
Qu’est-ce qui pourrait copier un fichier dans un dossier ?

Merci de vos réponses.

Au fait, j’ai bien mis pause comme tu me l’as demandé et voilà ce qui s’affiche :

http://imagik.fr/thumb/175591.jpeg

Que dois-je faire ?
Edité le 11/12/2008 à 15:13

Merci beaucoup pour ton aide Beneflo !

J’ai enfin trouvé ce qui ce passait !

En fait, Windos n’a pas l’air du tout d’aimer le “é” de “Compaq Propriétaire”.
J’ai changé plusieurs fois le chemin d’accès et la copie n’a fonctionné que lorsqu’il n’apparaissait pas dans le chemin d’accès. (C:\Capuche.txt).

Même avec les guillemets, çà ne marchait pas : il ne faut pas d’accents.

Encore merci !

c’est bien ce que je t’avais mentionné ds mon premier post…

Ravi de t’avoir aidé dans ton probléme…

A+

Si tu crées ton .bat avec le bloc notes, tu utilises une police ANSI, alors que DOS travaille avec une police ASCII/OEM
Il faut que tu crées ton fichier avec la commande Edit du DOS, et là tu n’auras plus de problème.
A la limite, tu la crées sous windows, c’est quand même plus pratique, et ensuite tu edites ton fichier .bat sous DOS pour corriger les accents et autres caractères.
Personnellement, j’utilise pspad qui permet tout en étant sous windows d’utiliser la police OEM

Salut,

T’as essayé :

copy C:“Documents and Settings”“Compaq_Propriétaire”\Bureau\Capuche.txt C:“Documents and Settings”“Compaq_Propriétaire”\Bureau"Nouveau dossier (3)"\

Sinon fais comme gcc a dit, c’est une bonne solution
Edité le 11/12/2008 à 19:00

Essaye plutôt copy “C:\Documents and Settings\Compaq_Propriétaire\Bureau\Capuche.txt” “C:\Capuche.txt”

ie: des double quote (") pour protéger les chemins.

Rebonjour et merci pour vos réponses ! :slight_smile:

Ma ligne de commande a bien marché sous Windows XP mais, lorsque je l’ai essayé sous Vista, ça n’a pas fonctionné !

J’ai du modifier les droits administrateurs et supprimer le contrôle de compte utilisateur mais, çà n’a pas suffit.

Maintenant, il copie bien mais, il ne remplace pas le fichier précédent :
ça n’a fonctionné que lorsque j’ai supprimé le fichier a remplacer.:sweet:

Est-ce que quelqu’un pourrait m’expliquer ce que je dois modifier dans ma ligne de commande pour qu’il remplace ?

Merci par avance. :slight_smile:

Salut,

Rajoute une “/Y /E” a la fin de la ligne.
Cela permet de répondre “yes” automatiquement aux demandes de remplacement de fichiers (que tu ne vois pas car c’est une tache planifiée).

Tiens nous au jus si ça marche ou pas !

a+

(EDIT : /y sert pour la réponse automatique. Le /e je sais plus trop pourquoi, mais ça ne faisait pas de mal de toute façon à l’époque où je faisais des scripts de sauvegarde.)
Edité le 19/12/2008 à 15:58

Tu es sûr que ce n’est pas /V au lieu de /E ?

Re,

rectification : /E à ne pas mettre si on utilise la commande “copy”

/E est une option pour tout copier (répertoires et sous répertoires y compris ceux qui sont vides… Mais elle n’est valable que pour la commande XCOPY (que je préfère d’ailleurs)