Forum Clubic

Création d'un réseau sans fil sous linux

Bonjour,

J’aimerai configurer un réseau sans fil sous linux où je connecte mon serveur linux sur l’ADSL et ensuite, c’est lui qui sert de routeur pour les autres ordis chez moi. Cela est-il possible? Si oui, quel est le matériel nécessaire svp? J’ai pensé à faire ça en wifi mais je ne trouve que peu de choses pour Linux (de plus, j’aimerai éviter de passer par un routeur et que ça soit le serveur qui donne les adresses IP). Wifi, Bluetoothe, quelle serait la solution idéale?

Merci d’avance de votre aide.

oui c’est possible :wink:

depuis la version 2.6 (si je ne dis pas de betise sur le chiffre) le Wifi est integré au noyau de linux. donc si tu as une distribution recente ça ne posera pas trop de soucis à installer.

une fois le wifi installé, ça ne fera aucune difference à configurer qu’une autre carte reseau filaire;)

Par contre oubli le bluetooth, c’est pas fait pour ça.

Pour le materiel => CF FAQ du forum :wink:

En gros, je voudrais savoir s’il me suffisait de mettre une carte réseau sans fil à chaque PC ou alors s’il me fallait passer par un routeur obligatoirement (je pense que le concept de hub pour sur sans fil est inexistant :whistle: ). Merci d’avance :jap:

edit pour dire que j’ai la distribution Red Hat 7 (la dernière je crois)

perdu :slight_smile:

le hub est remplacé par ce qu’on appel un point d’acces Wifi.

On peut se passer du point d’acces, mais à partir de 3-4 Pc les perfs du reseau s’ecroulent

http://forum.clubic.com/forum2.php?config=clubic.inc&post=282&cat=27&cache=&sondage=0&owntopic=0&p=1&trash=0&subcat=117

:wink:

Merci pour vos réponses, j’ai peu en effet créer mon réseau entre 2 PC pour l’instant grace à un point d’accès Belkin (je ne connaissais pas mais ça marche bien). Pourtant, j’ai un petit problème car je viens de rajouter un autre PC et outre des problèmes de clefs originellement, il ne veut pas définir son IP (en fait, j’ai beau pinger, il ne voir rien alors qu’il est pourtant connecté :/). Les 2 PC que j’ai connecté sont sous XP mais celui chez qui ça marche est sur XP home et celui sur qui ça ne marche pas est sur XP pro.

Merci de votre aide à nouveau :slight_smile:

Stéphane