Forum Clubic

Création de mon propre Serveur, Questions multiples

Bonjour à tous,

Jouant à CSS (CounterStrike Source, FPS), et voyant les prix assez élevés (pour ne pas dire exorbitants) des serveurs CSS loués par des sociétés comme VeryGames, RedLine, EVG, Inter-Medias et j’en passe, j’ai dans l’idée de créer mon propre serveur.

Questions :

  1. Faut-il que je fasse une 2ème tour pour faire ce serveur, ou la puissance de ma machine suffit-elle ?
    (Ma config’ est dans mon profil)
  2. Le serveur a-t-il des exigences en terme de composants (ex : tant de RAM, etc.) ?
  3. Pourriez vous me donner un exemple de config’ qui pourrait servir de serveur ?
  4. Faut-il une très bonne connection pour avoir un serveur compétent ?
    (Quand je parle de serveur compétent, je parle d’un serveur ‘‘qui touche’’, pour les connaisseurs…)
  5. Y aura-t-il des manipulations à faire pour que le serveur fonctionne pour ce dont il est disposé ?
    (Aurais-je à utiliser un FTP de la même façon qu’un ‘‘locataire de serveur payant’’ ?)
  6. Dois-je racheter un OS pour le serveur ? (Question qui peut paraître un peu conne je le reconnais…)

Je précise que je dispose d’une carte mère Gigabyte MA-GA790GP-DS4H et d’une ATI 4870 512 Mo, et 1 Go de RAM P8500PK (RAM que j’enlèverai de ma config’ 1), si besoin est.

Voilà. En espérant obtenir de l’aide de votre part, et en vous remerciant d’avance.

Bonne journée.

Personne pour m’aider ? :frowning: Je suis malheureux là…

Pour faire un serveur l’élément à privilégier c’est la connection internet(connection<8Mbits n’y pense même pas sauf pour très peu de joueurs) pour avoir que les joueurs disposent de ping correct.
Ensuite niveau configuration, prévoit un bon processeur (quadcore de préférence) et de la RAM (4Go préférable)
Ensuite pour l’OS il me semble que tu as le choix avec linux ou windows donc c’est selon tes préférences. (avec linux moins de risque de plantage).
La carte graphique n’intervient pas dans un serveur tu peux en prendre une bas de gamme.
Ensuite pour faire un serveur il faut prévoir de laisser tourner ton pc 24h/24 pour qu’il se fasse connaître.

Donc en ajoutant plus de RAM et en connaissant ton proco ainsi que le débit et la qualité de ta connection je pourrais te dire si tu peux en faire un serveur.
Le mieux étant une machine dédiée pour cet usage.

En connexion, ile semble que j’ai 8 Mbits (c’est, je pense, le problème), ma config’ tu la connais un peu…mais de toute façon je comptais faire un serveur à part…
Pourquoi aurais-je besoin de 4 Go ? (Avec un serveur dédié)
Ai-je vraiment besoin d’un processeur puissant ? (de toute façon je comptais mettre mon 940 BE)
Je mettrai quand même une carte graphique (4870), car ce serveur aura une double fonction, serveur et PC pour les lans.

Pour ma part j’avais pensé à la config’ suivante :

Boîtier : Lian Li PC-A05N
Alimentation : OCZ ModXStream Pro - 500W
Disque dur : Seagate Barracuda 7200.12 S-ATA - 500 Go - 16 Mo
Graveur : Samsung SH-S223C
Processeur : Phenom II X4 940 BE
Carte mère : Gigabyte GA-MA790GP-DS4H
Mémoire : 2 x 1 Go G.Skill P8500PK
Système d’exploitation : Microsoft Windows 7 Edition Familiale Premium 32 bits (oem)

Mon but c’est quand même de récupérer le plus possible de choses sur mon autre config’, je compte donc récupérer, une 4870 (que j’ai déjà virée), le ventira Noctua avec un seul ventilo (je garde le deuxième ventilo pour ma config’ principale auquel je mettrai un Xigmatek Thor’s Hammer S126384 ou autre…), 1 Go de ram (je rachète donc 1 Go seulement pour le serveur), la CM que j’avais déjà puisque j’en ai achetée une autre.

Alors je veut pas être pessimiste mais, avec ta connexion de 8mb tu as un peut moins de 1mb d’envois, tu ne pouras pas hébergés de partie avec plus de 6/8 joueurs en simultanés.

De plus :

  1. Faut-il que je fasse une 2ème tour pour faire ce serveur, ou la puissance de ma machine suffit-elle ?
    Pour moi oui, sachant que tu auras en plus des soucis de configuration de resau c’est pas forcement évident de tout routé sans routeur (vrai routeur pas une box)

  2. Le serveur a-t-il des exigences en terme de composants (ex : tant de RAM, etc.) ?
    Beaucoup de RAM 4Go me semble pas mal, le proc un bon core2duo devrais suffir

  3. Pourriez vous me donner un exemple de config’ qui pourrait servir de serveur ?
    Serveur dédier heberger en datacentre.

  4. Faut-il une très bonne connection pour avoir un serveur compétent ?
    (Quand je parle de serveur compétent, je parle d’un serveur ‘‘qui touche’’, pour les connaisseurs…)

Ben la tu toucheras pas grd chose, des que vous serrez 5/6 sur le serveur tu auras des lags

  1. Y aura-t-il des manipulations à faire pour que le serveur fonctionne pour ce dont il est disposé ?
    (Aurais-je à utiliser un FTP de la même façon qu’un ‘‘locataire de serveur payant’’ ?)
    Bien sur tu pourras déposez tes fichier en direct tu ne doit pas forcement recourir à un FTP

  2. Dois-je racheter un OS pour le serveur ? (Question qui peut paraître un peu conne je le reconnais…)
    Serveur stable = linux debian ou fedora.

D’ou je tire mes information ?
Je gère sur internet des serveur dédié depuis 10 ans maintenant :slight_smile:

Bref pour finir, je te conseil une machine payante chez un vrai hebergeur sinon tu vas faire du bricolage rien de serieu.
Nous pour prendre notre premier serveur, ont c’est cotiser à plusieurs :wink:
Tu as des bon serveur à partir de 50€/mois comme ici[/url] ou [url=http://www.kimsufi.com/ks/]ici
Voila mon avis perso :slight_smile:

Je ne connais pas le serveur dédié de css mais si tu es sous vista ou seven il vaut mieux avoir un peu de RAM en plus pour éviter de swapper sur le disque dur.
Sous xp effectivement 1Go suffit.

Ps: Pas mal l’astuce pour que je réponde à ton topic :wink:

Salut,

vu le prix des serveurs (30€/mois pour un intermedias Pro sa touche très bien), je ne dépenserais pas d’argent dans une config supplémentaire pour faire serveur surtout si vous le payé à plusieurs comme le dit ThMan. De plus l’installation de debian, mise à jour du noyau, install et configuration c’est pas aussi que simple que ca (j’ai du le faire sur une machine OVH).
Edité le 20/05/2010 à 11:02

Donc que conseilles tu ?

Merci pour tes réponses, mes principales lacunes concernaient surtout ce qui est en rapport avec la connexion, cependant je dois prendre mon 940 BE comme processeur étant donné que la carte mère dont je suis censé me servir est sur socket AM2+ (donc pour le Core2Duo…).

Sinon pour lamedor : je ne comptais pas faire un serveur ‘‘FFA’’ mais un serveur War, ça ne nécessitait pas de le faire connaître ni de le laisser allumer 24/24 (et ça n’a besoin que de 11 slots (10 joueurs + 1 source TV), mais merci quand même…

En fait les seules choses dont je dispose sont ‘‘inutiles’’ à ce que je veux faire…

Pour la location de serveur payant, ça ne m’intéresse pas, même si je sais que les serveurs OVH sont très bons…
J’aime pas l’idée de la location, tu payes aussi cher qu’un crédit et tu le possèdes jamais…

Je pense que je vais attendre d’avoir un studio, pour acquérir une connexion digne de ce nom et pouvoir monter ce petit projet (en sachant qu’une machine de qualité me coûterait environ 500 € à l’achat, ça équivaut à un investissement rentabilisé en 10 mois, en prenant bien sûr un serveur à 50 €/mois à titre de comparaison) à condition d’en avoir encore l’intérêt à ce moment là…

(Pas besoin de te justifier pour tes réponses, je l’aurais détecté si tes propos avaient été incohérents…De toute façon tu t’exprimes bien donc ç’est déjà un gage de ‘‘professionnalisme’’ :jap: )

Merci encore pour ces informations qui m’ont bien éclairé.

Pendant que t’es là, j’ai un soucis avec la connexion de mon PC que voici :

Lorsque je branche le fil ethernet (rouge) Orange qui est censé si je ne me trompe pas être à 100 mbits/s, ça marche mais je n’ai un débit que de 10mbits/s…Dans les réglages de la connexion il est bien stipulé ‘‘négociation automatique’’, les autres réglages semblent bons aussi…Je précise que les informations de ma carte mère relatives à ma connexion sont les suivantes : Contrôleur réseau Realtek® 8112 ; Vitesse du contrôleur réseau 1000/100/10 Mbps (Gigabit).

J’ai bien activé la fonction ‘‘Realtek Lan Cable’’ dans le BIOS, qui visiblement semble être en rapport direct avec la connexion ethernet (c’est un peu con ce que je dis mais on sait jamais…).

Question : Selon toi quel serait le problème ?

N’hésites pas à me demander des informations nécessaires à l’aide que tu pourras éventuellement me fournir si toutefois tu le souhaites…

Merci encore.
Edité le 20/05/2010 à 11:50

Une carte mère am2+ peut recevoir sans problème un processeur am3 (sauf les x6 1090T et compagnie)
Ensuite concernant ton problème de connection celà peut venir soit de la carte réseau qui n’est pas bien installé ou paramétré dans windows.
Dans ce cas là essaye d’aller dans le gestionnaire de périphériques et de reinstaller ta carte en cliquant droit et en faisant desinstaller.
Ensuite redemarre ton pc normalement ça devrais marcher.
Sinon si effectivement ça viens du bios essaye de mettre les réglages par défaut.

Mais bon de toute façon même à 10Mb/s ta connection ne devrais pas être bridée.

Je le sais qu’une carte AM2+ supporte un processeur AM3…Quand même !
Mon but c’était de mettre le 940 BE que j’ai sur le serveur et de mettre un 955 BE sur ma config (chose qui prouve que je voulais vraiment t’acheter ton processeur et non pas juste faire semblant de le vouloir pour que tu répondes à mon sujet…).

Pour la connection : J’ai déjà essayé de désinstaller etc. Je pense plus pour le problème de paramètrage…Le mieux ça serait que je marque tous les paramètres et qu’on me dise s’ils sont bien réglés…

Pour la carte réseau, je n’ai jamais fait d’installation à proprement parler, mais si elle fonctionne en 10 Mbits/s c’est qu’elle fonctionne quand même…

Je ne vais pas me contenter de 10 Mbits/s alors que je suis en ce moment en Wifi N 54 Mbits/s…

Bon après-midi.

Pardonnes moi pour la confusion, je croyais que tu pensais ne pouvoir mettre qu’un processeur am2+ sur ta carte mère…
Et as tu essayé d’installer ta carte réseau avec les pilotes fournis sur le cd de ta carte mère ?
Pour paramétrer votre carte réseau il n’y a que dans le gestionnaire de périphériques que l’on peut agir il me semble pour ce problème.
J’essaierais de te faire une capture d’écran ce soir pour te montrer à quel endroit exactement agir.
As tu essayé aussi de changer de port RJ45 de ta livebox ?
Bonne journée à toi aussi :wink:
Edité le 20/05/2010 à 14:52