Forum Clubic

Copie-coller sous dos

Bonjour
voila je voudrais copier un fichier (n’importe quoi) par exemple dans un repertoire c:\1 dans un repertoire c:\2 mais avec un fichier bat sous dos
Merci

bah, vu que dans tous les cas tu devras donner un nom de fichier, autant utiliser la commande copy

sinon, copy c:\1\* c:\2\ devrait suffir pour tout copier d’un répertoire à l’autre.

heu, je dirait . plutot non ?

Je crois que le . ne cible que les fichiers alors que le * tout court cible tout le contenu du répertoire source.

@confirmer

xcopy /s pour copier toute une arborescence. Il y a plein d’options intéressantes dans xcopy, ne pas hésiter à faire un xcopy /?
Et pour effacer les arborescences, ils ont enlevé deltree; il y a del /s, mais ça fait moins classe. :smiley:

Ben si tu mets * tous les fichiers vont etre copié et si tu met . tous les fichiers qui possedent un "." dans leurs nom vont etre copiés. :jap:

Bonsoir,

Je me permets de faire ressurgir ce topic car j’ai un souci.
J’ai besoin de copier des dossier depuis le DD interne de mon ordi (c:) vers un DD branché en USB (h:).

Le problème, c’est que je ne peux plus utiliser le copier/coller classique à cause d’un sombre probleme de svchost…bref, la seule solution qu’il me reste pour faire du copier/coller, c’est DOS.

Or, avec copy, je n’y arrive pas.

Voilà ce que je mets. Peut-être que je m’y prends mal ?

C:\Documents and Settings\MOI>copy c:\Documents and Settings\MOI\Bureau\fichier.txt h:\NOUVEAU

Bien entendu, le C:\Documents and Settings\Moi> est là dès l’ouverture de la fenetre cmd et ne s’efface pas.
Là dessus, je fais “Entrer”…et il me sort que le fichier est introuvable…

Si vous pouviez m’aiguyer, ce serait cool…

d’avance, merci :slight_smile:

problème basique, il faut rajouter des guillemets aux chaines de caractere qui comportent un espace :

copy "c:\Documents and Settings\MOI\Bureau\fichier.txt" h:\NOUVEAU

:slight_smile:
Edité le 03/10/2008 à 19:17

Bah c’est sympa d’avoir répondu si rapidement, merci :wink:

Effectivement, c’est basique, mais mine de crayon, ça a reglé en partie mon problème.

Sinon, dans la continuité : comment faire pour copier le contenu de toute une arbo ?
Idéalement, j’aimerais copier tout ce que contient le dossier “c:\Documents and Settings\MOI” (càd Mes Documents et tout le reste) vers h.

Or, avec copy “c:\Documents and Settings\MOI*” h:\NOUVEAU, il copie les fichiers contenus dans “MOI”, mais pas les dossiers qui y sont.

N’y a-t-il aucune solution ?
Faut-il passer par Xcopy ? (d’ailleurs c’est quoi, un logiciel, une invit de commande ?)

Merci !

Il faut passer par xcopy oui. C’est exactement comme copy, mais en récursif (et un peu plus souple). La syntaxe de base doit être la même je pense, donc tu peux essayer la même commande en remplaçant “copy” par “xcopy” :wink:
Edité le 03/10/2008 à 20:36

:slight_smile:

J’ai donc essayé avec xcopy…avec la commande suivante, puisque j’en ai eu marre de donner dans la dentelle :

xcopy c:*.* h:NOUVEAU*.* /s/e/v/h

ça marche pas mal…jusqu’au moment où il arrive au répertoire Documents and Settings. Il copie parfaitement certains dossiers qui s’y trouvent (y compris des dossiers relatifs à d’autres “users”)…jusqu’à arriver à c:\doc & settings\MOI. Du dossier MOI (autrement dit, celui contient mes documents, mon bureau, etc), il ne copie que les fichiers et non les dossiers qui s’y trouvent…car le processus de copie s’arrete avec ce message : violation de partage.

A quoi est-ce dû ? Y’a-t-il moyen de contourner ce problème ?

Merci, encore et toujours.

Bon, je laisse tomber.

XCOPY est limité à des transferts de 4 Go et des bananes. Je vais sortir mon dur, le mettre en slave dans la carlingue d’un pote et récupererai mes données comme ça.

C’est windows qui te verrouilles tes fichiers
Il faut que tu fasses la manoeuvre après avoir redémarré en invite de commande