Forum Clubic

Connexion ssh via clé privé/clé public

Bonjour,

J’ai un soucis pour faire communiquer 2 serveurs red hat .

sur root@bibi, j’ai généré une paire de clé RSA.
j’ai copié le contenu de ~/.ssh/idrsa.pub --> root@bubu:/root/.ssh/authorized_keys

Jusque la, j’arrive a me connecter de root@bibi vers root@bubu (il ne me demande pas de mot de passe)

Maintenant, je copie cette meme clé vers --> user@bubu:/home/user/.ssh/authorized_keys

et la, impossible de me connecter de root@bibi vers user@bubu sans qu’il me demande de mot de passe

mon sshd_config est classique:

SyslogFacility AUTHPRIV
PasswordAuthentication yes
ChallengeResponseAuthentication no
GSSAPIAuthentication yes
GSSAPICleanupCredentials yes
UsePAM yes
X11Forwarding yes
Subsystem       sftp    /usr/libexec/openssh/sftp-server
IgnoreRhosts yes
IgnoreUserKnownHosts no
PrintMotd yes
StrictModes yes
RSAAuthentication yes
PermitRootLogin yes
PermitEmptyPasswords no
GatewayPorts no
AllowTcpForwarding yes
KeepAlive yes
Protocol 1,2

Comment puis je faire pour que la connexion se face bien SANS mot de passe vers un user sur un autre serveur ?

Merci
Edité le 23/06/2011 à 12:40

Le mot de passe demandé, tu es sur que c’est le serveur en face qui le demande ? Ca serait pas ta clé qui est cryptée plutot ?

Il faut faire attention a plusieurs details :

  • le fichier authorized_keys doit avoir des droits tres stricts (600)
  • il me semble qu’il faut declarer ce fichier dans la conf sshd
    -utilise l’option "-i " pour tenter de te connecter ainsi tu seras sur d’envoyer la bonne clé…

Ensuite PAM peut foutre le bazar dans l’authentification de ssh. Faut chercher comment redhat configure ca par defaut… normalement, il ne devrait pas y avoir de probleme pour se connecter avec une clé mais sait-on jamais.
Tu peux mettre usePAM a no mais je te le conseille pas.

si les logs sont pas activés, fait le et consulte les. Sache aussi que ssh pond du log dans /var/log/messages (ou syslog) et dans /var/log/auth

Au final, j’avais tout recommencé, et la bizarrement ca marche .
j’ai peut etre mal copié les clé, ou je sais pas.
pb résolu