Forum Clubic

Connexion « directe » entre 2 PC sous W2000 Pro

Bonjour,

J’essaie de partager des fichiers entre 2 PC ayant chacun Windows 2000 Pro et qui sont connectés ensemble par des cartes réseaux via un câble ethernet inversé.

Les PC semblent se voir (le ping répond) mais je ne peux accéder aux fichiers.

J’ai cherché des tutos sur le net pour configurer mais y’a pas grand’chose sur W2K
(surtout du XP et du W95/98)

Voici les ipconfig et le ping entre les pc :


CONFIGURATION DE L’ORDI (P3) QUE JE VEUX CONNECTER À L’ORDI P2 :

C:\Documents and Settings\Christiane Gobeil>ipconfig /all

Configuration IP de Windows 2000

    Nom de l'hôte . . . . . . . . . . : ibm
    Suffixe DNS principal . . . . . . :
    Type de noud. . . . . . . . . . . : Diffuser
    Routage IP activé . . . . . . . . : Non
    Proxy WINS activé . . . . . . . . : Non
    Liste de recherche de suffixe DNS : no-domain-set.bellcanada

Ethernet carte Connexion au P2 : <= MA CONNEXION VERS LE P2

    Suffixe DNS spéc. à la connexion. :
    Description . . . . . . . . . . . : SMC9332BDT EtherPower 10/100
    Adresse physique. . . . . . . . . : 00-E0-29-09-A4-4E
    DHCP activé . . . . . . . . . . . : Oui
    Autoconfiguration activée . . . . : Oui
    Autoconfiguration d'adresse IP. . : 169.254.191.55
    Masque de sous-réseau . . . . . . : 255.255.0.0
    Passerelle par défaut . . . . . . :
    Serveurs DNS. . . . . . . . . . . :

Ethernet carte Connexion au Net avec Speedstream : <=MA CONNEXION DSL INTERNET VIA USB

    Suffixe DNS spéc. à la connexion. : no-domain-set.bellcanada
    Description . . . . . . . . . . . : Speedstream Ethernet USB Adapter
    Adresse physique. . . . . . . . . : 00-13-A3-44-B4-B2
    DHCP activé . . . . . . . . . . . : Oui
    Autoconfiguration activée . . . . : Oui
    Adresse IP. . . . . . . . . . . . : 192.168.2.21
    Masque de sous-réseau . . . . . . : 255.255.255.0
    Passerelle par défaut . . . . . . : 192.168.2.1
    Serveur DHCP. . . . . . . . . . . : 192.168.2.1
    Serveurs DNS. . . . . . . . . . . : 192.168.2.1
                                        192.168.2.1
    Bail obtenu . . . . . . . . . . . : April 9, 2008 11:32:37 AM
    Bail expire . . . . . . . . . . . : April 12, 2008 11:32:37 AM

C:\Documents and Settings\Christiane Gobeil>ping 169.254.197.58 <=ADRESSE IP DU P2

Envoi d’une requête ‘ping’ sur 169.254.197.58 avec 32 octets de données :

Réponse de 169.254.197.58 : octets=32 temps=1 ms TTL=128
Réponse de 169.254.197.58 : octets=32 temps<10 ms TTL=128
Réponse de 169.254.197.58 : octets=32 temps<10 ms TTL=128
Réponse de 169.254.197.58 : octets=32 temps<10 ms TTL=128

Statistiques Ping pour 169.254.197.58:
Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),
Durée approximative des boucles en millisecondes :
minimum = 0ms, maximum = 1ms, moyenne = 0ms

C:\Documents and Settings\Christiane Gobeil>

*** Sur ce PC, dans « Favoris réseau =>Ordinateurs proches du mien », je vois deux icônes :

  1. « Ibm » : avec un double click dessus je vois les dossiers « E », « Imprimantes » et « Tâches planifiées ».

  2. « Robertp2 » : avec un double click dessus j’obtiens « Saisie du mot de passe réseau » et en dessous « Mot de passe incorrect ou nom d’utilisateur inconnu pour : \Robertp2.


CONFIGURATION DE L’ORDI P2 (AUQUEL JE VEUX ACCÉDER AVEC P3):

C:\Documents and Settings\Administrator>ipconfig /all

Windows 2000 IP Configuration

    Host Name . . . . . . . . . . . . : RobertP2
    Primary DNS Suffix  . . . . . . . :
    Node Type . . . . . . . . . . . . : Mixed
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Connexion au P3: <= NOM DE LA CONNEXION “ENTRANTE” PROVENANT DE P3

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Realtek RTL8019 LAN adapter or compatible
    Physical Address. . . . . . . . . : 00-4F-4C-04-C0-89
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.197.58
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
    DNS Servers . . . . . . . . . . . :

C:\Documents and Settings\Administrator>ping 169.254.191.55

Pinging 169.254.191.55 with 32 bytes of data: <= ADRESSE IP DU P3

Reply from 169.254.191.55: bytes=32 time<10ms TTL=128
Reply from 169.254.191.55: bytes=32 time<10ms TTL=128
Reply from 169.254.191.55: bytes=32 time<10ms TTL=128
Reply from 169.254.191.55: bytes=32 time<10ms TTL=128

Ping statistics for 169.254.191.55:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Documents and Settings\Administrator>

*** Sur ce PC, dans « My Network Places » je ne vois pas d’icône similaire à « Ordinateurs proches du mien ». Si je fais une recherche de PC dans « My Entire Network », j’obtiens deux résultats (icônes) :

  1. « Ibm » : avec un double click dessus je vois « Incorrect password or unknown username for « \Ibm »

  2. « Robertp2 » : avec un double click dessus je vois les dossiers «Printers » et « Scheduled Tasks ».


Les propriétés de mes connections (utilisant la carte réseau) sur les 2 pc montrent un statut « connecté à 10 mb/s »; elles sont détectées automatiquement par Windows au démarrage.

Si j’essaie de configurer « Accepter une Connexion entrante » ou « Connecter directement à un autre ordinateur » avec « l’Assistant Connexion réseau » de W2K (c-à-d la procédure suggérée par Microsoft pour connecter deux PC avec un câble direct), je n’ai pas l’option de choisir mes cartes réseau comme périphérique : les seules options sont le « Parallèle direct (LPT1) » ou le Port de communication (COM1) ou (COM2). Comme je ne peut pas brancher mon câble (un RJ-45 inversé) dans les sorties LPT1 ou COM en arrière de mes PC, je ne sais pas comment me sortir de cette impasse

Quelqu’un a-t-il une suggestion ??? Je peux pas croire qu’on ne peut connecter deux W2K Pro ensemble via des cartes réseau
faut-il absolument que l’un des OS soit W2K Server?

Qui a dit que la config des réseaux c’est pas compliqué…

Merci de vos suggestions,
Robert

je trouve tes connexion bizarre, surtout pour le pc qui est connecté sur internet.
Les adresses ip sont inversées pour moi, je ne comprends pas.
Tu ne dois ni choisir accepter connexion entrante ni connexion directe à un autre pc.
Tu dois faire l’assistant classique de création de réseau domestique, l’un en choisissant se connecte direct à internet, l’autre se connecte à internet via une passerelle ou un autre ordi de se réseau.
puis il te demandera si tu ve partager tes dossiers.

Après pour l’histoire du mot de passe, c’est le truc super galère que j’ai jamais bien compris.
normallement, tu as deux possibilités

  1. tu vas dans les propriétés du fichierà partager, et tu le partage à tout le monde, sans mot de passe et tu retire tout ce qui peux géner dans l’onglet securité ( si onglet sécurité il y a)
  2. tu choisis de mettre un mot de passe. Pour cela, tu dois avoir un compte avec le meme nom et le meme mot de passe sur chaque ordis. Tu t’y connecte et la ca devrait marcher.

Enfin, puisque tu ping correctement, si ton transfert de fichier est un transfert occasionel, et que tu ne veux pas te prendre la tête, monte un serveur ftp, c’est ce que je fais quand je galère de trop, tu va perdre 10 minutes à le configurer, mais au moins apres, ca mareche nickel.

Salut Fedia,

J’avais oublié de partager le fichiers (mes documents) et après l’avoir fait j’ai réussi à voir les documents de l’autre pc… quelques fois.

Je sais pas pourquoi mais parfois mon mot de passe fonctionne et parfois non…!

C’est vraiment chiant et je me demande si ta solution de monter un serveur ftp ne règlerais pas le problème une fois pour toute… as-tu un tuto que tu pourrais me référer pour monter ce serveur?

Merci d’avance,
Robert

Cela depend peut etre de la session à laquelle tu es connecté pour ton problème de mdp.
tu peux vérifier que le partage est OK en fisant clique droit sur poste de travail puis gérer (j’espere que ca y est sous w2k)
(dans outils systeme -> dossiers partagers -> partage)
Tu n’as pas l’air d’avoir le problème, mais je t’en parles à tout hazard, si des fois l’ordis enregistre un mauvais mdp et ne veut plus te le redemander, pense à passer par connecter un lecteur réseau (dans poste de travail->outil je crois) et la tu pourra choisir identifiant et mdp.

Enfin, le serveur ftp, c’est en effet ce que je trouve le plus “simple” a mettre en oeuvre dans ce genre de pb. Le seul passage caspié est la config des parefeu/antivirus pour ouvrir le port 21.
Je n’ai aucun tuto de particulier à te conseiller mais google is your friend. (“tuto serveur ftp”).

Bon courrage et tiens nous au courrant :wink: