Forum Clubic

Configurer Xorg.conf sous ubuntu

Salut.
J 'ai plusieurs problèmes avec Ubuntu. Tout d’abord, je penses que ma carte graphique n’est pas bien reconnu, parce que quand je vais dans le gestionnaire de périphériques ben dans nForce AGP, il y’a un sous menu avec écrit : unknow(0x00f1).
Pourtant j’ai bien installé le paquet nvidia-glx, que j’ai activé, et j’ai d’ailleurs vu une énorme différence avec glxgears.

Par contre, mon écran est limité à 800x600, alors que d’habitude, et même sous mandrake je pouvais aller bien plus haut. J’ai bien essayé de modifié le xorg.conf, mais sans succés.

Troisième problème, il s’agit de configurer ma sortie télé pour qu’elle soit toujours active en clone de l’écran.
J’ai modifié le xorg.conf, et toujours sans succés. D’ailleurs voici le fichier. Si vous pouvez trouver des erreurs ou m’expliquer ce qui ne va pas. J’ai bien lu le man xorg.conf, et j’ai suivit les indications mais ca n’a pas marché.

/etc/X11/xorg.conf (xorg X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

(Type “man /etc/X11/xorg.conf” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom

sudo sh -c ‘md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum’

sudo dpkg-reconfigure xserver-xorg

Section “Files”
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath “/usr/lib/X11/fonts/misc”
FontPath “/usr/lib/X11/fonts/cyrillic”
FontPath “/usr/lib/X11/fonts/100dpi/:unscaled”
FontPath “/usr/lib/X11/fonts/75dpi/:unscaled”
FontPath “/usr/lib/X11/fonts/Type1”
FontPath “/usr/lib/X11/fonts/CID”
FontPath “/usr/lib/X11/fonts/100dpi”
FontPath “/usr/lib/X11/fonts/75dpi”
# paths to defoma fonts
FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”
FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID”
EndSection

Section “Module”
Load “bitmap”
Load “dbe”
Load “ddc”
Load “dri”
Load “extmod”
Load “freetype”
Load “glx”
Load “int10”
Load “record”
Load “type1”
Load “vbe”
EndSection

Section “InputDevice”
Identifier “Generic Keyboard”
Driver “keyboard”
Option “CoreKeyboard”
Option “XkbRules” “xorg”
Option “XkbModel” “pc105”
Option “XkbLayout” “fr-latin9”
EndSection

Section “InputDevice”
Identifier “Configured Mouse”
Driver “mouse”
Option “CorePointer”
Option “Device” “/dev/input/mice”
Option “Protocol” “ImPS/2”
Option “Emulate3Buttons” “true”
Option “ZAxisMapping” “4 5”
EndSection

Section “Device”
Identifier “NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]”
Driver “nvidia”
BusID “PCI:2:0:0”
Screen 0
EndSection

Section “Device”
Identifier “NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]”
Driver “nvidia”
BusID “PCI:2:0:0”
Screen 1
EndSection

Section “Monitor”
Identifier “moniteur0”
HorizSync 28-38
VertRefresh 43-72
EndSection

Section “Monitor”
Identifier “moniteur1”
HorizSync 28-38
VertRefresh 43-72
EndSection

Section “Screen”
Identifier “Screen 1”
Device “NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]”
Monitor “moniteur0”
DefaultDepth 24
SubSection “Display”
Depth 24
Modes “800x600” “1x1”
EndSubSection
EndSection

Section “Screen”
Identifier “Screen 0”
Device “NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]”
Monitor “moniteur1”
DefaultDepth 24

SubSection “Display”

Depth 1

Modes “1024x768” “800x600” “640x480” “1x1”

EndSubSection

SubSection “Display”

Depth 4

Modes “1024x768” “800x600” “640x480” “1x1”

EndSubSection

SubSection “Display”

Depth 8

Modes “1024x768” “800x600” “640x480” “1x1”

EndSubSection

SubSection “Display”

Depth 15

Modes “1024x768” “800x600” “640x480” “1x1”

EndSubSection

SubSection “Display”

Depth 16

Modes “1024x768” “800x600” “640x480” “1x1”

EndSubSection

SubSection "Display"
	Depth		24
	Modes		"1024x768" 

#“800x600” “640x480” “1x1”
EndSubSection
EndSection

Section “ServerLayout”
Identifier “Default Layout”
Screen “Screen 0”
Screen “Screen 1” RightOf “Screen 0”
InputDevice “Generic Keyboard”
InputDevice “Configured Mouse”
EndSection

Section “DRI”
Mode 0666
EndSection

Et est-ce que l’installation des drivers proprios n’arrangerait pas les choses?

Pour l’écran + tv, regarde du côté de TwinView. C’est untruc “made in nVidia” qui est compatible avec Xinerama. J’ai donné le lien dans un post vendredi dernier.

tu utilise deja les driver proprietaire !

Driver “nvidia”

et il ne faut pas chager DRI avec le nvidia donc :

Load “dri”

#Section “DRI”

Mode 0666

#EndSection

comme tu le configure il te faut demarer deux server X ( un sur chaque ecran ) , comme le dit Dumblecore , regarde au niveau de twinview il le fait tous seul ( pas besion de declare deux ecrans) tu configure avec xorg.conf ton ecran principal et tu dit a twinview que tu a un ecran secondaire.

regarde le fichier d’install des driver nvidia , il y a plein d’appendix pour tous metre en place tres facilement,puis pour active l’AGP aussi .

ben en fait j’ai pas installé les drivers proprios, mais juste un paquet sur le CD ubuntu nommé nvidia-glx je crois.

Par contre, pourquoi je n’arrives pas à avoir une résolution plus grande que 800x600. En plus dans mon xorg.conf, j’ai viré toutes les autres résolutions, mais ca ne marche pas quand même

que dit le log du server X ?

Le paquet nvidia-glx sous ubuntu installe les drivers proprios!

Ben moi, j’aurai bien voulu savoir quoi mettre dans mon fichier xorgconf pour avoir la sortie tv activée???
voici mon xorgconf:
[cpp]# /etc/X11/xorg.conf (xorg X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

(Type “man /etc/X11/xorg.conf” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom

sudo sh -c ‘md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum’

sudo dpkg-reconfigure xserver-xorg

Section “Files”
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath “/usr/lib/X11/fonts/misc”
FontPath “/usr/lib/X11/fonts/cyrillic”
FontPath “/usr/lib/X11/fonts/100dpi/:unscaled”
FontPath “/usr/lib/X11/fonts/75dpi/:unscaled”
FontPath “/usr/lib/X11/fonts/Type1”
FontPath “/usr/lib/X11/fonts/CID”
FontPath “/usr/lib/X11/fonts/100dpi”
FontPath “/usr/lib/X11/fonts/75dpi”
# paths to defoma fonts
FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”
FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID”
EndSection

Section “Module”
Load “bitmap”
Load “dbe”
Load “ddc”
Load “dri”
# Load “extmod”
SubSection “extmod”
Option “omit xfree86-dga”
EndSubSection
Load “freetype”
Load “glx”
Load “int10”
Load “record”
Load “type1”
Load “vbe”
EndSection

Section “InputDevice”
Identifier “Generic Keyboard”
Driver “keyboard”
Option “CoreKeyboard”
Option “XkbRules” “xorg”
Option “XkbModel” “pc105”
Option “XkbLayout” “fr-latin9”
EndSection

Section “InputDevice”
Identifier “Configured Mouse”
Driver “mouse”
Option “CorePointer”
Option “Device” “/dev/input/mice”
Option “Protocol” “ExplorerPS/2”
Option “Buttons” “7”
Option “ZAxisMapping” “4 5”
EndSection

Section “Device”
Identifier “ATI Technologies, Inc. Radeon 9800 Pro (R350 NH)”
Driver “fglrx”
Option “UseInternalAGPGART”
BusID “PCI:2:0:0”
Option “VideoOverlay” “on”
EndSection

Section “Monitor”
Identifier “L1730S”
Option “DPMS”
EndSection

Section “Screen”
Identifier “Default Screen”
Device “ATI Technologies, Inc. Radeon 9800 Pro (R350 NH)”
Monitor “L1730S”
DefaultDepth 24
SubSection “Display”
Depth 1
Modes “1280x1024” “1024x768” “800x600” “720x400” “640x480”
EndSubSection
SubSection “Display”
Depth 4
Modes “1280x1024” “1024x768” “800x600” “720x400” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1024x768” “800x600” “720x400” “640x480”
EndSubSection
SubSection “Display”
Depth 15
Modes “1280x1024” “1024x768” “800x600” “720x400” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1024x768” “800x600” “720x400” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1024x768” “800x600” “720x400” “640x480”
EndSubSection
EndSection

Section “ServerLayout”
Identifier “Default Layout”
Screen “Default Screen”
InputDevice “Generic Keyboard”
InputDevice “Configured Mouse”
EndSection

Section “DRI”
Mode 0666
EndSection
[/cpp]

il y a un package nvidia-settings aussi je crois.

personne pour m’aider???

Ben t’as regardé sous synaptic si t’avais tous les paquets nvidia?

Sinon moi j’ai une carte ATI :smiley: , mais les pilotes propriétaires ne suffisent pas, il faut aussi les “linux-image-” et les “linux-restricted-modules-” correspondant à la version de ton noyau.

En tout cas, tu peux aller sur le forum Ubuntu-fr, tu trouveras sûrement une réponse (voilà lien vers la partie serveurs graphiques-cartes vidéo : http://forum.ubuntu-fr.org/viewforum.php?id=27 ).

si tu regarde bien, tu verras que j’y ai déjà poster là-bas…
mais toi puisque tu as une carte ati, tu veut pas me dire comment tu active la sortie tv???

Une config ‘Xorg.conf’ pour une GeForce TI4200 avec sortie sur VGA + S-TV

[fixed]# /etc/X11/xorg.conf (xorg X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

(Type “man /etc/X11/xorg.conf” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom

sudo sh -c ‘md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum’

sudo dpkg-reconfigure xserver-xorg

Section “Files”
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath “/usr/lib/X11/fonts/misc”
FontPath “/usr/lib/X11/fonts/cyrillic”
FontPath “/usr/lib/X11/fonts/100dpi/:unscaled”
FontPath “/usr/lib/X11/fonts/75dpi/:unscaled”
FontPath “/usr/lib/X11/fonts/Type1”
FontPath “/usr/lib/X11/fonts/CID”
FontPath “/usr/lib/X11/fonts/100dpi”
FontPath “/usr/lib/X11/fonts/75dpi”
# paths to defoma fonts
FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”
FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID”
EndSection

Section “Module”
Load “GLcore”
Load “bitmap”
Load “dbe”
Load “ddc”
Load “dri”
Load “extmod”
Load “freetype”
Load “glx”
Load “int10”
Load “record”
Load “speedo”
Load “type1”
Load “v4l”
Load “vbe”
EndSection

Section “InputDevice”
Identifier “Generic Keyboard”
Driver “keyboard”
Option “CoreKeyboard”
Option “XkbRules” “xorg”
Option “XkbModel” “pc105”
Option “XkbLayout” “fr”
EndSection

Section “InputDevice”
Identifier “Configured Mouse”
Driver “mouse”
Option “CorePointer”
Option “Device” “/dev/input/mice”
Option “Protocol” “ImPS/2”
Option “Emulate3Buttons” “true”
Option “ZAxisMapping” “4 5”
EndSection

Section “Device”
Identifier “NVIDIA Corporation NV25 [GeForce4 Ti 4200]”
Driver “nvidia”
BusID “PCI:2:0:0”
Option “NoLogo”
Option “TVStandard” “PAL-N”
EndSection

Section “Monitor”
Identifier “Écran générique”
Option “DPMS”
HorizSync 30-65
VertRefresh 50-75
EndSection

Section “Screen”
Identifier “Default Screen”
Device “NVIDIA Corporation NV25 [GeForce4 Ti 4200]”
Monitor “Écran générique”
DefaultDepth 24
SubSection “Display”
Depth 1
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 4
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 15
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
EndSection

Section “ServerLayout”
Identifier “Default Layout”
Screen “Default Screen”
InputDevice “Generic Keyboard”
InputDevice “Configured Mouse”
EndSection

Section “DRI”
Mode 0666
EndSection[/fixed]

apt-get install linux-image-2.6.10-5-k7 linux-headers-2.6.10-5-k7 linux-restricted-modules-2.6.10-5-k7
apt-get install nvidia-glx nvidia-settings
dpkg-reconfigure xserver-xorg
Tu auras deja les drivers Nvidia qui marche apres pour la Tv faut voir…
Jerome

il a ecrit (son xorg.conf)[quote=""]
Section “Device”
Identifier “NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]”
Driver “nvidia”
BusID “PCI:2:0:0”
Screen 0
EndSection
[/quote]

donc ses drivers nvidia marchent deja.

Oui il a ecrit son xorg.conf qui ne marche pas ( comme moi j’avais fait avant ca ) et puis apres j’ai fait ce que j’ai indique plus haut ( surtout lles linux restricted) et depuis ca marche a tous les coups ( GF 2Mx , Gf 4Mx , 6600Gt PciE )

bon moi j’ai pas chercher a configurer ma sortie tv (car j’ai pas de tv), mais a priori elle est activée automatiquement avec une ati, mais les xorg.conf des personnes qui l’utilise comporte 2 parties Device et 2 parties Screen:

Voila, je sais pas si ca pourra aider, mais a priori c’est comme ça que fonctionne le double écran avec une ati.