Forum Clubic

Configurer xorg.conf pour le double affichage

Ben tout est dans le titre.

En fait je suis sous mdk 10.1, et j’arrive pas à avoir en même temps l’image sur la télé et sur le PC, alors que l’un après l’autre c’est nickel.

En fait si vous pouviez détaillez les options du fichier xorg.conf pour pouvoir faire çà… :smiley:

Merci d’avance :slight_smile:

EDIT: pour info g une leadteck 6600GT… Et j’ai installé les drivers proprios d’il y’a un mois. Donc est-ce que je dois mettre à jour mes drivers , ou c’est moi qui fait un truc qui va pas??

en fait le principe est assez simple, tu dois déclarer 2 sections screen et deux sections monitor en spécifiant le busid à utiliser ainsi que le pilote pour chaque occurence de l’adresse de la carte que tu trouves dans le lspci.

en fait la procédure à effectuer pour configurer ton xorg.conf est entièrement et très bien décrite sur le même site ou tu as téléchargé les drivers.

section : (app-i) APPENDIX I: CONFIGURING TWINVIEW

ftp://download.nvidia.com/XFree86/Linux-x86/1.0-6629/README.txt

j’ai mal lu, désolé mais pour la sortie tv c’est dans le même fichier (app-j) APPENDIX J: CONFIGURING TV-OUT

ouais mais je l’ai déjà lu.

Par contre à aucun moment ils disent de déclarer 2 sections screen et deux sections monitor.

Comment je fais?
je déclare screen1 et screen2
Une petite aide ou juste un exemple plz?

je n’ai pas de carte nvidia, par contre je peux te donner mon fichier xorg.conf pour matrox et t’en inspirer, à mon avis c’est très proche.

ben je veux bien.
Merci!

benjamin@amon-rah benjamin $ grep -v ^# /etc/X11/xorg.conf
Section “Module”
Load “dbe” # Double buffer extension
SubSection “extmod”
Option “omit xfree86-dga” # don’t initialise the DGA extension
EndSubSection
Load “type1”
Load “freetype”
EndSection

Section “Files”

RgbPath     "/usr/X11R6/lib/X11/rgb"
FontPath   "/usr/share/fonts/misc/"
FontPath   "/usr/share/fonts/TTF/"
FontPath   "/usr/share/fonts/Type1/"
FontPath   "/usr/share/fonts/75dpi/"
FontPath   "/usr/share/fonts/100dpi/"
FontPath   "/usr/share/fonts/local/"

EndSection
Section “InputDevice”

Identifier  "Keyboard1"
Driver      "kbd"
Option "AutoRepeat" "500 30"
Option "XkbLayout"  "fr"

Option "XkbRules"   "xorg"
Option "XkbModel"   "microsoftoffice"

EndSection

Section “InputDevice”

Identifier  "Mouse1"
Driver      "mouse"
Option "Protocol"    "Imps/2"
Option "Device"      "/dev/input/mice"

Option "Resolution" "800"
Option "ChordMiddle"

EndSection

Section “Monitor”
Identifier “Monitor0”
HorizSync 31.5 - 60
VertRefresh 40-150
EndSection

Section “Monitor”
Identifier “Monitor1”
HorizSync 31.5 - 82.0
VertRefresh 40-100
EndSection

Section “Device”
Identifier “G400_1”
Driver “mga”
ChipSet “mgag400”
Card “Matrox Millenium G400”
VideoRam 32768
BusID “1:0:0”
EndSection
Section “Device”
Identifier “G400_2”
Driver “mga”
ChipSet “mgag400”
Card “Matrox Millenium G400”
BusID “1:0:0”
Screen 1
EndSection

Section “Screen”
Identifier “Screen0”
Device “G400_1”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
Modes “1280x1024”
EndSubSection
EndSection

Section “Screen”
Identifier “Screen1”
Device “G400_2”
Monitor “Monitor1”
DefaultDepth 24
SubSection “Display”
Depth 24
Modes “1280x1024”
EndSubSection
EndSection

Section “ServerLayout”
Identifier “SimpleLayout”
Screen “Screen1” LeftOf “Screen0”
Screen “Screen0”
InputDevice “Mouse1” “CorePointer”
InputDevice “Keyboard1” “CoreKeyboard”
Option “Xinerama” “on”
EndSection

voila voila

thx

Regarde ici[/url] et [url=http://howto.stephane-huc.net/nVidia/support/TwinView/]là

personnellement, j’ai un truc étonnant.

Qd je lance ce fichier de config:

Avec ce fichier, au lieu d’avoir un affichage sur le crt et la tv, je n’ai que l’affichage sur la tv (mon crt semble se mettre en veille).
Avant, ce meme fichier fonctionnait. (sous xfree, c’est sur, sous xorg, je crois que ca a marcher également pendant unc certain temps). Je ne sais pas si c’est du au changement de driver nvidia, une option qui aurait évoluer avec…

est-ce que mon probleme pt venir du MetaModes ?

T’as oublié l’option “TwinViewOrientation”. Et faut aussi mettre :

Option “TwinView” “on” (t’as pas mis le “on”)

rhaaaaa, le genre d’erreur où il faut un oeil autre que le sien pr le voir tellement c’est flagrant.

Merci

Y a pas de quoi. Ca fait 5 packs d’orangina :whistle: