Forum Clubic

Configurer file zilla derierre un routeur

Bon voila mon souci, j’ai créé un serveur ftp avec filezilla 9.11 mais je n’arrive pas a le rendre accessible en ligne lorsque j’utilise mon routeur (Tecom AH4021), en revanche lorsque je branche mon modem adsl classique tout se passe correctement et mon ftp est accessible. Le souci vient donc d’un mauvais parametrage de mon routeur ou de filezilla.
D’apres les recherches que j’ai fait sur le net il faudrait que je le parametre en mode passif, j’ai essayé mais en vain :grrr: les aides et sujet que j’ai trouvé son vague et impréciss, ca fait bientot 2 jours que j’essaie de regler le souci.

Si l’un d’entre vous pouvait m’expliquer en détails comment parametrer ce P@#è"^! de mode passif pour que je ne soit pas obliger de switcher entre modem classique et routeur, je lui en serait grandement reconnaissant :jap:

est-ce que tu as ouvert le port 21 sur ton routeur ?

(redirection de port vers l’IP de ton PC hebergeant el serveur)

Sans cela ça ne peut pas marcher.

Un site util pour cela:

http://www.portforward.com/routers.htm

oui, ca j’ai fait, j’ai créé une regle NAT. La partie qui me pose probleme dans filezilla[/url] et qui, je pense, doit coincer c’est ca => [url=http://img362.imageshack.us/my.php?image=sanstitre8sx.jpg]http://img362.imageshack.us/img362/1900/sanstitre8sx.th.jpg

tu as essaye en lui indiquant l’IP LAN de ton PC ?

Je renvoie le topic sur le froum réseaux :jap:

Je renvoie le topic sur le forum réseaux :jap:

oui aussi :’(

Hum

Bon on reprend à zero:

le serveur est-il accessible en local ?

depuis ton PC peux-tu te connecter en utilisant ton IP ALN ou l’IP 127.0.0.1 ?
Si un autre PC est present sur le LAN, accede-t-il au serveur ?

Si c’est positif alors il n’y a rien à faire niveau serveur et c’est au niveau routeur.

Verifie que tu as bien mis la regle de translation de port ( attention, ce n’est pas tout à fait pareil qu’une regle NAT ) et que tu n’a pas aussi besoin d’ajouter une regle au firewall du routeur …

freshyzz!! Moi aussi j’en ai ch…é à me faire mon serfeur FTP, mais j’ai enfin réussi!

Déjà: je suppose que tu utilise une redirection dns (genre dyndns, ou no-ip). Donc Filezilla doit connaitre ton ip publique! pour cela dans “passive mode settings”, (là ou tu as entouré ou tu pense que ça coince) tu selectionne “retrieve external IP from” et normalement t’a une adresse par defaut qui apparait. Sinon, mets “http://filezilla.sourceforge.net/misc/ip.php” .

Ensuite pour etre sur que le mode passif fonctionne coche "use custom port Range" et mets par ex 20000 - 25000.

Puis enfin, va dans ton routeur et ouvre les ports de 20000 à 25000 vers ta becane qui heberge le serveur.

Moi j’ai du attendre 2 - 3 minutes, le temps que filezilla resolve mon ip publique… Apres ca a marché!!! youpii!!!