Forum Clubic

Configuration routeur mikrotik routerboard rb750g

Bonjour et merci à tous ceux qui vont prendre le temps de lire et repondre à mes questions.

Tout d’abord, je vais “planter le décors”… J’ai actuellement une BOX de mon FAI, sur laquelle j’ai un routeur WRT54GL (avec dd-WRT) suivit de mon réseau (point d’accès wifi, différents PC, etc…). Tout fonctionne très bien, mais ayant deja vu mourrir un WRT54G après de longues années de service, je me suis mis en tete de le remplacer préventivement… tant qu’à faire en faisant évoluer mon réseau… Je me suis donc tourné vers un routeur Gigabit (le TP-Link TL-WR1043ND 802.11n que j’aurais peut-etre du prendre…), mais en me promenant sur eBay j’ai trouvé pour moins cher, un routeur “PRO”… le MikroTik RouterBoard 750G.
C’est la que tout devient très compliqué… autant je trouvais facilement comment configurer mon WRT54GL, autant je n’arrive même pas à faire communiquer le port 1 (la box) et le port 2 (mon PC). J’ai essayé de suivre la documentation ( http://www.mikrotik.com/documentation.html ) mais je n’y arrive toujours pas (suite à mise à jour, mon routeur est en version 3.30 5.19).

Merci à tous ceux qui pourront m’indiquer comment faire…

Voici les “besoins”:

  • ma box donne une IP par DHCP (ça j’ai réussit à le faire accepter par le RB750G)
  • j’aimerai que le routeur fasse DHCP sur mon réseau (j’ai réussit 1 seule fois mais j’ai fait un reset usine et depuis, même en me fiant à la capture d’ecran que j’avais faite, je n’arrive plus à activer ce serveur DHCP)
  • j’ai actuellement la box qui donne une adresse IP en 192.168.1.xxx et mon reseau (derrière le WRT54GL) en 192.168.0.xxx
    je peux modifier ces paramètres s’ils sont la source du problème (mais comme le WRT54GL sait le faire, je suppose que le problème vient surtout de l’interface chaise/clavier).
  • j’aimerai aussi (comme le fait deja mon WRT54GL) assigner des addresses IP en fonction de certaines adresses MAC.
  • aussi autoriser/interdire l’accès à certaines machines (toujours par adresse MAC).
  • filtrer certaines adresses (regies publicitaires, sites de Pr0n…) en fonction toujours de l’adresse MAC.

http://img37.imageshack.us/img37/176/rb750g.jpg

EDIT: j’ai mis à jour le router de la version 3.30 en 5.19 (voir un peu + bas).
Edité le 14/08/2012 à 19:41

Bonsoir

Déjà mauvaise idée de prendre du matériel " " “pro” " " sans connaissance un peu plus approfondi. A part le MPLS il est vraiment très très médiocres.

J’ai un peu de mal a comprendre ce que tu souhaite faire (un petit schéma peut être pas mal ). Si j 'ai bien compris tu veut mettre un nouveau routeur a la place de ton WRT54GL qui est derrière une box ( mode bridge ?).

Tu as interface en 192.168.0.1 et une autre en 192.168.88.0(ip par défault du constructeur). L’interface ether2 semble être dans un état down/down :p.

Ne met pas tes interfaces en DHCP mais en fixe. De plus tu as une interface qui n’est plus en classe C, sauf si ton objectif est de faire du VLSM je pense que c’est une erreur si bien sur tu es en /24.

Trés sincerement attaque ton routeur en telnet ou SSH au moins il y aura des fichiers de log et de conf correct car la ce n’est pas facile de comprendre notamment les différentes ip. Prend pour cela des ip pour le telnet et ssh dans le même sous réseau.

Apres avoir changer l’IP de l’interface ether1 ce sera a celle ci que tu devra te connecter si tu veut config avec une GUI. Precise aussi les masque de sous réseau que tu utilise meme s’ils sont standard.
Edité le 14/08/2012 à 03:11

Bonsoir et merci pour cette réponse !

Effectivement, j’ai opté pour ce matériel “PRO” pensant faire une affaire (bon prix, réseau 1Gbit…) et surtout en imaginant recevoir quelques chose de + résistant dans le temps (meilleure qualité ?), et maintenant que je n’y comprends rien, je me dit qu’il aurait été préférable de rester sur du matériel “SOHO” !

Le RouterBoard 750G doit venir remplacer le WRT54GL actuellement en place.

Voici une rapide représentation du réseau actuel:

http://img140.imageshack.us/img140/8949/reseaub.jpg

La BBox ne peut pas etre configurée en “simple” modem, j’ai donc laissé le DHCP activé mais j’ai reservé l’adresse 192.168.1.1 pour mon WRT54GL (il n’y a qu’un téléphone classique en + du WRT54GL connecté à la box).

La box utilise son adresse par défaut (192.168.1.254).

C’est ensuite le WRT54GL qui me sert de routeur !
Ayant déjà la plage 192.168.1.xxx d’utilisé coté WAN du routeur, j’ai utilisé la plage 192.168.0.xxx coté LAN
C’est peut-etre une mauvaise idée (je n’ai pas de formation reseau/informatique…mais je peux apprendre).

Sur le WRT54GL j’ai désactivé le WIFI, le reseau fournit par la FONERA 2.0N suffisant à couvrir mon appartement.

La FONERA est elle configurée en “BRIDGE”.

C’est le WRT54GL qui sert de DHCP à tout le réseau, que ce soit les différents PC en RJ45 ou les différents appareils nomades (smartphones, tablettes, PC portables) qui se connectent au WIFI de la FONERA.

Actuellement le WRT54GL sert donc de ROUTEUR entre la BOX et mon réseau, mais aussi de DHCP ainsi que de filtre (certaines adresses internet, accès reseau simple ou accès reseau et internet, plage horaire…)

J’espère avoir été assez clair dans mon explication.
Edité le 14/08/2012 à 03:40

Alors déja quelques petites erreurs/remarques:

-La box est toujours le routeur principal puisque c’est un modem/routeur sans etre en bridge. Elle assure la liaison avec l’ISP. L’ adresse WAN est l’adresse public et non pas une classe C privé. (cf : RFC 1918 )

-Le nouveau est donc simplement adossé a celui ci et fait du routage interne.Un switch L3(layer eut été bien mieu).

-La box ne fait pas DHCP car sans configuration les broadcast ne passent pas les routeurs mais je pense que le DHCP est toujours actif

-Concernant les adresses reseaux differentes c’est normal les routeurs relient des reseaux differents donc rien a signaler de ce coté sauf que la configuration est peut etre mal faite.

La configuration du nouveau routeur est clairement differentes il faut configurer ether 2 correctement. (je posterai les modific ce soir
Si je ne me trompe pas la Box ne fait pas réllement de routage il s’agit plus d’un routeur avec des ports d’extension switch pour schèmatiser. Un peu comme le nouveau routeur sauf s’il dispose de 5 interface comme le laisse sugerer la config de ether 1 et 2.

Pour les filtrages que tu souhaite faire cela va clairement etre compliqué car ce n’est pas un routeur aussi grand public que le Linksys. Je doute que celui ci gere des acl etendu ou dynamique. Mais ta box ou un proxy peuvent faire l 'affaire.
Edité le 14/08/2012 à 10:07

Merci encore pour le temps que tu prends pour m’aider et me guider.

Donc quelques explications sur mon réseau… à la base, j’ai connu internet en 56k, puis par la suite à l’aide d’un modem ADSL USB pas tres stable… et rapidement remplacé par un modem ADSL ethernet.
Une fois que mon père avait prit gout à internet et monopolisait trop souvent mon PC, j’ai décidé de mettre en place un réseau à l’aide d’un router (mon 1er WRT54G qui est mort entre temps).
Avec les evolutions de l’internet en France, mon offre a évolué et mon modem à été remplacé par une BOX…
Mon réseau fonctionnant correctement, je n’ai pas vu l’utilité (ni voulut etre dépendant des capacités de la box de mon FAI) et n’ai pas mis cette BOX comme mon routeur principal mais simplement comme un accès internet (c’est peut etre une 1ere erreur, mais j’aime garder le controle sur “mes” équipements, tout en pouvant décider de changer de FAI et donc aussi de BOX).
Les équipements mobiles commençant à se multiplier, j’ai alors ajouté une FONERA (bah oui un accès internet ailleurs que chez soit peut etre sympa), puis désactivé le wifi du routeur, la FONERA fournissant un réseau en 802.11n (contre 802.11g pour le routeur).
Au fil des évolutions, les PC sont passé en Gbit et bien que mon ADSL ne saura pas exploiter cette interface, il devient de + en + frequent de partager/envoyer des documents sur le réseau local (fin de semaine arrive une TV avec DLNA)…
J’ai donc décidé pour un prix très correct et une évolution de 100Mbps à 1Gbps de remplacer mon routeur actuel (le WRT54GL sous ddWRT)… d’ou aujourd’hui mon MikroTik RouterBoard 750G.

  • Concernant le DHCP, j’utilise peut-etre ce terme d’une manière non adaptée… dans mon idée (je n’ai toujours pas de cours réseaux… mdr) le DHCP sert uniquement à distribuer des adresses IP aux différentes machines qui lui sont connctées…

C’est donc comme cela que j’attribue l’adresse WAN du routeur par la BOX (adresse MAC => IP 192.168.1.1)
http://img37.imageshack.us/img37/6577/bboxdhcp.jpg

Et aussi les adresses de mon réseau local par le routeur:
http://img843.imageshack.us/img843/8144/wrtdhcp.jpg

  • Concernant les adresses différentes, oui j’ai quand même compris un minimum mais si comme tu le dis c’est “mal fait” on peut corriger cela sans soucis… il me faudra simplement quelques explications sur ce qu’il faut améliorer/modifier/corriger.

  • Le nouveau routeur est effectivement très différents de tout ce que j’ai connu jusqu’a présent (WRT Linksys, ddWRT, FONERA…).
    Il possède effectivement 5 ports Gbits et la documentation conseille de connecter le port ETH1 sur l’accès internet.
    J’aimerai si possible que les ports 2 à 5 fonctionnent de la même manière (comme un switch) afin de pouvoir librement y connecter un peu tout ce que j’ai sur mon réseau (ce serait bete d’avoir 3 ports Gbit inutilisés et de tout passer par les ports 100Mbps de la FONERA).
    Pour ce qui est de la configuration, je viens de trouver comment mettre à jour le RB750G (et les menus changent assez par rapport à la capture du 1er post), je vais faire quelques captures, mais il y a tellement de possibilités, que j’essayerai de mettre les captures en fonction des besoins… n’hésite pas à demander si tu veux voir qqch plus en détail.

  • Pour ce qui est des filtrages, j’ai configuré le routeur actuelle de la manière suivante:
    http://img715.imageshack.us/img715/3811/wrtdnsnasq.jpg

et:
http://img339.imageshack.us/img339/4582/wrtaccess.jpg

Après mise à jour en version 5.19:
http://img195.imageshack.us/img195/7979/rb519.jpg
Edité le 14/08/2012 à 19:32

Petit UP concernant mon avancement !

Depuis la mise à jour en 5.19, les menus ressemblent + à ce que l’on trouve dans les explications, ce qui m’a permit d’avancer un peu.
La config “d’usine” du routeur dans cette version 5.19 active aussi beaucoup de paramètres.
Il y a par exemple un client DHCP coté Ether1, un serveur DHCP coté Ether2 et les ports Ether3, Ether4 et Ether5 fonctionnent comme Ether2.

En suivant ce wiki, j’ai réussit à acceder à internet !
J’ai donc laissé ma box en tête (192.168.1.254) qui donne en DHCP l’adresse IP Ether1 (192.168.1.1).
Du coté réseau local (Ether2, 3, 4 et 5), je suis en 192.168.88.xxx
J’ai paramétré les DNS, quelques attributions d’IP et l’horloge du routeur par NTP.

Je peux actuellement surfer, recevoir mes emails, écouter les webradios… enfin un peu tout ce qu’une connexion est sensé faire…

Mais depuis j’essaye en vain de mettre en place une redirection de port.
J’ai essayé un peu tout ce qui me passait par la tête (en commençant par suivre ce wiki), mais je n’y arrive pas…
Avec le WRT54GL, je redirigeai un port qui arrivait par DynDNS sur ma box, vers la FONERA.
La box redirige donc toujours ce port vers l’adresse du RB750G, 192.168.1.1 (la même adresse qu’utilisait mon WRT54GL).
Ensuite j’essaye de rediriger ce même port vers l’adresse de la FONERA (192.168.88.4) mais la communication reste impossible.

Ce qui me gène le + c’est que même en essayant d’acceder au serveur de la FONERA, je ne vois aucune activité sur le RB750G…

Voila ce que j’ai rentré… j’ai bien sur essayer de changer certains paramètres mais je ne trouve pas lequel est en “faute”.
http://img802.imageshack.us/img802/3718/rb750nat.jpg

Je viens aussi de vérifier s’il n’y a aps de soucis du coté de DynDNS mais tout semble OK… Quand je fait un PING de mon DynDNS, je recçoit bien l’adresse IP WAN de ma BOX…

Le soucis doit donc bien venir de cette redirection de port de la box vers la FONERA…

J’ai aussi vérifié que le port doit bien être en TCP mais rien n’y fait… je n’arrive vraiment pas a le faire passer…

Merci pour votre aide !
Edité le 15/08/2012 à 14:45

Bon, à force d’insister et d’essayer toutes les configurations qui me sont venues en tête, j’ai finit par tomber sur quelques chose qui fonctionne… j’ai l’impression que le routeur filtre dans les 2 sens (il suffisait sans doute de le savoir… mais mon WRT54G n’avait besoin que d’une seule regle pour permettre cette communication).

Du coup voila ce que j’ai mis:

http://img39.imageshack.us/img39/4387/rb750nat2.jpg

Est-ce que ça parait logique ? Est-ce que ça ne gène pas de rediriger vers 192.168.1.0/24 plutot que vers 192.168.1.254 ??

EDIT: J’ai bien essayé de rediriger ce port vers ma BOX (192.168.1.254) mais rien à faire… ça ne passe pas… étrange ?

EDIT2: Pour filtrer les publicitées et autres sites, j’ai bien trouvé ce tutorial. Ca fonctionne plutot bien, mais ne me permet pas de filtrer en fonction de la machine qui accède à internet… et plutot que de rester 'transparent", le routeur signale que la page a été bloquée par l’administrateur… Possible de faire mieux ?
Edité le 16/08/2012 à 01:16