Forum Clubic

Config debian

bonjour tout le monde ,
je viens de finir d’installer debian sur mon pc
mais je me suis tromper lors du parametrage de mon ecran

j’ai indiqué une résolution max de 600x800 alors qu’il me faudrait une résolution de 1024x768

dans le control center je n’arrive pas a monter la résolution au dessus de 800x600

comment est ce que je peut faire??
ou est ce que je peut changer la résolution??

merci

Si tu utilises Xorg, edites /etc/X11/xorg.conf et si tu utilises XFree86, bah c’est XF86Config-4 dans le même repertoire. Dans la section Screen il me semble, tu as tes resolutions de listée pour chaque “depth”. Tu peux rajouter 1024x768 pour toutes. Ensuite, relance X (ctrl+alt+bckspc). Normalement c’est bon.
Ah quoique maintenant que j’y pense, si t’es sous debian tu dois sans doute pourvoir faire un dpkg-reconfigure xserver-xorg ou xserver-xfree86 qui devrait te redonner la fenetre de conf de X.

c’est bon je suis arrivé a changer la résolution
il reste encore un petit probleme, l’invite de changement de session est enorme , l’endroit ou on tappe son login et son mot de passe pour ouvrir une session

Tu utilise quoi ? XDM, KDM, GDM, MDM ? Ca doit être configurable mais si tu debutes ca risque d’être un peu long à expliquer :confused:

oualala !!!

debian utilise des systemes de configuration bien fichus, autant les utiliser

pour reconfigurer un package :

dpkg-reconfigure

dans ton cas : dpkg-reconfigure xserver-xfree86

j’utilise xdm comme gestionnaire de connexion

Euh il y a une erreur dans ta phrase.
[:m@ssive]

:stuck_out_tongue:

c’est une expression courante par chez moi, ca veut dire qu’ils sont bien faits :o

je te proute :stuck_out_tongue: :smiley:

je ne parlais pas du " bien fichu" en tant qu’expression, mais du “debian” => “bien fichu”
:fou:

essayerais tu de lancer un [:sergiomrt] ?

:stuck_out_tongue:

on s’amuse comme on peut :slight_smile:

Désolé je ne connais pas bien xdm donc je ne sais pas comment faire. Mais tu peux passer à un Display manager un peu plus evolué et user-friendly comme ceux que j’ai cité. GDM est celui de gnome, KDM celui de KDE, MDM celui de mandriva etc… J’ai trouvé ca si ca peut t’aider:
http://www.freebsd.org/doc/fr_FR.ISO8859-1/books/handbook/x-xdm.html
Visiblement, il faut s’occuper du fichier Xressource

voila le fichier de configuration Xressources de xdm ca peut peut etre vous aidez a répondre a ma question
j’auimerais diminuer la taille de l’invite de conexion
chez moi elle est trop grande , elle dépasse de mon ecran

$Xorg: Xresources,v 1.3 2000/08/17 19:54:17 cpqbld Exp $
!
!
!
!
! $XFree86: xc/programs/xdm/config/Xres.cpp,v 1.6 2003/01/04 03:11:31 dawes Exp $
!

xlogin*login.translations: #override
CtrlR: abort-display()\n
F1: set-session-argument(failsafe) finish-field()\n
Delete: delete-character()\n
Left: move-backward-character()\n
Right: move-forward-character()\n
Home: move-to-begining()\n
End: move-to-end()\n
CtrlKP_Enter: set-session-argument(failsafe) finish-field()\n
KP_Enter: set-session-argument() finish-field()\n
CtrlReturn: set-session-argument(failsafe) finish-field()\n
Return: set-session-argument() finish-field()

xlogingreeting: Debian GNU/Linux (CLIENTHOST)
xlogin
namePrompt: \040\040\040\040\040\040\040Login:

xlogin*fail: Login incorrect

#if WIDTH >= 1024
xlogingreetFont: -adobe-helvetica-bold-o-normal–25-180-100-100-p-138-iso8859-1
xlogin
font: -adobe-helvetica-medium-r-normal–20-140-100-100-p-100-iso8859-1
xloginpromptFont: -adobe-helvetica-bold-r-normal–20-140-100-100-p-105-iso8859-1
xlogin
failFont: -adobe-helvetica-bold-r-normal–20-140-100-100-p-105-iso8859-1
#if PLANES >= 8
xloginlogoFileName: /usr/X11R6/lib/X11/xdm/pixmaps/debian.xpm
#else
xlogin
logoFileName: /usr/X11R6/lib/X11/xdm/pixmaps/debianbw.xpm
#endif
#else
xlogingreetFont: -adobe-helvetica-bold-o-normal–14-140-75-75-p-82-iso8859-1
xlogin
font: -adobe-helvetica-medium-r-normal–12-120-75-75-p-67-iso8859-1
xloginpromptFont: -adobe-helvetica-bold-r-normal–12-120-75-75-p-70-iso8859-1
xlogin
failFont: -adobe-helvetica-bold-r-normal–12-120-75-75-p-70-iso8859-1
#endif

#ifdef COLOR

xloginborderWidth: 1
xlogin
frameWidth: 5
xlogininnerFramesWidth: 2
xlogin
shdColor: grey30
xloginhiColor: grey90
xlogin
background: grey
!xloginforeground: darkgreen
xlogin
greetColor: Blue3

xlogin*failColor: red
*Foreground: black
*Background: #fffff0
#else

xloginborderWidth: 3
xlogin
frameWidth: 0
xlogininnerFramesWidth: 1
xlogin
shdColor: black
xlogin*hiColor: black

#endif

xloginuseShape: true
xlogin
logoPadding: 10

XConsole.text.geometry: 480x130
XConsole.verbose: true
XConsoleiconic: true
XConsole
font: fixed

Choosergeometry: 700x500+300+200
Chooser
allowShellResize: false
Chooserviewport.forceBars: true
Chooser
label.font: -new century schoolbook-bold-i-normal--240-*
Chooserlabel.label: XDMCP Host Menu from CLIENTHOST
Chooser
list.font: ---medium-r-normal---230---c--iso8859-1
Chooser
Command.font: -new century schoolbook-bold-r-normal--180-*

Essaye man Xressource et teste aussi tout ce qui contient “geometry” :wink: . Moi je ne connais pas ce DM et en plus je ne me suis pas vraiment attarder sur leur configuration (à tous). Le mieux est que tu fasse toi même des essais, c’est plus formateur que d’avaler une manip toute faite qu’on te donne. Tu verra comme ca ce que font les autres options et tu pourra encore plus le configurer que ce que tu pensais faire :smiley: . C’est-t-y-pas-beau ?

c’est peut etre une mauvaise config de la resolution…

non , c’est uniquement l’invite de connexion qui est trop grande , sous kde j’ai une bonne image

peut etre que la resol de X est mal configuree mais que tu as compense en tripatouillant les parametres de resol dans KDE… ceci expliquerait cela.

C’est vraiment pas normal que l’invite de connexion de XDM soit difforme et, AMHA, bidouiller le Xressource n’est qu’un cache misere… et ne regle pas le vrai probleme sous-jacent

j’ai installé gdm et maintenant c’est bon

XDM en general est une misere :smiley: . Quoique j’avais vu une astuce pour balancer une video en ecran de fond sur XDM avec mplayer. Ca doit etre assez fun [:buddy_guy]