Forum Clubic

Config de Lilo sous Ubuntu - Comment démarrer 2 OS sur 2 disc différe

Bonjour à tous,

Je sais qu’il existe un nombre incommensurable de post à c sujet mais j’arrive encore a trouver qqch qui n’a pas été fait (en tout cas après une heure de recherche, rien) :confused:

Ma question est comment faire un multiboot de deux Os sur 2 discs différent
Mon linux est sur hdb et mon windows sur hda

Je n’arrive pas à configurer mon lilo pour 1° qu’il me demande quel Os je veux 2° Pour qu’il me boot mon windows (j’avais déjà fait l’essai avec une autre sitrib et cela ne fonctionnait pas)

Merci.

Euh sous ubuntu c’est pas grub ?

si. :wink:
et normalement,c’est automatique.Non???

Alors, je n’ai pas grub sous Ubuntu et ben chez moi ct pas auto!! D’où ma question!! Mais merci de vos réponses…

lance

$cat /boot/grub/menu.lst

et copie le résultat ici, sans les commentaires (les lignes qui commencent par un #)

tu voulais pas plutot dire
$cat /etc/lilo.conf |grep -v "#"

Voilà ce que cela me donne:

Je rajoute qu losrque je lance lilo dans la console cette erreur arrive, je dois dire que je n’ai pas tout compris:

Quest ce qu’il faut que je change??

J’ai rennomé dans /dev le dm en dm-0 et voila l’erreur que j’ai maintenant:

ça tourne au cauchemar!!! :ouch:

  1. vire lilo et dit a ubuntu d’installer grub (un vrai gestionnaire de démarrage).

  2. une fois installé mets nous ce qui a mis dans /boot/grub/grub.conf sans les #

  3. donne le contenu de /etc/fstab

  4. le retour de la commande ls /boot/
    Pourquoi ? Parce que avec lilo, quand ca ne marche pas comme on veut, y’a plus qu’a pleurer, alors avec grub, y’a encore possiblité de s’en sortir.

A tout de suite.

bin en fait je croyais pas possible qu’il ais installé lilo sous ubuntu :stuck_out_tongue:

Mais je l’ai pas installer, il est venu tout seul!! :sweet:

P.S. Comment je fais pour installer grub sans tout faire foirer??

apt-get install grub :stuck_out_tongue:

Alors du nouveau tryphoon ?

Alors pour /boot/grub/grub.config ça n’existe pas!!! :frowning:
Mon fstab est là

Voilà le retour de commmande ls /boot/

Dites moi que c’est pas la cata!!!

Pour info, chez moi sous ubuntu, la config de grub se trouve dans /boot/grub/menu.lst
Par contre je le vois pas dans le ls /boot que tu as fait :heink:

D’où un gros problème pour moi!!!

Je crois que j’ai à peu près tout réussi à trouver mais je n’ai pas de menu.lst !! Je ne sais pas comment le (créer) configurer!!

Je patauge et je présent que si j’éteins mon PC, il ne se rallumera plus!!!

Voila le mien:


# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.           
default  4

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout  10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title  Windows 95/98/NT/2000
# root  (hd0,0)
# makeactive
# chainloader	+1
#
# title  Linux
# root  (hd0,1)
# kernel	/vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hda6 ro vga=771

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,5)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## nonaltoption boot targets option
## This option controls options to pass to only the
## primary kernel menu item.
## You can have ONLY one nonaltoptions line
# nonaltoptions=quiet splash

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## ## End Default Options ##

title  Ubuntu, kernel 2.6.12-9-386 
root  (hd0,5)
kernel  /boot/vmlinuz-2.6.12-9-386 root=/dev/hda6 ro vga=771 quiet splash
initrd  /boot/initrd.img-2.6.12-9-386
savedefault
boot

title  Ubuntu, kernel 2.6.12-9-386 (recovery mode)
root  (hd0,5)
kernel  /boot/vmlinuz-2.6.12-9-386 root=/dev/hda6 ro vga=771 single
initrd  /boot/initrd.img-2.6.12-9-386
boot

title  Ubuntu, [memtest86+](http://www.clubic.com/telecharger-fiche10823-memtest86.html)
root  (hd0,5)
kernel  /boot/memtest86+.bin  
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title  Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title  Microsoft Windows XP Professionnel
root  (hd0,0)
savedefault
makeactive
chainloader	+1

J’espère que ça t’aidera.

C’est quand meme bizarre ton affaire, t’as bien utilisé apt-get ou synaptic pour installer grub?

maintenant tu as installé quoi ? grub ou lilo ?

si tu as installé grub (et viré lilo), tu peux faire :
#sudo dpkg-reconfigure grub (=> reconfigure grub)
#sudo grub-install /dev/hdX (en remplaçant X par la lettre de ton disque dur) (=> installe grub dans le 1er secteur [MBR] de ton disque hdX)
#sudo dpkg-reconfigure linux-image-$(uname -r) (=> reconfigure ton noyau, et modifie le menu de grub pour afficher les différents choix)

si tu as lilo… aucune idée :paf:

Voilà ce que cela me donne: