Forum Clubic

Compiler gcc 2.96 - ordre d'application des pacthes

Je sais que la version 2.96 n’est pas une reference (voir meme pire :non: ) !!!!

Mais néanmoins j’ai absolument besoin de la compiler, du coup je me retrouve avec une archive contenant un compilo (les sources) en version gcc-2.96-20000731 plus une floppée de fichiers *.patch (~400) mais rien pour me dire dans quel ordre appiquer ces patches.

Si quelqu’un peu m’aider a trouver l’ordre ce serait :super:
voir meme :clap:
et :bounce:

Heu où as tu trouvé ça? Si l’archive s’appelle 2.96, que fait là cette floppé de patchs?

Essaye ça : http://ftp.debian.skynet.be/ftp/ubuntu/poo…rse/g/gcc-2.96/

Au passage, je suppose que c’est pour compiler un module d’un soft compilé avec ce gcc là. Es tu sûr à 100% que tu ne peux pas forcer un 2.95? Bref, qu’est ce qui fait qu’on en arrive à devoir utiliser le 2.96?

Pour trouver c’est pas trop dure il suffit de prendre rpmfind.net et il y a tout la vie de GCC en general et de la 2.96 en particulier, et en faite chaque evolution de la 2.96 a ete faite, par patches, par rapport a la reference.
On en arrive a 400 patches pour faire un gcc 2.96 qui se tient mais dans quel ordre, c’est un mistere.

Tu as bien ciblé le besoin, j’ai une appli, que je n’ai pas developpé, mais qui a ete faite en gcc 2.96 et je sais que ca marche mais comme on veut migrer les OS linux de nos machine (RH7.3) vers du fedora 3 ou 4 on est obliger de garder quelque part un gcc 2.96 mais je n’arrive pas a le reconstruire.
J’ai essayer en recompilant un gcc 2.95.4, ca marche presque si ce n’est que j’ai un sigsegv au lancement de l’appli, la version gcc 3.2.3 n’est pas contente des le depart avec des choses dans la STL il me semble et gcc 3.4.x idem.

Donc je suis preneur de toute aide pour me donner l’ordre d’application des patches.

merci