Forum Clubic

Compiler Gaim à la main -> ok mais rien dans /usr/bin :|

Bonsoir :stuck_out_tongue:

Je viens de compiler gaim-vv sous ma gentoo par pour le support webcam mais simplement pour essayer de modifier 2-3 petites choses dans l’interface graphique de gaim :stuck_out_tongue:

Seulement après avoir installer les dépendances et tappez :

./configure
make
make install

Je n’ai rien dans /usr/bin :??: J’ai bien un gaim-vv dans le dossier /src mais ./gaim-vv ne fonctionne pas …

J’ai trouvé un executable dans /usr/local/bin mais la soucis avec le protocol ssl.

J’ai bien toutes les dépendances car gaim qui lui est emergé avec portage tourne très bien :slight_smile: ( j’ai fait le test en compilant gaim à la main même soucis )

Une petite idée ? Merci d’avance :slight_smile:

faut ptêt passer une option spécifique pour avoir ssl dans Gaim. Ensuite, c’est normal qu’il aille dans /usr/local/bin, d’après le FHS, les programmes compilés manuellement doivent avoir comme préfixe /usr/local. Pour le mettre dans /usr, il faut passer le paramètre “–prefix=/usr” à configure

[cpp]# Copyright 1999-2005 Gentoo Foundation

Distributed under the terms of the GNU General Public License v2

$Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-1.3.0.ebuild,v 1.10 2005/05/25 16:55:35 mcummings Exp $

inherit flag-o-matic eutils toolchain-funcs debug

DESCRIPTION=“GTK Instant Messenger client”
HOMEPAGE=“http://gaim.sourceforge.net/
SRC_URI=“mirror://sourceforge/gaim/${P}.tar.bz2”

LICENSE=“GPL-2”
SLOT=“0”
KEYWORDS=“alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86”
IUSE=“nls perl spell nas cjk gnutls silc eds krb4 tcltk debug”

RDEPEND=">=x11-libs/gtk±2.0
>=dev-libs/glib-2.0
nas? ( >=media-libs/nas-1.4.1-r1 )
media-libs/libao
>=media-libs/audiofile-0.2.0
perl? ( >=dev-lang/perl-5.8.2-r1
!<perl-core/ExtUtils-MakeMaker-6.17 )
spell? ( >=app-text/gtkspell-2.0.2 )
gnutls? ( net-libs/gnutls )
!gnutls? ( >=dev-libs/nss-3.9.2-r2 )
silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
eds? ( gnome-extra/evolution-data-server )
krb4? ( >=app-crypt/mit-krb5-1.3.6-r1 )
tcltk? ( dev-lang/tcl
dev-lang/tk )
x11-libs/startup-notification"

DEPEND="$RDEPEND
dev-util/pkgconfig
nls? ( sys-devel/gettext )"

List of plugins

app-accessibility/festival-gaim

net-im/gaim-blogger

net-im/gaim-bnet

net-im/gaim-meanwhile

net-im/gaim-snpp

x11-plugins/autoprofile

x11-plugins/gaim-assistant

x11-plugins/gaim-encryption

x11-plugins/gaim-extprefs

x11-plugins/gaim-latex

x11-plugins/gaim-otr

x11-plugins/gaim-rhythmbox

x11-plugins/gaim-xmms-remote

x11-plugins/gaimosd

x11-plugins/guifications

print_gaim_warning() {
ewarn
ewarn “If you are merging ${P} from an earlier version, you may need”
ewarn “to re-merge any plugins like gaim-encryption or gaim-snpp.”
ewarn
ewarn “If you experience problems with gaim, file them as bugs with”
ewarn “Gentoo’s bugzilla, http://bugs.gentoo.org. DO NOT report them”
ewarn “as bugs with gaim’s sourceforge tracker, and by all means DO NOT”
ewarn “seek help in #gaim.”
ewarn
ewarn “Be sure to USE=“debug” and include a backtrace for any seg”
ewarn “faults, see http://gaim.sourceforge.net/gdb.php for details on”
ewarn “backtraces.”
ewarn
ewarn “Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php
ewarn
einfo
einfo “Note that we are now filtering all unstable flags in C[XX]FLAGS.”
einfo
ebeep 5
epause 3
}

pkg_setup() {
print_gaim_warning
if use krb4 && ! built_with_use mit-krb5 krb4 ; then
eerror
eerror You need to rebuild app-crypt/mit-krb5 with USE=krb4 in order to
eerror enable krb4 support for the zephyr protocol in gaim.
eerror
die “Configure failed”
fi
}

src_unpack() {
unpack ${A}
cd ${S}
use cjk && epatch ${FILESDIR}/gaim-0.76-xinput.patch

# Fix silc building
if use silc ; then
	cd ${S}/src/protocols/silc
	epatch ${FILESDIR}/gaim-1.3.0-silc-ft.patch
	cd ${S}
fi

}

src_compile() {
# Stabilize things, for your own good
strip-flags
replace-flags -O? -O2

# -msse2 doesn't play nice on gcc 3.2
[ "`gcc-version`" == "3.2" ] &amp;&amp; filter-flags -msse2

local myconf
use debug &amp;&amp; myconf="${myconf} --enable-debug"
use perl || myconf="${myconf} --disable-perl"
use spell || myconf="${myconf} --disable-gtkspell"
use nls  || myconf="${myconf} --disable-nls"
use nas &amp;&amp; myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
use eds || myconf="${myconf} --disable-gevolution"
use krb4 &amp;&amp; myconf="${myconf} --with-krb4"
use tcltk || myconf="${myconf} --disable-tcl --disable-tk"

if use gnutls ; then
	einfo "Disabling NSS, using GnuTLS"
	myconf="${myconf} --enable-nss=no"
	myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
	myconf="${myconf} --with-gnutls-libs=/usr/lib"
else
	einfo "Disabling GnuTLS, using NSS"
	myconf="${myconf} --enable-gnutls=no"
	myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
	myconf="${myconf} --with-nss-includes=/usr/include/nss"
	myconf="${myconf} --with-nspr-libs=/usr/lib/nspr"
	myconf="${myconf} --with-nss-libs=/usr/lib/nss"
fi


econf ${myconf} || die "Configuration failed"

emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"

}

src_install() {
make install DESTDIR=${D} || die “Install failed”
dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
}

pkg_postinst() {
print_gaim_warning
}
[/cpp]

Voila le ebuild de gentoo j’ai essayé :

./configure --with-gnutls-includes=/usr/include/gnutls --with-gnutls-libs=/usr/lib

Mais ca ne passe pas :confused:

si tu as une autre idée … Merci de ton aide :jap:

Peut-être que cette version ne supporte pas SSL ?

Je ne pense pas car j’ai pris gaim 1.3.0 je l’ai recompilé a la main et j’ai le même soucis et par portage çà fonctionne.

Je vais revoir sur le site de gaim si il n’y a pas une astuce.

Sinon essai d’adapter l’ebuild de gaim a gaim-vv et de le mettre dans l’overlay de portage, en plus se sera plus propre.

./configure --with-gnutls-includes=/usr/include/gnutls --with-gnutls-libs=/usr/lib --with-nss-libs=/usr/lib/nss --with-nspr-libs=/usr/lib/nspr --with-nss-includes=/usr/include/nss --with-nspr-includes=/usr/include/nspr

Voila la solution :jap: j’ai repris les ligne de l’ebuild ca passe :wink:

+1

Salut :wink:

Je peux rajouter ou créer mon propre ebuild ? J’ai regardé l’autre jour comment ebuild fonctionnait mais si je me souviens bien il est lier à un autre fichier qui vérifie la taille du packet ainsi que son checksum md5.
Je suppose qu’on sait faire sauter çà.

Je vais regarder çà tout à l’heure car la je suis repassé du mauvais coté de la force pour imprimer mes cours :smiley:

Merci :wink:

mets tes ebuilds dans le chemin pointé par le PORTDIR_OVERLAY que tu as peut-etre renseigné dans le /etc/make.conf. si ce n’est pas le cas, tu devines ce que tu dois faire