Forum Clubic

Comment réinstaller "Client pour réseau Microsoft" ?

:(Bonjour,

J’essaie de relier 2 ordi avec un cable RJ 45 inversé (crossover cable), mes deux ordi sont sur Windows 2000 Pro.

L’ordi “Invité” (sous version française de W2000 que j’ai appellé “P3”) est capable de voir l’ordi “Hôte” (sous version anglaise de W2000 que j’ai appellé “P2”); à travers “Favoris réseau > Ordinateurs proches du mien > P2. Lorsque je clic sur P2, je vois la boite “Saisie du mot de passe réseau” qui dit: “Mot de passe incorrect ou nom d’utilisateur inconnu pour \P2”. J’en conclus que les cartes réseau et le cable inversé fonctionnent bien. Les propriétés de cette connection montrent que la connection utilise les composantes “Client pour le réseau Microsoft”, Partage de fichiers et d’imprimantes…” et le protocole TCP/IP.

Mon problème se situe au niveau du P2 lorsque j’essaie de configurer la connexion réseau du P2 en Hôte (host) via le Network Connection Wizard. Je peux choisir mon type de connexion (Connect directly to another computer) mais lorsqu’Il demande me demande de choisir entre “Host” ou “Guest” (je prend Host) et que j’appuie sur Next, j’obtient le message d’erreur suivant du Wizard:

“: Incoming Connections depend on the Routin and Remote Access servic wich was unable to start. For more information check the system event log”. (J’ai esayé de trouver ce “system event log” sans succès…)

Je crois que ce message est le résultat d’une erreur que j’ai faite auparavant. J’avais réussi à configuer une connexion Hôte sur cet ordi (P2) mais je n’arrivais pas à régler un problème de mot de passe; j’ai alors (stupidement!) désinstallé la composante “Client pour le résau Microsof” de cette connexion et voyant que je n’arrivais nul part, j’ai supprimé cette connection pour la recommencer “à neuf”. C’est à ce moment que j’ai reçu le message d’erreur cité plus haut…

J’ai vérifié les propriétés de ma connection internet (ADSL via carte réseau) et j’ai remarqué que la composante Client pour réseau Microsoft, qui était présente avant, avait disparue…

J’ai désinstallé & réinstallé (via Control Panel > Add/Remove programs > Add/Remove Windows Componants) composantes suivantes de Windows:

  • Networking Services
  • Other Network File and Print Services
  • Internet Information Services (ISS)

J’ai réessayer de configuer ma “connection directe” et je reçois le même message d’erreur et la composante Client pour réseau Microsoft est toujours absente de ma connexion ADSL.

Ma question est donc : comment réinstaller la composante “Client pour réseau Microsoft” sans avoir à réinstaller complètement Windows 2000 ?

Merci de vos conseils…
Robert

salut,

J’ai désinstallé & réinstallé (via Control Panel > Add/Remove programs > Add/Remove Windows Componants) composantes >>suivantes de Windows:

  • Networking Services
  • Other Network File and Print Services
  • Internet Information Services (ISS)

J’espère que tu as réinstallé comme il faut tous les composants par défaut. Autrement ca va être galère de chercher un service manquant et qui devait être activé…
Et je pense à celui là en particulier quand il s’agit de ‘partage connexions’.
support.microsoft.com…

Parce que normalement l’utilisateur n’a pas à toucher au niveau des ‘ajouts/supp composants’, sutout quand il s’agit de composants systèmes.

Reviens sur Gest de périph, supprime ta carte réseau et les composants par défaut vont revenir d’eux mêmes, y compris ‘Client pour réseau Microsoft’. Si cela ne revient pas, lis les *.inf (de mémoire les oemX.inf -X étant un chiffre) ou les .inf ayant un rapport avec la marque ou modèle de ta c.réseau et supprimer l’.inf fautif pour pouvoir réinstaller complètement ta c.réseau au redémarrage.
Puis tu vas t’affecter des:

  1. ‘ip manuel’ (192.168.0.x ou en 192.168.1.x) pour chaque poste faisant partis
  2. d’un même ‘groupe de travail’ avec la ‘passerelle’ qui va bien.
  3. partage juste un dossier dans chacun des postes à des fins de tests.
  4. cmd > ping depuis l’hôte vers l’invité et vice versa.

Salut houba,

J’ai réussi à réinstaller la composante “Client pour réseau Microsoft.” Mon problème est maintenant de configurer ma “connection directe” entre mes deux ordi. Je vais donc faire un ‘sujet’ dans le forum “Réseau”. Juste au cas où tu pourrais m’aider avec ce problème, je te transmet les données que j’ai rassemblées à ce sujet:

=>les deux PC ont le Service Pack4 et sont régulièrement mis à jour via Windows Update.

=> Les 2 pc sont distant de 2 mètres.

=> Le but ultime c’est le partage de fichiers et (optionnel mais intéressant) de la connexion Inet.

A) le P3 voit le P2 dans voisinage de réseau et j’obtiens une demande de login et password.

B) je ne vois pas P3 dans le voisinage de réseau de P2

C) la config réseau de P2 est :
(vu dans “Incoming Connection Properties” via Control Panel > Network and Dial up Connection)

Onglet General > Dans la boite Devices il y a un crochet dans “Communications cable between two computers (COM 1)” et dans “Show icons on taskbar when connected”.

Onglet Users > il y a 4 Users configurés (chacun avec un crochet devant) et un crochet dans “Always allow directly”. Les Users configurés sont:

  1. “Administrator”. Dans les propriétés (bouton Properties) on voit:
    Onglet General:
    User name : Administrator (sur fond grisé)
    Full name: vide
    Password: une douzaine de petits “x” enlignés
    Confirm password:une douzaine de petits “x” enlignés
    Onglet Callback: le point est devant “Do not allow callback”

  2. “Guest (suivi de “P3” entre parenthèses)”. Dans les propriétés (bouton Properties) on voit:
    Onglet General:
    User name : Guest (sur fond grisé)
    Full name: P3
    Password: une douzaine de petits “x” enlignés
    Confirm password:une douzaine de petits “x” enlignés
    Onglet Callback: le point est devant “Do not allow callback”

  3. "IUSR_P2 (suivi de “Internet Guest Account” entre parenthèses). Dans les propriétés (bouton Properties) on voit:
    Onglet General:
    User name : IUSR_P2 (sur fond grisé)
    Full name: Internet Guest Account
    Password: une douzaine de petits “x” enlignés
    Confirm password:une douzaine de petits “x” enlignés

    Onglet Callback: le point est devant “Do not allow callback”

  4. "IWAM_P2 (suivi de “Internet Guest Account” entre parenthèses). Dans les propriétés (bouton Properties) on voit:
    Onglet General:
    User name : IWAM_P2 (sur fond grisé)
    Full name: Internet Guest Account
    Password: une douzaine de petits “x” enlignés
    Confirm password:une douzaine de petits “x” enlignés

    Onglet Callback: le point est devant “Do not allow callback”

Onglet Networking > Dans la boite “Network components”, il y a:

-un crochet devant TCP/IP. Dans les propriétés, je vois, sous “Network Access”, un crochet devant “Allow callers to access my LAN”; et, sous “TCP/IP adress assignment”, un point devant “Assign TCP/IP adresses automaticly using DHCP”.

-un crochet devant File and Printer Sharing for Microsoft Networks,

-un crochet devant Client for Microsoft Network; CEPENDANT le crochet devant cet item est sur fond grisé (je crois qu’une partie du problème est là…). Dans les propriétés/onglet RPC Service, je vois dans “Name service provider” => Windows Locator.

D) Les propriétés de la config réseau du P3 qui "voit le P2 sont (tel que vues dans les “Propriétés de Connexion au P2” via Panneau de Controle > Connexions réseau et accès à distance):

Onglet General (le seul présent pour cette connection)=> La connection utilise ma carte réseau ethernet (SMC 9332BDT EterPower 10/100 => écrit sur fond grisé)

Dans la boite “Les composant sélectionnés sont utilisés par cette connexion” il y a:

-un crochet devant Client for Microsoft Network; CEPENDANT le crochet devant cet item est sur fond blanc (alors que sur le P2 il est sur fond grisé) . Dans les propriétés/onglet Service RIPC, je vois dans “Fournisseur de service de nom”=> Service de recherche Windows…

-un crochet devant TCP/IP. Dans les propriétés, je vois un point devant “Obtenir une adresse IP automatiquement” et un autre devant “Obtenir une adresse des serveurs DNS automatiquement”. Dans les paramètres TCP/IP avancés/onglet Paramètres IP, je vois que DHCP est activé.

-un crochet devant "Partage de fichiers et d’imprimantes pour les réseaux Microsoft.

-un crochet devant “Afficher une icône dans la barre des tâches une fois connecté”

**** Point important****: La boite de propriétés de la connexion du P3 est différente de celle rencontrée sur le P2: il y a seulement un onglet (Général) sur lequel je vois que la connexion utilise ma carte réseau Ethernet PCI (une SMC 9332BDT EtherPower 10/100) sur laquelle est branchée mon cable inversé.

La différence fondamentale (que je viens juste de m’apercevoir!) est que sur le P2, je n’ai pas l’option d’utiliser la carte réseau installée sur celui-ci (une Realtek RTL 8019 LAN adapter or compatible PCI to ISA bridge) et sur laquelle est branché mon cable inversé.

Les seules options du P2 au niveau des Devices disponibles sont :
a) Communications cable between two computers (COM1)
b) Direct Parallel (LPT1).

CEPENDANT, le cable inversé est connecté sur la carte réseau Realtek sur laquelle est configurée une “vieille” connection Internet (via Modem ADSL et cable ethernet). Ma “nouvelle” connection Internet utilise toujours le même Modem ADSL mais j’utilise maintenant un cable USB (pcq je voulais libérer la carte réseau pour pouvoir connecter mes deux ordis ensemble).

DONC, je crois que le problème est l’impossibilité de choisir la carte Réseau RealTek pour configuer ma connection directe. J’ai essayé différentes opérations pour remédier à ce problème:

a) J’ai supprimé ma connection directe pour essayer de la configurer de nouveau.Quand je reconfigure (avec le Network Connection Wizard) une nouvelle connection directe; je ne vois toujours pas l’option de pouvoir choisir ma carte RealTek (j’ai seulement le choix entre “direct cable (COM1)” et "Direct Paralell (LPT1). Lorsque je complète ma configuration en utilisant "direct cable (COM1), je retrouve les mêmes propriétés du P2 citées plus haut.

b) Lorsque j’essaie du supprimer ma “vieille” connection Inet qui utilise ma carte réseau (via Control Panel/Network connection) j’obtient le message d’erreur “The connection you selected cannot be deleted”. J’obtient le même message d’erreur si j’essaie de Désactivé ma carte préalablement (via le Device Manager).

Je crois donc que le problème est donc de pouvoir libérer ma carte réseau Realtek pour pouvoir la configurer en connection directe… Comment se fait-il que je ne peux supprimer ma “vieille” connection même si je désinstalle la carte dans le Device Manager???

Toutes les suggestions sont bienvenues!

Cordialement,
Robert
Edité le 06/04/2008 à 23:02