Forum Clubic

Comment lire une vidéo mkv encodée en h.264 avec accélération matérielle GPU ?

Bonjour,
je veux lire une vidéo mkv encodée en h.264 en profitant de l’accélération matérielle GPU. J’ai une GeforceM 8800GTS (Purevideo HD).
Les classiques PowerDVD et Nero ne reconnaissent pas le mkv même s’ils supportent apparemment le PureVideo.
Une solution ?
Merci !

si tu lis ta vidéo est que tu constates des saccades, c’est que ton micro n’est pas assez puissant pour lire des vidéos HD.
pour lire tes vidéos mkv, il te faut les codecs (matroska) et un bon micro genre core 2 duo, ça passe nickel (vidéo en 720).
pour le support GPU des vidéos HD, il faut que les pilotes de ta carte vidéo, les codecs vidéos et l’os gére la prise en charge décodage GPU (dans un avenir proche, on l’éspère).
source : www.homecinema-fr.com…

télécharge plus tot matroska!!!

J’ai des saccades sur VLC mais ça roule sans problème sur WMPlayer avec le codec ffdshow pour des vidéos en 1080p (j’ai un T8100 - 4Go RAM - Geforce 8800M GTS). Le seul problème, c’est que ça me bouffe 60% de ressources CPU alors qu’avec une accélération matérielle, c’est censé tourner à 5%.

En gros, si je lance un Blu-Ray, je peux profiter de l’accélération matérielle grace à PowerDVD qui gère les Blu-Ray et le moteur de décompression matériel PureVideo mais comme il ne supporte pas le mkv, je ne peux pas l’utiliser et je suis obligé de chercher un codec H.264 (compatible WMPayer) qui gère l’accélération GPU nvidia en l’occurrence PureVideo.

Apparemment Media Player Classic supporte l’accélération matérielle d’après ce que j’ai vu à la fin de ton lien, mais ça me donne toujours autour de 40% d’occupation CPU. Je me résigne…

Salut Big Brother,

Il faut prendre la version Home Cinema de Media Player Classic.
mpc-hc.sourceforge.net…
Edité le 23/11/2008 à 22:05

C’est bien la version Home Cinema que j’ai…
D’ailleurs j’ai l’impression que l’accélération matérielle est bien activée mais la consommation CPU reste à 40% i.e. très proche de ce que j’atteins avec WMPlayer. Dans Option / Internal Filters / H264/AVC(DXVA), DXVA en dessous duquel est écrit Geforce 8800M GTS est enabled.

Bizarre car perso je tombe à moins de 5 % de ressources processeur avec une ATI HD4850.