Forum Clubic

Comment lire un simple divx sur ubuntu warty ?

voilou je n’arrive pas à lire une video. Il y a un player qui est deja fourni : totem et celui n’y arrive pas…

Je pense que cela est plus du à un probleme de codec, j’ai donc installé le paqeut ftp://ftp.nerim.net/debian-marillat/dists/stable/main/binary-i386/w32codecs_20040916-0.0_i386.deb :

[cpp]root@mobile:/home/alex/Desktop # dpkg -i w32codecs_20040916-0.0_i386.deb
(Lecture de la base de données… 62444 fichiers et répertoires déjà installés.)Préparation du remplacement de w32codecs 1:20040916-0.0 (en utilisant w32codecs_20040916-0.0_i386.deb) …
Dépaquetage de la mise à jour de w32codecs …
Paramétrage de w32codecs (20040916-0.0) …[/cpp]

mais cela ne marche toujours pas. Comment faire ?

vas dans une console passe en root
tape apt-get update
puis apt-get install mplayer (ou gmplayer pour le gui)
ensuite essai de lire ta video avec

erf encore quelqu’un qui n’est pas allé voir dans la docu de ubuntulinux.org :confused:

Chez ubuntu ils ont hérité du “fanatisme” antiproprio de chez debian, il suffisait donc d’activer ubuntu-universe dans tes sources…

Et comment on fait pour que mplayer ne merde pas ?! Dans mon cas, j’utilise mplayer-custom et je deviens fou. Meme pour le compiler, ca foire. Je regrette ma debian sid que j’ai cassé.
Erreur pour mplayer-custom :
[fixed]
MPlayer interrupted by signal 4 in module: init_audio_codec

  • MPlayer crashed by an ‘Illegal Instruction’.
    It usually happens when you run it on a CPU different than the one it was
    compiled/optimized for.
    Verify this!
  • MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with --enable-debug and make a ‘gdb’ backtrace and
    disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn’t happen.
    It can be a bug in the MPlayer code or in your drivers or in your
    gcc version. If you think it’s MPlayer’s fault, please read
    DOCS/HTML/en/bugreports.html and follow the instructions there. We can’t and
    won’t help unless you provide this information when reporting a possible bug.
    [/fixed]

je ne pense que ce soit un probleme de player. Totem meme s’il est 1000 fois moins puissant mplayer doit pouvoir lire autant de format de video que les autres players dont totem

c’est plus une question de codec pour moi …

je l’ai activer
je suis sous windows pour lire ma video, je vous donnerais mon /etc/apt/source.list

PS : j’ai honte, j’utilise vlc media player sous wiwi, je crois qu’il existe sous linux

lol

apt-get install gstreamer-ffmpeg
apt-get install gstreamer-mad
ou
apt-get install vlc
ou
apt-get install w32codecs (avec depot marillat)
puis
apt-get install totem-xine
ou
apt-get install mplayer
ou
apt-get install xine-ui

il existe dans multiverse (qu’il faut activer aussi)
personnellement, j’ai laisse tomber le depot marillat car il y a trop de problemes de dependances avec la ubuntu
quant a vlc, il est super mais il ne lit pas encore les wmv9 (c’est prevu bientot)

voila c’est ca ! totem est tout a fait capable de lire pleins de formats si il utilise les libs de xine :smiley:
celui la tourne au poil…
sinon tu peux installer xine direct mais il sera moins bien integre a gnome

+1 Pour VLC jamais eu un probleme avec ,sans installer un seul codec de rab il lit a peu pres tout ,en plus (soyons chauvins)il est fait par des francais :stuck_out_tongue:

Salut.
Je vais lancé une réponse “trollienne”.
Pourquoi je n ai pas choisi Ubuntu, FC3 ou Suse 9.2?
Parceque sur Mandrake y a pas besoin :slight_smile:
Maintenant allez y; degainez lol

si même les linuxiens se déchirent entre eux…

enfin peut-on appeler un utilisateur de Mdk un linuxien ? :whistle:

désolé j’ai pas pu résister :stuck_out_tongue:

man urpmi :o

La vraie question est : est ce qu’un utilisateur de Debian peut encore être un linuxien normal et non un intégriste debianeux (syndrôme qui se développe fréquemment quand on utilise exclusivement Debian et que l’on perd pied avec la réalité des autres distributions ;)).

j_c_p: c’est même pas vrai :o , les debianistes ne sont pas intégristes.

Ils pensent juste que Debian est la meilleure distrib jamais faite, et que toutes les autres puent, et les pires d’entre elles sont gentoo et gentoo :whistle:

[:tbirdtheyuri]

:d ;).

Bin je suis un debianeux qui aime beaucoup gentoo :o :stuck_out_tongue:

+1 Idem. Dernierement, j’ai mis la ubuntu hoary et elle est pas mal. Mais impossible de compiler mplayer :stuck_out_tongue:

j’ai pas fait

je viens de le faire et ca marche nickel comme sous wiwi

[/quote]

comme tu as pu le voire j’ai installé w32codec
[cpp] * root@mobile:/home/alex/Desktop # dpkg -i w32codecs_20040916-0.0_i386.deb
* (Lecture de la base de données… 62444 fichiers et répertoires déjà installés.)Préparation du remplacement de w32codecs 1:20040916-0.0 (en utilisant w32codecs_20040916-0.0_i386.deb) …
* Dépaquetage de la mise à jour de w32codecs …
* Paramétrage de w32codecs (20040916-0.0) …[/cpp]
mais j’ai pas essayé avec les player que tu as cité …
totem-gestreamer, c’est le player par defaut de ubuntu. Il n’est pas bien ?
si cela marche pas avec lui cela marche pas avec les autres, je pars de ce principe la …

comme je te l’ai dis ca été activé
[cpp]root@mobile:/home/alex # cat /etc/apt/sources.list
deb cdrom:[Ubuntu 4.10 Warty Warthog - Preview i386 Binary-1 (20041020)]/ unstable main restricted

deb http://archive.ubuntu.com/ubuntu warty main restricted
deb-src http://archive.ubuntu.com/ubuntu warty main restricted

Uncomment the following two lines to add software from the ‘universe’

repository.

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team, and may not be under a free licence. Please satisfy yourself as to

your rights to use the software. Also, please note that software in

universe WILL NOT receive any review or updates from the Ubuntu security

team.

deb http://archive.ubuntu.com/ubuntu warty universe
deb-src http://archive.ubuntu.com/ubuntu warty universe

deb http://security.ubuntu.com/ubuntu warty-security main restricted
deb-src http://security.ubuntu.com/ubuntu warty-security main restricted

deb http://backports.ubuntuforums.org/backports warty-backports main universe multiverse restricted
deb http://backports.ubuntuforums.org/backports warty-extras main universe multiverse restricted

deb ftp://ftp.nerim.net/debian-marillat/ stable main
[/cpp]

Mauvais principe :stuck_out_tongue:

Actuellement sous linux tu as 4 ‘lib’ qui permette de lire une vidéo:
vlc qui est capable de lire de nombreux formats.
mplayer et xine qui sont capable de lire les formats courants par defaut, au quel tu peux ajouter les codecs w32 pour lire les formats qui n’ont pas de décodeur natif (real, wm*)
gstreamer, relativement jeune et inutilisable pour les vidéos chez moi.
Par defaut, gstreamer sous ubuntu ne sait lire que les formats libre, on ajoute ensuite des plugins (gstreamer-ffmeg pour les avi, gstreamer-mad pour le mp3).
Tout les autres lecteur utilisent une de ces libs (totem, kaffeine, …)

C’est un peu le boxon :), mais en général, un xine ou un vlc suffise largement.