Forum Clubic

Comment formuler ce qui suit ?

1formule xls pour: SI(A1)=entre1et6=12, entre6et8=18,entre8et10=24 merci.


1formule xls pour: SI(A1)=entre1et6=12, entre6et8=18,entre8et10=24

moi je representerai ça sur 3 colonnes avec une formule du genre:
1ere colone: si(a1<6;12;"")
2e colonne : si(a1<8;18;"")
3eme colonne :si(a1<10;24;"")

c plus simple pour s y retrouver apres …


et si tu veux le resultat sur une colonne ..tu adittionnes tes 3 colonnes sur une 4eme et voila ..

=SI(ET(A1>0;A1<6);12;(SI(A1<8;18;(SI(A1<=10;24;“Chiffre Supérieur à 10”)))))

ça marche oneshot …bien joué…

En fait la formule exacte est :

=SI(ET(A1>0;A1<6);12;(SI(ET(A1>=6;A1<8);18;(SI(ET(A1>=8;A1<=10);24;SI(A1>0;“Chiffre Supérieur à 10”;“Chiffre Trop Petit”))))))

Afin de rajouter un controle sur les nombres inférieur à 1
Edité le 16/01/2008 à 13:06

Saleté de smyleys qui veut pas se desactiver je suis obligé de mettre un espace:

=IF(AND(A1>0;A1<6);12;(IF(AND(A1>=6;A1<8 );18;(IF(AND(A1>=8;A1<=10);24;IF(A1>0;“Chiffre Supérieur à 10”;“Chiffre Trop Petit”))))))
Edité le 16/01/2008 à 13:07

tu vois que tu y as reflechi qd meme … :super:

C’est vrai, ca me turlupinait !! :ange:

y a ça aussi …moins long et ça marche
=SI(A1<1;“A1 < 1”;SI(A1<=6;12;SI(A1<=8;18;SI(A1<=10;24;“A1 > 10”))))