Forum Clubic

Comment faire passer sur un autre disque les infos - pour le boot (IDE vers SATA)

Bonjour,

J’ai actuellement 2 disques sur lesquels sont installées deux copies de windows XP. L’une, la première a avoir été installée est sur un disque dur IDE. J’ai ensuite rajouté un disque SATA sur lequel j’ai remis une version de windows XP, en l’installant sans débrancher le premier disque (où il y avait donc alors la première copie de windows).

Mon problème est donc de passer les informations nécessaires au boot sur le disque SATA afin de me débarrasser du premier disque et pouvoir booter sans.

J’ai déjà essayé de mettre les fichiers boot.ini, ntdetect.com, ntldr et bootfont.bin sur la session sur laquelle j’ai installé la deuxième copie de windows. Mais lorsque je démarre, j’ai un message m’indique qu’il ne trouve pas de session de boot. Je demande comment faire car j’aimerais y arriver sans avoir à formater et réinstaller windows.

Merci d’avance.

:hello:

Si tu veut juste rendre ton disque bootable, procede comme suit :

Demarre sur le CD d’installation de Windows
Choisi R pour reparer windows et lancer la console de recuperation.

Tu choisi ensuite la partition de ton disque SATA (a la limite, tu debranche ton DD ide).

Et a l’invite tu tape ceci :

FIXBOOT
FIXMBR

Tu tape exit pour redemarrer, et logiquement c’est bon.

Quand je tape fixboot, j’ai le message suivant : “fixboot ne peut pas trouver le lecteur système ou le lecteur spécifié n’est pas valide”. La commande fix mbr fonctionne.
Qu’est ce que je pourrais essayer d’autre, car XP ne boot toujours pas sur le disque SATA ?

quelques questions :
le sata est bien en premier disque de boot dans le bios?
il y a bien une partion primaire dessus ?

sinon tu peut aussi essayer un bootcfg /rebuild

Dans le BIOS je ne peut que choisir de booter sur les disques durs, je n’ai pas le choix pour le disque à mettre en premier.
Pour la partition hé bin … pour la partition primaire, j’en suis aps sûr du tout, vu qu’il me semble que windows ne crée qu’une seule partition primaire et que j’en avais déjà une sur mon autre disque, donc je dirais plutôt non. Je vais vérifier ça.

Partition magic m’indique que j’ai une partition principale sur mon disque SATA. Maintenant je sais pas si Principale = Primaire :confused:

Tu n’a pas une option “Boot SCSI” ou “another device” … voir meme “SATA” ?

Pour plus d’infos: c’est quoi la carte mere ?

car tout depend de si le controleur SATA est à part ou integré au chipset (nforce4 par ex)

J’ai activé “Try other devices” et j’ai une ABIT KN8 Ultra, donc nForce 4 ultra.

bon ben si c’est nforce4 alors les disque SATA sont reconnu sans probleme comme disque dur au meme titre que les disque PATA. Donc laisse sur" disque dur".

Le truc c’est qu’il faut que tu active la partition sur laquelle tu as mis ton systeme.

Avec partition magic ou meme depuis le gestionnaire de disque windows, verifie que la partition soit bien activée (donc bootable)

ensuite un petit coup de fixboot et fixmbr et ça devrait rouler

ça n’a pas marché, je vous met coment j’ai procédé pour voir si il n’y a pas une erreur :

1- Patition magic --> je définis d: (partition primaire du lecteur SATA) comme partition active.
2- redémarrage
3- Démarrage sur le cd d’XP
4- Restauration : “fixboot” -> marche pas, comme avant.
5- “fixmbr”
6- Restart -> il ne boot pas sur la partition d:
7- Je rebranche mon IDE et là il ne boot que si je met le cd de windows et que je ne démarre pas du cd. :heink:

dans un 2eme essai j’ai débranché le disque IDE et j’ai essayé fixboot (sur c:) -> marche pas puis fixboot d ->marche mais la suite reste la même

Je comprends plus là :??:

EDIT : j’ai oublié de dire pour le 7 : il ne boot pas sans que l’IDE soit branché et partion magic m’indique actuellement que la partition active est c: donc apparemment je n’ai rien changé.

essai de faire plusieurs fixboot/fixmbr

parfois il faut que fixmbr soit fait avant fixboot ou vice-versa

personnellement je lance toujours plusieurs fois les 2 commandes alternativement pour etre sûr.

au fait tu donne bien les bon parametres à fixboot ?

pour etre sur de toi tape fixboot /? et verifi les parametres à donner

Ps: va voir dans le gestionnaire de disque de windows pour activer la partition :slight_smile:

http://webdemarcus.free.fr/Faire/Win2000co…ecuperation.htm

C’est bon ça marche :slight_smile:
En fait je n’indiquais pas sur quel disque faire le fixmbr et donc il le faisait sur l’ancien disque ce qui rendait le reste inutile.
Merci beaucoup. :super:

Ce message n’était pas conforme aux règles d’utilisation du nouveau forum :

:wink:

En lisant le début du topic je me suis dit que ce n’était pas possible que ça ne fonctionne pas et en arrivant en bas, j’ai été rassuré, c’était une erreure de manipulation ouf!

La prochaine fois c’est mieux de le faire tout de suite, plutôt que d’installer 2x windows!