Forum Clubic

Comment faire fonctionner le wifi avec une carte mère msi h87-g43 et uefi

bonjour
je suis possesseur d’une carte mère h87-g43 avec uefi mais je ne peux pas faire fonctionner le wifi
j’ai essayé avec windows 7, avec windows 8.1
avec 2 clé wifi différentes ; une ieee802.11 54bps et une cisco linksys wusb8600n
j’ai également essayé avec une carte TP-Link TL-WN781ND pci
dans tous les cas cela ne fonctionne pas du tout alors que sur des pc plus anciens il n’y a aucun problème
je soupconne que c’est à cause du nouveau bios uefi mais je ne trouve rien sur le net à ce propos, ni aucune mention nulle part de matériel compatible uefi

Thématique sélectionnée : Wi-Fi

Salut,

Cela ne fonctionne pas… précise, il y a un message d’erreur ? les pilotes ne s’installent pas ? Tes versions de Windows sont officielles ?

bonjour
il n’y a aucun message d’erreur, les pilotes s’installent si j’en installe (mais sur mon autre ordi il suffit de brancher n’importe quelle clé wifi pour qu’elle me propose les réseaux disponibles)
mais sur cet ordi ça ne me propose rien quoi que je fasse, dans le device manager la clé ou carte apparait avec un point d’exclamation mais c’est tout, il n’y a rien à faire
il y a un logiciel qui vient avec une des clés wifi mais il reste bloqué sans qu’on puisse rien en tirer
si je cherche sur internet avec uefi et wifi comme mots clé il y a un seul résultat qui pourrait donner une indication, c’est un site où il est noté qu’une carte wifi intel ne prend pas en charge uefi
alors j’ai pensé qu’il s’agissait d’un problème avec uefi le nouveau bios mais personne n’en parle nulle part, j’ai posé la question à MSI, le constructeur de la carte mère mais je n’ai aucune réponse
pour le moment ça reste un mystere

Sinon quand tu branches une clef USb quelconque, cela fonctionne correctement ?

Sinon un flashage du Bios as tu essayé ? Tu as essayé sur les ports USB 2.0 et 3.0 ? Bon après tu as essayé avec une carte PCI donc il y a vraiment un souci.

Tu as une bonne alimentation ? Tes versions de Windows sont elles officielles ?

les clés usb sont correctement lues, les clés wifi sont parfaitement reconnues d’ailleurs mais : pas de réseau ou plutôt pas de wifi, dans windows l’icone pour le wifi (comme une flute de pan) apparait avec une croix rouge
j’ai effectivement essayé les ports usb 2.0 et 3.0
oui j’ai une bonne alim, une FSP hexa 500 , qu’on m’avait conseillé ici

supposant que la carte mère était défectueuse je m’en suis fait renvoyer une nouvelle (du même modèle) par amazon mais cela ne change rien et oui mes versions de windows sont officielles et dûment mises à jour

en fait koala06 j’en viens à penser que le wifi est volontairement empêché sur MSI H87-G43 pour une raison que j’ignore

parce que le wifi on peut le faire marcher sans problème avec des cartes mères qui on été concues avant même que le wifi n’existe, cela fonctionne à partir de windows XP sp2

je pense demander à changer la carte mère pour un autre modèle

en fait je soupçonne maintenant que le bios uefi est incompatible avec tous les périphériques wifi actuels
on trouve des cartes uefi avec un wifi intégré mais elles coutent 300€ en moyenne, les cartes uefi sans wifi intégré coutent moins de 100€
donc ceux qui veulent s’équiper et profiter de la wifi ont intérêt à acheter une carte plus ancienne (bios) s’ils ne veulent pas se ruiner

Perso, je n’y crois pas du tout.

Concrètement il se passe quoi ?

Des réseaux wifi sont détectés ?
Il y a des problèmes (croix sur fond rouge ou point d’exclamation) dans le gestionnaire de périphériques ?

Il est vrai que j’ai monté pas mal de PC et il ne semble pas avoir de problème avec le Wifi.
Dans la semaine je monte un pc a base d’haswell et carte mère Asus pour un client. Je te dirai si j’ai des problèmes de wifi. Je te tiens au jus. :wink:


Après MSi je n'achète plus depuis bien longtemps, j'ai eu pas mal de problème lors de mes assemblages.

bon j’ai commandé une nouvelle carte mère avec le wifi intégré, une asus Z87 pro, comme ça plus de problème

pour répondre à juju j’attend que quelqu’un me dise qu’il a fait fonctionner un wifi autre qu’intégré avec uefi
et je serais très étonné dans ce cas (mais qu’en sais-je après tout)

que se passe-t-il concrètement ? dans le gestionnaire de périphérique cela apparait comme fonctionnant très bien mais ça ne détecte aucun réseau et en réalité ne fonctionne pas du tout
quand je branche la clé, elle est détectée, windows 8.1 l’installe, lui trouve un driver, mais c’est tout, elle ne fonctionne pas, la piste de uefi me semble la meilleure en l’état actuel de mes connaissances

j’attend des nouvelles de koala qet on en saura plus long

Salut,
bon testé avec une clef Wifi koenig, tout est ok, aucun problème. Tout fonctionne très bien. Donc testé avec une Asus à base de z87.

alors le mystere reste entier
merci d’avoir fait le test

Par contre retour SAv de mon côté de ma carte mère Asus, problème de Boot. Lors du premier démarrage, l’ Uefi s’affiche et obliger de choisir manuellement le dur a booter.
Ca commence à me plaire :wink:

Moi je pars sur du H87 en espérant que cela fonctionne correctement.

Ce ne serait pas un réglage dans l’UEFI d’afficher le menu de sélection de boot à chaque lancement ?

philippederrick => Les Windows que tu as essayé sont bien des versions officielles ?

Juju j’espère que ce n’est pas ça sinon j’ai l’air d’un blaireau lol. Normalement on n’a pas ce genre d’option par défaut (je ne savais pas qu’elle existait d’ailleurs, et sacré intérêt :slight_smile: )), dans l’onglet boot j’ai vérifié de fond en comble et un peu partout.

Bon là c’est parti en SAV, je verrai bien.
Je vous tien au jus

salut
bon j’ai reçu ma asus Z87 pro mais j’attend un pote pour l’installer

les windows que j’utilise, Juju, sont des versions officielles que l’on trouve sur internet

voilà j’ai installé une autre version de windows 8.1 et soudain ça fonctionne normalement

c’était donc bien un problème de windows, merci de vos conseils !

Bon moi de mon côté, c’était bien la carte mère qui me posait problème.
Content pour toi Philippe :wink: