Forum Clubic

Comment désactiver le lancement automatique de defrag.exe ?

Bonjour, il arrive sur le PC de ma petite amie un truc que je n’ai absolument jamais vu ailleurs.

defrag.exe , c’est-à-dire le programme de défragmentation de Windows se lance automatiquement en arrière-plan et ce après que le PC ait été inactif pendant quelques minutes.

Je sais que son disque dur est bien vieux et abimé, mais il est parfaitement défragmenté. Comme cela n’arrive pas quand on est occupé dessus, j’imagine que c’est un service qui se lance automatiquement, mais je ne trouve absolument aucune information à ce propos sur le net.

Quelqu’un a-t-il rencontré ce problème ou sait-il me proposer la solution ou le terrain dans lequel fouiller pour la trouver?

D’avance merci!!!

C’est peut-etre le planificateur de taches qui a la defragmentation de programmee ?

pas bête, j’y avais pas pensé, peut-être qu’une tâche se serait créée automatiquement, mais non, y a rien de programmé…

Tu as verifie tous les endroits d’ou defrag aurait pu etre lance (autoruns) ?

oui bien entendu!

et rien du tout…

vraiment personne n’a rencontré ce problème? :??:

Salut,

Elle n’avait pas installé (mais oublié) un autre logiciel de défrag par hasard ? tu as regardé dans le gestionnaire des services ?

Sinon, à cette clé de registre :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction
qu’a-t-elle à Enable ? Si c’est Y, mets-la à N puis reboot pour voir.

merci bcp, je regarderai la clé de registre, c’est peut-être cela…

En effet, elle a installé un autre programme de defrag, qui est o&o defrag, mais cependant je ne vois pas pourquoi c’est le defrag.exe de windows qui se lance, sinon ce serait oodefrag.exe . D’ailleurs j’avais déjà essayé en le désinstallant completement, mais defrag.exe se lançait toujours, donc ce n’est pas lié.

une idee comme ca en passant…si tu faisais un defrag “normal et complet” que se passe t’il ensuite??? parce que il se peut qu’il veut terminer 1 defrag…(a voir)…@+

Et tu peux ajouter :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OptimalLayout
EnableAutoLayout = 0

et si ca marche pas desactive le service d’indexation

voir :
http://snakefoot.fateback.com/tweak/winnt/tweak.html

hm rien ne marche, ca lance toujours defrag.exe quand on ne touche pas le pc depuis quelques temps… voilà un mystère windowsien particulièrement intense :slight_smile:

Merci à tlm, tout de même!

Tu as fais un scan anti-virus ?
Sinon telecharge TweakUI et desactive la defragmentation du boot…

http://download.microsoft.com/download/whistler/Install/2/WXP/EN-US/TweakUiPowertoySetup.exe

Une autre piste :
Regarde ce que contient la valeur BootExecute de la clé
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

un an plus tard, elle aura fini par changer de disque dur, on a vraiment pas trouvé le problème, lol :slight_smile:

ET ???

Pourquoi tu nous remontes ce vieux topic ???

Pour dire comment s’ést terminé l’histoire, je voulais pas te vexer non plus :slight_smile:

Je n’avais pas vu que c’est toi qui l’avait ouvert !
Désolé ! :wink:

:jap: