Forum Clubic

Comment désactiver le DEP (Prévention Exécution des Données) sur Win XP SP3 ?

Bonjour,

Je cherche à désactiver le fameux DEP sur pc installé en XP PRO SP3 mais rien à faire.
J’ai bien sûr déjà essayé l’astuce (qui fonctionne très bien sur un XP SP2) qui consiste à modifier le fichier boot.ini et à remplacer “/noexecute=OptIn” par “/noexecute=AlwaysOff”.
J’ai ce souci sur 4 pc (tous les 4 sont en XP SP3).

Merci d’avance pour votre aide.

Tu ne peux tout simplement pas désactiver le DEP sur le SP3, d’après ce lien, du moisn pas encore, ça viendra sans doute…
Personnellement, je trouves que le virer sur SP1 ou SP2 est un peu dangereux si un jour un programme malveillant joue au foufou :stuck_out_tongue:
Edité le 03/10/2008 à 19:27

Ce qui est indiqué dans le lien donné par AiMslcK fonctionne aussi avec le SP3.
J’ai essayé /NOEXECUTE=ALWAYSOFF dans le boot.ini et cela désactive bien DEP : l’onglet DEP est alors grisé dans Propriétés Système / Avancé / Performance.
Cela désactive aussi PAE (Extension d’Adresse Physique) qui n’apparait plus dans Propriétés Système / Genéral

Ah ok…Au temps pour moi alors :slight_smile:
Certaisn disent que ça ne fonctionne pas…Et comme je suis sur XP, je ne pouvais pas vérifier

Bonjour,
Alors je viens de refaire un test.
Dans le fichier boot.ini, j’ai supprimé l’option “/NOEXECUTE” puis redémarré.
Ensuite j’ai remis l’option, ce qui donne :

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professionnel" /fastdetect /noexecute=AlwaysOff

Après un reboot, j’ai bel et bien la fenètre “Prévention de l’exécution des données” qui est grisée. Par contre si je lance un *.exe j’ai toujours le message “Fichier ouvert - Avertissement de sécurité”.
C’est à n’y rien comprendre.
D’où ça peut venir d’après vous ?
Merci encore pour votre aide.

J’ai l’impression que le message “Fichier ouvert - Avertissement de sécurité” n’a aucun rapport avec DEP
Fais une recherche dans google avec: Fichier ouvert Avertissement de sécurité

Explique à quel moment ce message apparaît. Qu’est ce que tu fais ?

J’ai déjà fait une recherche mais beaucoup de forums restent sans réponse.
Ce message apparaît au moment où je veux exécuter n’importe quel fichier *.exe localisé sur mon disque dur (sauf pour les programmes déjà installés).
Par ex, si je veux lancer ce fichier : “C:\Driver Sweeper.exe”, j’ai le message suivant qui apparaît :

J’ai la même chose sur mon PC pour les fichiers que je viens de télécharger mais il suffit de décocher la case “Toujours demander avant d’ouvrir ce fichier” pour que la fenêtre n’apparaisse plus.

Ca y est j’ai enfin trouvé dans un forum comment faire. Le problème vient en fait de Firefox 3. Ce que je n’avais pas remarqué, c’est qu’en effet, j’avais ce message seulement sur les fichiers téléchargés avec Firefox.

Donc voici la manip pour ceux que ça intéresse :

  • Dans Firefox, taper “about:config”
  • Dans le filtre, entrer “browser.download.manager.scanWhenDone”
  • Mettre la valeur à False
  • Redémarrer Firefox pour prendre en compte les changements

Il y a donc aucun rapport entre le SP2 ou le SP3 de Windows XP, mais plutôt entre FirefoX 2 et 3.

–> Pb résolu
Edité le 08/10/2008 à 16:15

Effectivement, je n’avais pas remarqué ce changement entre firefox 2 et 3 (faut dire que j’utilise plus souvent Free Download Manager pour télécharger).

Merci pour l’info, j’ai appliqué le remède chez moi aussi.