Forum Clubic

Comment acceder à une partition

Bonjour,

Voila je debute sous linux…
j’ai une partition Windows, une partition en fat32 (qu’on va appelé d:)creer sous windows et le reste c’est pour Mandrake 10.1
Le truc c’est que j’aimerai avoir acces via linux à ma partition en fat32…
Quand je vais dans /mnt, j’ai cdrom - floppy - win_d - windows.
Apparement le repertoire windows correspond à ma partition windows.
Apparement il faut que je monte la partitions (d:) mais je sais pas trop comment faire… surtout qu’il faudrait que je sache à quel hda (1,2,etc…) elle correspond et je sais pas comment faire non plus…
Merci

hd correspond au périphérique ide
le a veut dire le périphérique maitre sur l’interface ide0
hdb signifie esclave sur l’interface ide0

hdc singifie maitre sur ide1
hdd signifie esclave sur ide1

ensuite tu as des numéro, si tu a 3 partition sur l’interface ide0 maitre, tu verra alors
hda1 hda2 hda3

fait un

 cat /etc/fstab 

pr voir comment sont monter tes partitions.

Normalement, mandrake te permet de faire cela facilement. il te suffit de cliquer sur l’icone correspondant.
au pire, lance une console et tape:

 mount /mnt/win_d 

SI tu n’y arrive pas, donne nous le résultat de la commande cat /etc/fstab

le c: d: sont de terme exclusivement windowsien. Tu verra que la methode unix est bien plus logique et évite de se faire de noeud au cerveau pr rien :wink:

la commande /etc/fstab me donne :

/dev/hda6 / ext3 noatime 1 1

/dev/hda8 / home ext3 noatime 1 2

/dev/hdc /mnt/cdrom auto user,iocharset=iso8859–15,codepage=850,noauto,ro,exec,users 0 0

/dev/fd0 /mnt/floppy auto user,iocharset=iso8859–15,codepage=850,noauto,ro,exec,users 0 0

/dev/hda1 /mnt/windows vfat iocharset=iso8859-15,codepage=850 0 0 none /proc proc defaults 0 0

/dev/hda7 swap swap defaults 0 0

Apparement jvois pas l’autre partions win_d pourtant jla voit dans le rep /mnt en tapant la commande ls

tu vois ta partition quand tu fais ls /mnt/win_d, je ne pense pas …

sinon pour la monter, essaie de faire en root :
su -
puis
mount /dev/hda2 /mnt/win_d
puis regarde si c’est bien monté : ls /mnt/win_d

Y@nnos: vérifie que la commande qe te donne weed002 fonctionne. Ensuite on automatisera tout ça en modifiant le fichier de configuration. (Je pense que tu dois povoir le faire depuis les menus ‘configurez votre ordinateur’)

Dsl je m’etait absenté qqe jour.
Bon du coup j’ai reussi à monté la partition en passant par l’outil de config de mandrake.
Par contre cette partition n’est accessible que par le Root…
Comment faire pour la rendre accessible à d’autre utilisateur ?
Merci

chown yonnos.yonnos /mnt/win_d => cela te permet de changer le proprio du repertoires /mnt/win_d

j’ai tapé : chown yann.yann data
data etant le repertoire dont je veux changer les acces.
Ca me mark : changement de proprietaire pour ‘data’ : operation not permitted. pourtant jsuis log en root.
C’est pareil quand j’essaie la commande chmod rien ne bouge…

Bon apres quelque heure voilà où j’en suis :
Droit d’acces à /data : “drwxr–r-- root root”.
J’aimerai la rentre accessible (lecture / ecriture / execution) à tous.
J’ai test la commande : “chmod -v a+wx data” ca me mark : "Le mode d’acces de ‘data’ a été modifié à 0777 (rwxrwxrwx).
Mais quand je fais un ls -l , /data est marké en rwxr–r--, rien n’a changé…
Et quans je fais un cd /data en tant qu’utilisateur autre que root : “permission denied !”

Merci à ceux qui m’aidront ;-p

Ok, le problème vient que tu utilises de la FAT qui ne gère pas les droits.

rajoutes dans le fstab dans la liste des options :
umask=0, user,

Bon ayé j’ai trouvé !
En fait il faut editer le fichier /etc/fstab et remplacé la ligne “/dev/hda5 /data vfat defaults 0 0” par “/dev/hda5 /data vfat noauto,rw,users,exec 0 0”
Voilà ca marche !
Merci à tous :wink:

bravo :jap:

non, les droits sont gérés uniquement au moment du montage, changer les droits des points de montage ne sert à rien

la méthode de v_atekor est la seule correcte

je doute que ce soit la seule solution.

Pourquoi ?
parce qu’il passe par le fstab. A ce que je sache pour monter une partition momentanément on est pas obligé de passer par fstab …

L’autre solution ne serait elle pas ?
chown alex.alex /mnt/win_d && mount /dev/hda1 /mnt/win_d

je viens de te dire que non

la solution c’est[fixed]mount -t vfat -o uid=500 /dev/hda1 /mnt/ton_point_de_montage[/fixed]
ou une autre option du genre, comme gid, umask …
et il ne faut pas oublier le -t, c’est obligatoire pour tout montage qui n’est pas dans le fstab

et le fstab est juste une solution pour automatiser ça, fstab n’est que le fichier de conf de mount …

oki spider, mais désolé de te contredir une nouvelle fois. J’ai une partition sur hda8 qui n’est pas monté automatiquement et qui n’est pas presente ds mon fstab.

Pour la monter, un simple mount /dev/hda8 /mnt/stockage, je n’ai pas besoin de spécifier le type de fichier. Il semblerait que la partition est en ext3, il n’y a pas besoin de specifier

mouais, s’tu l’dis, je te crois, mais il vaut mieux prendre l’habitude de le préciser

théoriquement il détecte tout seul le type (enfin sur une partoche de disque dur, sur une clé usb ou un autre truc “bizarre” du genre je m’avance pas)