Forum Clubic

Certificats SSL invalides sous Firefox 3

Bonjour,
Je viens d’installer Firefox en version 3.0rc2 pour Windows Vista et j’ai un problème très gênant concernant les certificats SSL. En effet, dès qu’un site est sécurisé, je reçois un avertissement comme quoi le certificat est expiré (ce qui n’est normalement pas le cas pour la plupart des sites que je visite, paypal ou ma banque notamment). En effet, la date indiquée d’expiration est souvent en janvier ou mars 2008… Il est dit qu’il peut y avoir une erreur de configuration de l’horloge au niveau du serveur ou quelque chose du genre… j’ai bien évidemment vérifier mon horloge Windows et elle est bien à l’heure. D’où peut venir ce problème ? Je suis obligé de mettre des exceptions pour ces sites et firefox ne les identifie donc pas correctement. Certains même (paypal) ne veulent pas du tout s’afficher.
A part le problème d’expiration, certains semblent être rejetés car auto-signés. Là aussi je ne suis pas certain que tous les sites sécurisés sur lesquels je navigue aient ce problème donc je penche plutôt pour un autre (ou le même) problème de mon côté.

Merci d’avance à ceux qui essaieront de m’aider.
Edité le 15/06/2008 à 12:34

Enormément de sites, même de confiance, ne tiennent pas non plus leurs certificats de sécurité à jour, ce qui génère beaucoup d’alertes sur les navigateurs actuels (« certificat invalide »). Pour qu’elles ne soient plus ignorées à la légère, Firefox 3 présente ses alertes plus clairement. Si l’internaute veut tout de même poursuivre sa connexion vers un site non conforme, le navigateur indique que « Les banques, magasins et autres sites Web publics légitimes ne vous demanderont pas de faire cela »…
ce sont les défauts de la version beta je crois.

Qui ont été corrigés depuis normalement (RC 2 actuellement et sur mon PC). De plus, quand on regarde les screens et vidéos prises de Firefox 3, on ne constate plus aucun problème… Quand je vais sur Paypal, on dirait que les CSS ne sont pas utilisés (jolie page blanche avec le texte un peu n’importe comment). De plus, comme tu le dis, les banques et autres sites “importants” comme ça gardent leur certificat à jour (encore heureux…). Ils se permettraient pas d’en avoir expirés depuis plusieurs mois (comme cela semble être le cas chez moi…). Du coup, je suis quasiment certain que le problème vient de chez moi et non des sites que je visite. Mais malheureusement je vois pas du tout d’où il peut être :confused:

Je ne sais absolument pas pourquoi (je n’ai rien modifié…) mais le problème semble (auto-)résolu.
Firefox 3 semble enfin fonctionner correctement (et mieux encore :-)) et les certificats bien reconnus.

Bon finalement le problème n’est pas réglé et est différent de ce à quoi je m’attendais…

J’ai finalement compris que le problème ne venait absolument pas de Firefox (Opera 9.5 a exactement le même problème…) mais apparemment plutôt de la configuration de ma connexion sur mon ordinateur… En effet, je suis ici (le weekend et les vacances) connecté via une Freebox derrière un routeur Linksys qui distribue Internet par wifi dans toute la maison. Et le problème semble n’avoir lieu qu’ici. Durant la semaine, je suis connecté via un VPN sur le réseau de mon école (Renater surement) et je n’ai alors aucun problème (d’où mon message précédent…).
De plus, les autres ordinateurs de la maison connectés sur le même réseau par wifi n’ont pas ce problème de certificats. Il semblerait donc qu’il y ait un problème dans la façon dont le réseau est configuré sur mon ordinateur ici et qui ferait que tous les certificats que je reçois m’apparaissent comme expirés…
Quelqu’un aurait-il une idée de la cause du problème ? N’hésitez pas à me demander plus d’informations.
Merci d’avance.

P.S. : le sujet n’a plus rien à voir avec Firefox et je modifierais bien le titre et les tags mais il semblerait que je ne puisse pas. S’il faut que je crée un nouveau sujet plutôt que de continuer celui-ci dites-le moi :slight_smile:
Edité le 12/06/2008 à 20:17

Personne n’a la moindre idée ?
Il semblerait que le problème vienne bien de la configuration dans Windows (Vista) de ma connexion. Sous Ubuntu, je n’ai aucun problème de ce genre, quel que soit le navigateur alors que sous Windows je l’ai, quel que soit le navigateur également (idem sous IE 7). J’avoue n’avoir aucune idée de la cause du problème mais j’espère que l’un d’entre vous saura me guider pour fixer ça :slight_smile:

Bon pour la deuxième fois (et j’espère que ce sera la bonne celle-là…) le problème est réglé.
Il semblerait finalement que ce soit l’une des options de sécurité de Kaspersky Antivirus en version 7 qui posait problème (certainement sur l’analyse des communications cryptées). J’ai mis à jour Kasperky vers la version 2009 dans l’après-midi et en ait profité pour revérifié toutes les options. J’ai ainsi désactivé cette analyse des communications cryptées (car comme il y a indiqué, il y a un risque qu’avec cette option activée certains sites web avec certificats SSL posent problème…) et il semblerait que tout soit rentré dans l’ordre.
J’espère ne pas avoir à me rectifier une fois de plus dans les jours qui arrivent…
En attendant, problème résolu !

Merci pour ces infos. Dommage que tu ne puisses pas changer le titre. Tu peux essayer de mettre des tags (certificats SSL, antivirus KAV)
pour qu’on tombe plus facilement sur l’info.

J’ai essayé mais ça ne marche pas non plus :confused:
Peut-être un modérateur qui passerait par là pourrait le faire, comme tu dis ça pourrait peut-être aider quelqu’un d’autre un jour :slight_smile: