Forum Clubic

Caractères spéciaux présents dans le nom d'un fichier remplacés par un code après téléchargement

Bonjour

Lorsque je télécharge un fichier dont le nom comporte des caractères spéciaux (é,è,’,â, …), après téléchargement, ces caractères spéciaux sont remplacés par un code (différent selon le caractère). Exemple

Je veux télécharger le fichier “blé.txt” (pourquoi pas :D)
Après téléchargement, le fichier est sur mon disque dur sous le nom “bl & #002 33.txt”
C’est à dire que le “é” est remplacé par le code “& #002 33”
( & #002 33 étant sans espace, mais je dois mettre des espaces sinon le forum le remplace d’ailleurs pas “é” …)
Comment ça se fait ? Et comment faire pour que le nom du fichier ne soit pas modifié ? (un peu long de renommer à chaque fois)

Merci d’avance
Edité le 27/06/2010 à 23:06

up

Merci pour ta réponse.
Pourrait-on me dire où régler ça ? ^^
J’ai mis UTF 8 dans les options firefox mais ça ne change rien, faut régler ça aussi quelque part dans le panneau de config ?
Edité le 28/06/2010 à 09:30

Ah oui …

Mais il ne s’agit pas de textes là, c’était juste un exemple ça.

C’est lorsque je télécharge un fichier que le nom n’est plus correct. Par exemple si je télécharge un fichier du nom de “blé.avi”, je me retrouve avec un “bl & #002 33.avi” après téléchargement.

Pourtant un ami a essayé de télécharger le même fichier que moi, et il obtenait le fichier avec un nom correct :S

J’ai essayé cet encodage, et également de mettre le même que mon ami, mais aç doit pas venir de là vu que j’ai toujours le problème ;(

Merci tout de même pour ton aide, si t’as d’autres idées n’hésite pas =)

Déjà fait.
Et c’est pas qu’un ordi qui a ce problème : que ce soit mon pc de bureau, mon pc portable, ou le pc a mes parents, j’ai essayé et tous ont ce problème.

A part la connexion, je ne vois pas ce qu’ils ont en commun (à part Avast m’enfin même désactivé j’ai le problème)

Non : mes 2 pc sont sous Windows 64b, et celui de mes parents XP 32 bits