Forum Clubic

Calcul d'heure

bonjour a tous je cherche une facon de calculer mes heure de travail avec un logiciel ou excel.
le seul hic que j’ai quand je prend excel je lui dit que je rentre genre a 23:00 et que je finit a 5:00 il me donne 18 heures de travail… il y a tu une facon de corriger cela ?

merci beaucoup de votre aide

Bonjour,

Le plus simple, mais pas forcément le plus pratique, est de rentrer la date en plus de l’heure.
Un truc du genre 22/02/2011 23:00 et 23/02/2011 05:00.

La solution de Jacky67 est la plus “propre” mais si tu es sûr de ne jamais travailler plus de 24h (on sait jamais :paf: ), tu peux utiliser cette formule :

A1 : heure début
B1 : heure fin
C1 : =SI(B1-A1<0;24+B1-A1;B1-A1)
Edité le 24/02/2011 à 15:12

C’est effectivement une bonne solution, mais je crois qu’il faut mettre 1 au lieu de 24.

La formule pourrait dans ce cas prendre aussi la forme =MOD(1+B1-A1;1)
Edité le 24/02/2011 à 21:42

Je voulais mettre 24:00, mais cela marche aussi avec 1 (ou tout autre nombre entier aussi d’ailleurs).
Ton autre formule est une bonne idée aussi.
Je crois que spider999 a le choix maintenant :d