Forum Clubic

Bureau 3D qui plante mandriva 2007

bonjour
j’ai installé mandriva 2007 sur un portable avec carte graphique nvidia geforce fx 5250
j’ai installé les drivers nvidia suivants NVIDIA-Linux-x86-1.0-9629-pkg1.run
et ai obtenu le logo nvidia au démarrage
mais quand je veux configurer la 3D avec compiz aixgl semble ne pas avoir d’effets alors que xgl m’ouvre une session avec un écran complètement blanc (kde ou gnome)
je dois alors redémarrer à la bourrin pour lancer une session drak3d si je veux réavoir accès à linux (sans effets 3D bureau)
ai je un souci d’incompatibilité ou est-ce que c’est mal configuré?
(pour les effets j’ai essayé d’en décocher mais comme je sais pas ce que c’est je sais pas les effets rééls…)

apparemment aiglx ne fonctionne pas avec les pilotes propriétaires, mais xgl l’est
or c’est lui qui plante en écran blanc
si quelqu’un peut m’aider svp :??:

les pilotes proprios nvidia, à partir de la version 9xxx n’ont besoin ni de XGL (grâce à l’extention ext_texture_from_pixmap) ni de aiglx (cela à toujours été pris en charge grâce au module glx proprio de nvidia)

je sais aussi que les environnements 3D (comme compiz et beryl) savent détecter la version du driver nvidia et agir en conséquence au lancement.

je ne peux pas t’aider plus, désolé :frowning:

Salut,

Tu n’es pas le seul à avoir des problèmes avec drak3d, j’en fait partis aussi, tout comme des centaines de personnes.

Ca me demandait à chaque fois de relancer la session par un “ctrl + ret.arr”, et c’était infini, j’ai donc laissé tomber … :neutre:

Gabe

merci et tant pis alors,
je vais rester avec mon beau linux sans 3D sniff :riva:
bon on va se consoler en disant que ce bureau doit pomper un max de ressources…
tiens je vais peut etre changer mandriva pour damn small linux

comme ça a été dis, installe un driver 9xxx et beryl/compiz.
assure toi d’avoir enlever l’option pour aiglx dans ton xorg.conf et
ajoute ça :
Section “Extensions”
Option “Composite” “Enable”
EndSection
et ça dans la section screen : Option “AddARGBGLXVisuals” “true”
et normalement ça marche sans rien faire de plus. :neutre:

de toute facon, les technos liees au bureau 3D sous linux sont encore en dev lourd et sont loin d’etre stables et finalisees (stables et finalisees au sens linux… pas windows :paf: )

pour l’instant, les devs travaillent principalement sous ubuntu et c’est sur cette distrib que la doc est la plus abondante et que les solutions sont les plus propres et adaptees.
Suse est bien geree aussi car elle a le support de Novell.
Mais le reste, c’est un peu du petit bonheur la chance et ta mesaventure ne m’etonne pas vraiment…

Le mieux est de désinstaler le driver proprio et d’installer la dernière version beta, sinon tu seras obligé d’utiliser xgl pour faire tourner Beryl!
Perso j’ai installé le driver beta 9626 nvidia ainsi que Beryl sur Ubuntu Edgy et tout fonctionne parfaitement! :wink:

ce driver est sortit en version stable 9629 il y a plus d’une semaine maintenant :wink:

ok merci pour les infos je vais tester sous d’autres distribs (suse d’abord puis ubuntu)
:bounce:

Merci pour l’info :jap: :clap:

merci à tous pour vos réponses
en fait c est compiz qui ne marche pas avec ma config
donc avec les driver nvidia 9629 j’ai installé berriz (http://mandriva.beryl-project.org/2007/i586/ prendre tout) en laisssant les effets 3d desactivés
CA MARCHE
YAHOO
merci encore