Forum Clubic

Bug absolument légendaire

Bonjour a tous,

alors voila, plutôt que de faire un ouin-ouin complétement inutile et immature je préfère porter a la connaissance du plus grand nombre du bug que je considère comme le plus légendaire que je connaisse, a savoir: un bug au niveau du son dans crysis (et accessoirement dans bioshock, parce que c’est le même problème).

Alors voila, pour faire cour y a peu de temps steam a mis en promotion crysis + warhead et crysis war, mais le problème et que lorsque j’ai commencer a jouer j’ai remarquer quelque chose de treeeeeees pénible: le son crépitait a un point que ça fait mal au oreilles même si le son est faible, je me dit que ca doit venir du processeur qui sature: que nenni brave gens, car même avec tout les détails au minimum le bug se produit.

après plusieurs heures de recherches infructueuses sur google je commence a désespéré, surtout quand on reagrde ma configuration:

processeur: e8400 dual 3GHz
ram: 3Go DDR3 Corsair
carte son: creative X-Fi titanium
carte graphique: Nvidia Geforce GTX 275
O.S: windows 7

Alors oui c’est peut être pas une config de la mort-qui-tu, mais j’ai remarque que la configuration par défaut est en élever partout, et que avec ou sans le son, j’ai toujours un nombre élever de fps in-game (sauf que quand je retire le son, je n’ai plus ces crépitements insupportables et assourdissants.

alors sinon j’ai fait la petite procédure habituelle de débogage: mise a jour des drivers, défragmentation des fichiers, etc.Sauf que le problème persiste et c’est juste insupportable car plus y a de l’action (a comprendre: plus d’explosions et effets sonores) le problème s’emplifi. sauf que la je sèche, j’ai pas de virus ou aucun autre souci sur ma machine, j’ai plus d’idée, même en baissant la qualité du son du jeu j’ai exactement le même problème(même pas réduit). Alors désoler pour ce post super long (j’aime être clair précis et détaillé :p) et si quelqu’un a une idée je prend xD

p;s: j’ai chercher partout sur le net ET sur ce forum mais n’ayant rien trouver de sérieux j’ai préférer crée ce topic, a savoir que j’ai exactement le même problème sur bioshock.

Je n’ai aucun problème de son dans Bioshock :neutre: as-tu envisagé qu’au lieu d’un “bug légendaire” ça soit ta carte son la responsable ? ce ne serais pas la première Creative a se comporter n’importe comment :stuck_out_tongue:

Et tu dis toi-même que le problème se présente dans plusieurs jeux…
Edité le 19/05/2011 à 00:24

ben le truc c’est que j’ai ce bug que dans 2 jeux et que ça m’empêche carrément de jouer, j’ai fait des tests sur la carte son, aucun problème , d’où le niveau légendaire du bug, aucun moyen de détecter la source du problème, mais vraiment aucun, donc je suis la comme un con avec mes 2 jeux sans pouvoir les finir( et jouer sans son c’est du suicide). :stuck_out_tongue:

Je vois pas ce que ca a de légendaire ^^ Surtout dans crysis qui est gavé de bugs dans les derniers niveaux qui sont carrément d’aventage gamebreaking que ca :wink:

Au hasard le boss araignée qui est 10km au dessus du carrier, le même boss araignée qui fait tomber à 2 FPS ton jeu sans raison, le même boss araignée qui est invulnérable tu sais pas pourquoi, etc etc etc… Le fait que tu puisses aller l’affronter sans avoir ramassé l’arme indispensable pour l’affronter (semble-t-il).

J’ai abandonné le jeu à cause de ca, c’est infaisable avec tous ces bugs (qui se cumulent en plus parfois)…

:hello:

T’a essayé de désactiver les effets sonores ( EAX, 3d… ) ? t’a fait le tour des paramètres sons dans windows ? T’a essayé sans la carte son ? Désactiver la musique dans les jeux ( ça fait ça de moins à gérer ) ?

PS 1 : j’ai pas eu de bugs qui m’ont empêché de jouer dans les Crysis et les Bioshock
PS 2 : je désactive toujours la musique dans les jeux.
PS 3 : sur ma hd4870 il faut que je désactive la sortie son hdmi sinon sa me fait des problèmes. Je sait pas ce qu’il en est chez Nvidia

merci pour les réponses, donc apparemment le vrai truc légendaire c’est surtout que crisys est gavé de bugs , le truc c’est que si je désactive tout sauf les voix j’ai quand meme les craquement , soit je désactive tout les sons soit j’ai le bug(je coupe aussi toujours les musique dans les jeux parce qu’elles sont mal fichus la plupart du temps). même en desactivan,t le eax j’ai le bug sonore et meme en changeant l’accelération audio ca fait pareil (d’ailleurs je remarquer que je peut plus le faire via dxdiag c’est dommage)

aller moi je continu les recherches, on sais jamais :stuck_out_tongue:

Baisser l’acceleration matériel du son dans windows sinon ? Sous XP ca résolvait souvent ce genre de blems…

crysis et surement bioshock utilisent fmodex pour le son

comme les jeux
"
L.A. Noire
Need for Speed: Shift 2 Unleashed
The Sims 3
Real Racing 2
Little Big Planet 2
Crysis 2
Deus Ex: Human Revolution
World of Warcraft: Cataclysm
Mafia 2
Starcraft II : Wings of Liberty
Lara Croft and the Guardian of Light
Alan Wake
Just Cause 2
Transformers: War for Cybertron
Bioshock 2
Dragon Age
Forza 3
Lego Universe
Batman : Arkham Asylum
"
si tu as un de ces jeux qui fonctionne bien , tu peux essayer de remplacer F:\Electronic Arts7\Crytek\Crysis\Bin32\fmodex.dll
et autre fmod*.dll par ceux du jeu qui marche

au mieux cela marche ou change rien , au pire le jeu plante au démarrage :smiley:
, donc sauvegarde les fichiers avant de les remplacer
Edité le 19/05/2011 à 17:47

J’ai aucun bug dans Crysis et Crysis Warhead! :neutre:[quote=“Smoky_toon”]
:hello:

T’a essayé de désactiver les effets sonores ( EAX, 3d… ) ? t’a fait le tour des paramètres sons dans windows ? T’a essayé sans la carte son ? Désactiver la musique dans les jeux ( ça fait ça de moins à gérer ) ?

PS 1 : j’ai pas eu de bugs qui m’ont empêché de jouer dans les Crysis et les Bioshock
PS 2 : je désactive toujours la musique dans les jeux.
PS 3 : sur ma hd4870 il faut que je désactive la sortie son hdmi sinon sa me fait des problèmes. Je sait pas ce qu’il en est chez Nvidia
[/quote]
+1 !

ah pas mal comme idée, surtout que crysis 2 n’as pas de problème de son je vai tester ca, encore merci a tous pour vos réponses, ca fait plaisir ^^

–edit, donc en faite j’ai tester de replacer les fichiers défectueux par les autres et en faite le jeu n’as plus du tout de son :confused: , dommage je sentait bien cette manip mais non, bah y a pas de raison qui es pas de solution :stuck_out_tongue:
Edité le 20/05/2011 à 00:46

ben plus personne?

j’ai pas eu de bug , d’aucune sorte, ni sur crysis ni sur bioshock

tu as quoi d’indiqué dans les log du jeu : F:\Electronic Arts7[u]Crytek\Crysis\LogBackups[/u]

un de mes vieux log a titre de comparaison : (sur win7RC malgré la détection du jeu)
[spoiler]
BackupNameAttachment=" Build(6115) Date(13 Jul 2009) Time(21 05 42)" – used by backup system

Log Started at Monday, July 13, 2009 21:05:42
Running 32 bit version
Executable: F:\Electronic Arts7\Crytek\Crysis\Bin32\Crysis.exe
FileVersion: 1.1.1.6115
ProductVersion: 1.1.1.6115
Using STLport C++ Standard Library implementation

— CPU detection —
Total number of logical processors: 4
Number of available logical processors: 4

Processor 0:
CPU: Intel Intel® Core™2 Quad CPU Q6600 @ 2.40GHz
Family: 6, Model: 15, Stepping: 11
FPU: On-Chip
CPU Speed (estimated): 2400.122293 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 1:
CPU: Intel Intel® Core™2 Quad CPU Q6600 @ 2.40GHz
Family: 6, Model: 15, Stepping: 11
FPU: On-Chip
CPU Speed (estimated): 2400.119727 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 2:
CPU: Intel Intel® Core™2 Quad CPU Q6600 @ 2.40GHz
Family: 6, Model: 15, Stepping: 11
FPU: On-Chip
CPU Speed (estimated): 2400.111268 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 3:
CPU: Intel Intel® Core™2 Quad CPU Q6600 @ 2.40GHz
Family: 6, Model: 15, Stepping: 11
FPU: On-Chip
CPU Speed (estimated): 2400.122238 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Total number of system cores: 4
Number of cores available to process: 4

Windows Vista 64 bit (build 6.0.6000)
System language: French
Windows Directory: “C:\Windows”
Prerequisites…

  • Installation of KB940105 hotfix required: no! (either not needed or already installed)
    Local time is 21:05:42 07/13/09, system running for 21 minutes
    4095MB physical memory installed, 3028MB available, 4095MB virtual memory installed, 26 percent of memory in use
    PageFile usage: 47MB, Working Set: 21MB, Peak PageFile usage: 1796MB,
    Current display mode is 1920x1080x32, (Unknown graphics card)
    IBM enhanced (101/102-key) keyboard and 16+ button mouse installed

Stream Engine Initialization
Network initialization
[net] using iocp socket io management
Physics initialization
MovieSystem initialization
Renderer initialization
Console initialization
Time initialization
Input initialization
Sound initialization
Sound - initializing AudioDevice now!
Sound - starting to initialize Windows Audio Session API output!
Sound - 2 drivers found:
Sound - available drivers: 0 Haut-parleurs (Périphérique High Definition Audio) !
Sound - available drivers: 1 Audio numérique (SPDIF) (Périphérique High Definition Audio) !
Sound - initializing FMOD-EX now!
Sound - initialized FMOD-EX
Sound - available record drivers: 0 Audio numérique (SPDIF) (Périphérique High Definition Audio) !
Sound - using FMOD version: 00040723 and internal 00040723!
Sound - initializing SoundSystem now!
Font initialization
AI initialization
Initializing Animation System
Initializing 3D Engine
Script System Initialization
Entity system initialization
Initializing AI System
[PlayerProfiles] Login of user : First Time Login - Successfully created default profile ‘default’
[PlayerProfiles] Login of user ‘’ successful.
[GameProfiles]: Successfully activated profile ‘default’ for user ‘’
$3r_FSAA = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
$3r_FSAA_samples = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
$3r_FSAA_quality = $60 $5[DUMPTODISK, REQUIRE_APP_RESTART]$4
[GameProfiles]: PlayerProfileManager reported first-time login. Running AutoDetectSpec.
Running machine spec auto detect (32 bit)…

  • Windows Vista 64 bit (build 6.0.6000)
  • System memory
    — 4094 MB
  • Intel® Core™2 Quad CPU Q6600 @ 2.40GHz
    — Number of available cores: 4 (out of 4)
    — Benchmark
    ----- Best time after 3 runs: 686.76 ms
    ----- Time multiplier: 0.57
    ----- Final time: 389.39 ms
    — Rating: CPU class 2
  • ATI Radeon HD 4800 Series (vendor = 0x1002, device = 0x9440)
    — Video memory: 1018 MB
    — Minimum SM 2.0 support: yes
    — DX10 supported: yes
    — Rating: GPU not rated yet!
  • Final rating: Machine class 2[/spoiler]

la partie interressante c’est
Sound initialization
Sound - initializing AudioDevice now!
Sound - starting to initialize Windows Audio Session API output!
Sound - 2 drivers found:
Sound - available drivers: 0 Haut-parleurs (Périphérique High Definition Audio) !
Sound - available drivers: 1 Audio numérique (SPDIF) (Périphérique High Definition Audio) !
Sound - initializing FMOD-EX now!
Sound - initialized FMOD-EX
Sound - available record drivers: 0 Audio numérique (SPDIF) (Périphérique High Definition Audio) !
Sound - using FMOD version: 00040723 and internal 00040723!

tu peux peut etre bricoler le fichier sys_spec_Sound.cfg dans F:\Electronic Arts7\Crytek\Crysis\Game\Config\CVarGroups

mettre le contenu de 1 en haut :

Edité le 21/05/2011 à 15:54

Et t’a essayé de ré-installer DirectX ?

Jamais eu aucun beug dans aucun de ces 2 jeux, a part peut être à la fin, le passage “Ouvrez la porte Nomad !” ou des micro-cut se font sentir …

Bref on s’en fout :paf:

Je met un +1 à Feunoir pour la modif du CVAR. Et tu peux aussi vérifier en clique droit sur l’icone de son/barre des taches - Périphérique de lecture - Clique droit sur ton périphérique en cours - propriétés puis Statistiques avancées. Ici tu configureras l’utilisation que fait Win de ta carte, Taux d’échantillonnage en priorité 16/24 Bit etc etc

Bah doit bien y’avoir un chipset son intégré dans ta carte mère, tu désactives la carte son et tu testes avec le chipset son et tu verras bien ce que ça donne, ça peut aider aussi à définir la source du problème nan?