Forum Clubic

Boot sur clée USB

Bonjour,

Alors voilà mon problème, j’a installé Debian sur une clée USB depuis un ordinateur (pc1) ainsi que GRUB, sur ce même pc il y a déjà un systeme d’exploitation que nous appelerons win :@ bref…
Quand je prends ma clé USB et que je la branche sur un autre ordinateur (pc2) sur lequel se trouve également installé win :@ et que je l’allume il boot sur windows donc je lui dis de booter sur la clée USB et là il me donne un message d’erreur du genre : “error loading operating system”
De plus lorsque j’essaye de demarrer le pc1 sans la clée USB GRUB me donne également un message d’erreur : “Error 21”

Mes questions sont:

  1. Comment faire pour lancer le système d’exploitation qui se trouve sur la clée USB sur le pc2 ?
  2. Comment faire pour que le pc1 accepte de booter sans la clée USB ?
    Edité le 12/09/2008 à 15:20

humm logiquement je dirais qu’il faut que grub soit installé sur la clé usb.
puis, sur les pc1& pc2, il faut que la clé usb soit définie comme périphérique prioritaire vis à vis du 1er disque dur dans l’ordre de boot.
:confused:

C’est le cas, grub est bien installé sur la clée USB (sur debian /boot/grub/ ) et quand je boot dessus depuis le pc2 ça me donne le message d’erreur que j’ai écrit au dessus : “error loading operating system”
Mais ce que je trouve bizard c’est que le pc1 me donne un message d’erreur “grub error 21” lorsque la clée n’est pas branchée.
Je ne connais pas à la perfection le fonctionement de GRUB mais peut etre qu’il s’installe sur tout les OS ce qui lui permetrai de booter dessus et qui expliquerai le message d’erreur…

ama tu à installer grub sur le premier disque dur du PC1 et donc quand ta clé est branchée et que le pc boot il va chercher le fichier de config’ de grub sur [clé usb] /boot/grub mais lorsque la clé n’est pas branchée il n’accède pas à ce fichier et donc te retourne une erreur.

il te faut donc :
installer grub sur le mbr de ta clé usb
ré-installer le mbr de winSALE sur le premier disque dur du PC1
aller dans le bios du pc1 et modifier l’ordre de boot pour placer en premier la clé usb, puis le premier disque dur
aller dans le bios du pc2 et faire la même modif’

tu obiendras donc:
pc1ou2 seul --> boot sur hd1 --> winSALE
pc1ou2 + clé usb --> boot sur clé usb --> choix de boot sur Debian ou winSALE (si modif de /boot/grub/menu.lst ou sinon boot sur Debian seul)

www.gnu.org…
indique pour l’erreur 21 :

:wink:

Tout d’abord merci pour ta réponse très claire !

Ré-installer les mbr windaube sur les hd ça je sais faire.
Là ou je bloque c’est au niveau de la clé usb:
Comment faire pour installer grub sur le MBR de la clé ?
Ou alors que faut-il modifier sur le MBR de la clé ?

Alors voilà ce que j’ai fais :
supprimé grub
installé mbr (paquet debian)
tapé la commande : install-mbr /dev/sda
ré-installé grub
et apres j’ai booté le pc2 sur la clé usb
Maintenant j’ai plus de message d’erreur mais l’ordinateur reste bloqué sur un écran noir avec écris : “MBR 1234F:”
et le curseur qui clignote j’ai attendu 10min mais n’y la clé n’y le pc ne travail :frowning:

Que faire ? :stuck_out_tongue:
Edité le 12/09/2008 à 14:40

Bon ça avance…

J’ai réussi à installer grub sur le mbr de la clé usb : grub-install /dev/sda (hey oui tout bete)
Et je retrouve bien les differents OS présent sur le pc MAIS parce qu’il y a encore un problème…

Lorsque je choisi un systeme (présent sur la clé) dans la liste il me dit “Unknown filesystem…” et encore quand je choisi xp (dans cette meme liste) il le reconnait le comme de l’ext2 …
Biensur inutile de préciser que dans ces deux cas il ne boot pas :@

–help

hum hum :heink:

reprenons clairement:
pc1 et pc2 boot-ils normalement sur winSALE sans la clé usb ?
si * oui déjà le "problème doit se situé uniquement coté clé usb donc le duo grub/debian
donc poste le contenu de /boot/grub/menu.lst

si * non il faut déjà arriver à faire booter les deux ordis avec le lanceur NT
:hello:

Woops désolé pour le retard mais je fais ça à mon boulo et le week-end c’est sacré :stuck_out_tongue:

Alors, le pc2 boot normalement sans la clé mais pas le pc1.
Je pense qu’avec une disquette de démarage ça devrait résoudre le problème mais après j’aurai auccun moyen de booter sur ma clé donc je préfere regler ça dans un second temps.

Voici moi menu.lst :

menu.lst - See: grub(8), info grub, update-grub(8)

grub-install(8), grub-floppy(8),

grub-md5-crypt, /usr/share/doc/grub

and /usr/share/doc/grub-doc/.

default num

Set the default entry to the entry number NUM. Numbering starts from 0, and

the entry number 0 is the default if the command is not used.

You can specify ‘saved’ instead of a number. In this case, the default entry

is the entry saved with the command ‘savedefault’.

WARNING: If you are using dmraid do not change this entry to ‘saved’ or your

array will desync and will not let you boot your system.

default 0

timeout sec

Set a timeout, in SEC seconds, before automatically booting the default entry

(normally the first entry defined).

timeout 15

Pretty colours

color cyan/blue white/blue

password [’–md5’] passwd

If used in the first section of a menu file, disable all interactive editing

control (menu entry editor and command-line) and entries protected by the

command ‘lock’

e.g. password topsecret

password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

password topsecret

examples

title Windows 95/98/NT/2000

root (hd0,0)

makeactive

chainloader +1

title Linux

root (hd0,1)

kernel /vmlinuz root=/dev/hda2 ro

Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

BEGIN AUTOMAGIC KERNELS LIST

lines between the AUTOMAGIC KERNELS LIST markers will be modified

by the debian update-grub script except for the default options below

DO NOT UNCOMMENT THEM, Just edit them to your needs

## Start Default Options

default kernel options

default kernel options for automagic boot options

If you want special options for specific kernels use kopt_x_y_z

where x.y.z is kernel version. Minor versions can be omitted.

e.g. kopt=root=/dev/hda1 ro

kopt_2_6_8=root=/dev/hdc1 ro

kopt_2_6_8_2_686=root=/dev/hdc2 ro

kopt=root=/dev/sda1 ro

default grub root device

e.g. groot=(hd0,0)

groot=(hd1,0)

should update-grub create alternative automagic boot options

e.g. alternative=true

alternative=false

alternative=true

should update-grub lock alternative automagic boot options

e.g. lockalternative=true

lockalternative=false

lockalternative=false

#e.g. lockold=false

lockold=true

additional options to use with the default boot option, but not with the

alternatives

e.g. defoptions=vga=791 resume=/dev/hda5

defoptions=

should update-grub lock old automagic boot options

e# lockold=false

Xen hypervisor options to use with the default Xen boot option

xenhopt=

Xen Linux kernel options to use with the default Xen boot option

xenkopt=console=tty0

altoption boot targets option

multiple altoptions lines are allowed

e.g. altoptions=(extra menu suffix) extra boot options

altoptions=(single-user) single

altoptions=(single-user mode) single

controls how many kernels should be put into the menu.lst

only counts the first occurence of a kernel, not the

alternative kernel options

e.g. howmany=all

howmany=7

howmany=all

should update-grub create memtest86 boot option

e.g. memtest86=true

memtest86=false

memtest86=true

should update-grub adjust the value of the default booted system

can be true or false

updatedefaultentry=false

## End Default Options

title Debian GNU/Linux, kernel 2.6.18-6-686-bigmem
root (hd1,0)
kernel /boot/vmlinuz-2.6.18-6-686-bigmem root=/dev/sda1 ro
initrd /boot/initrd.img-2.6.18-6-686-bigmem
savedefault

title Debian GNU/Linux, kernel 2.6.18-6-686-bigmem (single-user mode)
root (hd1,0)
kernel /boot/vmlinuz-2.6.18-6-686-bigmem root=/dev/sda1 ro single
initrd /boot/initrd.img-2.6.18-6-686-bigmem
savedefault

title Debian GNU/Linux, kernel 2.6.18-6-686
root (hd1,0)
kernel /boot/vmlinuz-2.6.18-6-686 root=/dev/sda1 ro
initrd /boot/initrd.img-2.6.18-6-686
savedefault

title Debian GNU/Linux, kernel 2.6.18-6-686 (single-user mode)
root (hd1,0)
kernel /boot/vmlinuz-2.6.18-6-686 root=/dev/sda1 ro single
initrd /boot/initrd.img-2.6.18-6-686
savedefault

END DEBIAN AUTOMAGIC KERNELS LIST

This is a divider, added to separate the menu items below from the Debian

ones.

title Other operating systems:
root

This entry automatically added by the Debian installer for a non-linux OS

on /dev/hda1

title Microsoft Windows XP Professionnel
root (hd0,0)
savedefault
makeactive
chainloader +1

C’est bon j’ai réussi !

En fait quand je boot sur la clé usb c’est le hd0 et non pas le hd1 donc j’ai remplacé tout les (hd1,0) par (hd0,0) et ça work !
L’inverse pour windaube (hd0,0) en (hd1,0)

Voilà j’espere que ça pourra servir à d’autres

:clap: