Forum Clubic

"blanc" dans ajout/suppression de programmes

Slt, j’ai remarqué que dans la fenêtre ajout/suppression de programme, j’ai un “blanc” qui apparait, et comme un dessin vaut mieux qu’un long discours, voici une capture:
http://julien.remen.free.fr/goodies/Image2.bmp

Est-ce que qqu’un sait comment se débarraser de ça??

Merci d’avance

salut,
l’url a un probleme

Le i est en majuscule dans le nom de fichier, et pas dans l’url … :frowning:
Voici l’image, et j’avou ne pas comprendre même en voyant, d’où provient le problème.
http://julien.remen.free.fr/goodies/Image2.bmp

Bah, tu trouves pas ça bizarre la partie grise: pas de nom de soft, pas de bouton pour installer désinstaller, et la taille que ça prend?!? Regarde un peu l’ascenseur de la fenêtre, tu comprendras mieux…

oui anormal et pas qu’un peu!
l’ascenseur est tout petit

il y a déja eu un topic sur celà - je m’en souviens, par contre la date , je ne m’en souviens plus du tout, même de l’année - et quel mots entrer ?

Je vais essayer de trouver ça
Lance quelques recherches de ton côté

bon, j’ai retrouvé le topic ( dec 2004)
“caracteres bizarres dans ajout/suppr de programmes”
http://forum.clubic.com/forum2.php?config=clubic.inc&post=36661&cat=19&cache=&sondage=0&owntopic=0&p=1&trash=0&subcat=0

sa liste Ajout occupait 9 copyscreens! … outch

ça avait l’air de se produire derrière le N pour son cas, mais nous n’avons pas trouvé la cause.

Il va falloir s’orienter vers une recherche WEb judicieuse
Cherchons

Arg, ça commence mal!!

M’enfin, je vais pas me faire avoir pas WinXP :smiley:

Si si, des fois c’est lui qui gagne :smiley:
Je vais chercher ( pas eu trop le temps là, mais bon)

j’ai trouvé quelque chose parlant de ce probleme, sur le site de Kelly’s
http://www.kellys-korner-xp.com/xp_a.htm#ws
Add or Remove - White Space

This is generally due to the DisplayIcon having a negative number. From here you can either remove the negative number or remove the last application listed: Start/Run/Regedit: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{}

Ce serait dû à la non possibilité d’afficher l’icone de l’application . Essaye de localiser la dernière appli installée et supprime-là dans la clé indiquée . Ce serait logiquement celle située derrière la bonne .

Waouw, la tu m’étonnes, je pensais pas obtenir une réponse concrète aussi rapidement!!!

Par contre, je pense pas que le pb vienne de la dernière appli installé, car entre temps j’ai fais pas mal de truc sur le PC, donc l’idée serait de localiser la clé qui possède une clé d’icone négative :??:

Bon, on va y aller!!

Merci en tout cas :jap:

salut,
comment trouver l’appli qui a une clé d’icône négative ?
Je n’en ai pas trouvé…

bonsoir ,

Je m’ étais aussi posé la question : ou est ce ‘DisplayIcon’ ?.
Je n’ai trouvé que récemment:

en fait le probleme évoqué dans le site de Kelly ( MVP Microsoft) est vraiment relatif à AutoCad et/ou Autodesk

Ce fameux DisplayIcon est un paramètre qu’on voit dans la panneau droit de Regedit pour les clés Uninstall de type Classe-Id ( les clé {8-4-4-4-12}

En l’occurence, la classe-id fautive est : {5783F2D7-0065-0409-0000-0060B0CE6BBA}

Panneau de droite, on a donc:

DisplayIcon REG_SZ C:\Program Files\AutoCAD LT 2000i\aclt.exe,-1
c’est le -1 de droite qui serait fautif

d’ailleurs ,le correspondant ecris ensuite:

"Changing the registry key data from “…aclt.exe,-1” to “…aclt.exe,1” for
the AutoCAD LT entry was the solution. Thanks for the post, Wes. "

il a résolu le probleme en changeant le -1 en 1

Tout est expliqué ici, en anglais, avec les explications de Kelly :

http://www.windowsforumz.com/modules.php?name=Forums&file=viewtopic&t=202370&ex=Configuration%20Manage-Add-Remove-Programs-List-

A ce que j’ai également compris, les 2 patchs proposés par Kelly modifient les caractéristiques de cette valeur DisplayIcon fautive
pour la changer comme ceci:
DisplayIcon REG_EXPAND_SZ %systemroot%\web\acad.ico
ou comme ceci
DisplayIcon REG_EXPAND_SZ %systemroot%\web\autocad.ico

Le patch a aussi naturellement mis en place auparavant les fichiers .ico dans le dossier %systemroot%\web\

Comme ça, plus d’index négatif!

J’avoue que c’est :pt1cable:

Salut Mike27
je n’ai pas acad mais je pense que mon problème vient de “firefox” qui est masqué alors que l’install de fileZilla apparait dans ajout suppr.

Je vais tenter d’appliquer ton patch à firefox
je vous tiens au courant

@+

Je reviens pour confirmer que je ne trouve pas firefox à l’endroit indiqué alors que je trouve fileZilla.

Comme il m’est impossible de désintaller ce…je vire toutes les occurences de firefox dans la bdr et sur le dd et je vois ce que cela donne.
re re moi
En voulant le virer je me suis aperçu qu’e mozilla firefox était bien dans
hhlm_software/ms/windows/current version/uninstall et que le N° de son icône est positif

Quel est donc ce logiciel que j’aurais installé et qui se trouve entre filezilla et firefox???

re @+

j’ai eu un truc comme ca quand j’avias comptine (un compteur internet, a l’époque du 56K :D) si j’avais la réponse alors…
une fois encore Bravo Mike :jap:

:frowning:
je ne trouve pas

Peut-être faut-il créer un clisd mais ça je ne sais pas faire…
Alors s’il y avait un logiciel…
à+

up svp

=> banco10

je ne sais pas quoi te dire de plus si tu as vérifié toutes les clés sous HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

Une remarque:
pour mon UnInstall de AD-Aware SE Personal, j’ai:
E:\AD-AWA~1\Ad-Aware.exe,-0
on voit donc qu’un signe négatif -0 semble bon aussi , car je n’ai pas de probleme de lignes blanches dans Ajout/Suppression de programme

Par contre, un -1 … ne semble pas logique : ces références 0,1,2 etc pointent -je pense- dans la liste des icones qui est elle-même rangée à l’intérieur de l’exe. Les exe ont différentes zones dont la zone des icones. 0 est le 1er, 1 le 2ème etc

Pour ce qui est de faire sois-même une classe-id : non
C’est à l’installation de l’application que tout ceci est monté , enregistré un peu partout , et ce n’est pas à nous -utilisateur- de se lancer la-dedans

Pour ce qui est du site de Kelly : elle a bien l’air de dire que ce probleme ne s’applique que si AutoDesk et/ou AutoCad est installé , et que c’est dans ces applis que la modif est à faire.

Ou alors, il y aurait encore une autre cause possible pas facile à trouver :frowning:

:stuck_out_tongue: Résolu!!!

c’était ce bourrin de fileprot [:banco10] qui s’était planqué.
J’ai supprimé le prog manuellement et tout viré dans la bdr y compris le vxd.

Si cela vous arrive
L’appli en cause se situe entre la dernière aplli visible au-dessus du masque et la première en-dessous
Cliquer sur “afficher par nom” en haut à droite

Méthode bourrin
Lister les aplli installées sur l’ordi

1 sauvegarde de la bdr
2 tenter de désinstaller le (dernier) fichier installé dont le nom succède immédiatement a la dernière appli visible
en général il faut le foutre à la poubelle.
3 aller dans la bdr et virer toutes les occurences de ce fichier.

Si le fichier est iportant utiliser hklm/…uxninstalllll:
!!!les noms des applis peuvent débuter par celui du concepteur ou de l’organisation (Mozilla Firefox ok Firefox = o)

:pt1cable:

[:ezeckiel2k]
nos posts se sont croisés à 5 secondes près

Good :smiley:

Problème résolu, j’ai effectué une recherche dichotomique de la clé fautive, donc tout est rentré dans l’ordre. Par contre, impossible de savoir à quoi correspondait cette clé… M’enfin, je me la garde sous le bras au cas où…